Bluetooth window flashes between "No Bluetooth adapters available" and "No devices found"

I recently replaced my motherboard and CPU, moving the disks without reinstalling the OS; everything was working fine, and since this MB has bluetooth functionality I tried it out and worked perfectly for a few weeks.
During the last month, I can’t tell when exactly, bluetooth stopped working and now contiuously flashes between “No Bluetooth adapters available” and “No devices found”.
I tried reinstalling pulseaudio-bluetooth, bluez and bluez-libs but it didn’t help.
Looking online I couldn’t find someone with a similar problem.

To note that I’m a beginner Linux user, and I rely almost entirely on the add/remove software manager built into Manjaro.

These are my system information:

Operating System: Manjaro Linux
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 5.10.164-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 20 × 13th Gen Intel® Core™ i5-13600K
Memory: 31,1 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: Z690 AORUS PRO
System Version: -CF