Bluetooth Turns On Automatically After Reboot!

After reboot bluetooth turns on automatically. I have edited /etc/bluetooth/main.conf and uncommented AutoEnable=false. But didn’t work and disabling bluetooth.service isn’t a proper solution.
I am on Manjaro Gnome with kernal 5.15 & it an intel wifi 6 card with wifi 6 and bluetooth 5.0. Laptop is Hp Omen 15 2020 (Ryzen 5 4600H & Gtx 1660 Ti).

Edit: Problem is caused by TLP.

I think that is the proper solution. Which command you followed?

sudo systemctl disable bluetooth.service # disables service from loading at boot
systemctl status bluetooth.service # verify that service got disabled
sudo systemctl mask bluetooth.service # if you really want it dead so other services can't start it again

This disables the service from loading in the background. So I can not turn bluetooth on from the gui, gnome-control-centre. I have to manually enable the service 1st and then turn bluetooth on or off.

I just did a clean install & the problem is not there. After reboot Bluetooth stays off. Don’t know what fixed the issue. Did absolutely nothing. Everything just works fine now after a clean install.

I can confirm this problem is causing because of TLP
Without tlp everything is just fine…with tlp enabled I am exhibiting the same behaviour as before. Bluetooth is being turned on automatically at start up.

Edit the file /etc/default/tlp and change RESTORE_DEVICE_STATE_ON_STARTUP=0 to RESTORE_DEVICE_STATE_ON_STARTUP=1.

Also make sure the file contains DEVICES_TO_DISABLE_ON_STARTUP="bluetooth" .

1 Like

This solved the issue. It was in /etc/tlp.conf

Thnx

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.