Bluetooth stopped working

Hi and I hope I am at the right place here:
I checked out all forum posts and the wiki already and I somehow cannot find a solution therefore I had to create an account. Sorry if this is something simple I just overlooked or so…

I set up the AutoEnable feature a few weeks ago and after the recent manjaro update I was pretty happy about my bt keyboard finally working as intended.

Today, it all stopped working and I do not know why.

I followed the wiki regarding the grub settings (bluetoothctl:_No_default_controller_available) because I somehow managed to start the service at some point but I had no controller set up, still nothing though.

bluez and bluez-utils are installed.

~ >>> sudo pacman -S bluez bluez-utils
~ >>> rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

~ >>> systemctl restart bluetooth.service
~ >>> systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: inactive (dead)
        Docs: man:bluetoothd(8)
Apr 22 21:22:27 rq-workstation systemd[1]: Condition check resulted in Bluetooth service being skipped.
~ >>> modprobe -c | grep blue
    alias acpi*:TOS6205:* toshiba_bluetooth
    alias net_pf_31 bluetooth
    alias of:N*T*Cmediatek,mt7622_bluetooth btmtkuart
    alias of:N*T*Cmediatek,mt7622_bluetoothC* btmtkuart
    alias of:N*T*Cmediatek,mt7663u_bluetooth btmtkuart
    alias of:N*T*Cmediatek,mt7663u_bluetoothC* btmtkuart
    alias of:N*T*Cmediatek,mt7668u_bluetooth btmtkuart
    alias of:N*T*Cmediatek,mt7668u_bluetoothC* btmtkuart
    alias of:N*T*Cmotorola,cpcap_led_blue leds_cpcap
    alias of:N*T*Cmotorola,cpcap_led_blueC* leds_cpcap
    alias of:N*T*Cnokia,h4p_bluetooth hci_nokia
    alias of:N*T*Cnokia,h4p_bluetoothC* hci_nokia
    alias pcmcia:m*c*f*fn*pfn*pa0A0736ECpb24E6DFABpc*pd* bluecard_cs
    alias pcmcia:m*c*f*fn*pfn*paBAF16FBFpb657CC15Epc*pd* bluecard_cs
    alias pcmcia:m*c*f*fn*pfn*paE3987764pb2524B59Cpc*pd* bluecard_cs
    alias symbol:__hci_cmd_send bluetooth
    alias symbol:__hci_cmd_sync bluetooth
    alias symbol:__hci_cmd_sync_ev bluetooth
    alias symbol:baswap bluetooth
    alias symbol:bt_accept_dequeue bluetooth
    alias symbol:bt_accept_enqueue bluetooth
    alias symbol:bt_accept_unlink bluetooth
    alias symbol:bt_debugfs bluetooth
    alias symbol:bt_err bluetooth
    alias symbol:bt_err_ratelimited bluetooth
    alias symbol:bt_info bluetooth
    alias symbol:bt_procfs_cleanup bluetooth
    alias symbol:bt_procfs_init bluetooth
    alias symbol:bt_sock_ioctl bluetooth
    alias symbol:bt_sock_link bluetooth
    alias symbol:bt_sock_poll bluetooth
    alias symbol:bt_sock_reclassify_lock bluetooth
    alias symbol:bt_sock_recvmsg bluetooth
    alias symbol:bt_sock_register bluetooth
    alias symbol:bt_sock_stream_recvmsg bluetooth
    alias symbol:bt_sock_unlink bluetooth
    alias symbol:bt_sock_unregister bluetooth
    alias symbol:bt_sock_wait_ready bluetooth
    alias symbol:bt_sock_wait_state bluetooth
    alias symbol:bt_to_errno bluetooth
    alias symbol:bt_warn bluetooth
    alias symbol:bt_warn_ratelimited bluetooth
    alias symbol:hci_alloc_dev bluetooth
    alias symbol:hci_cmd_sync bluetooth
    alias symbol:hci_conn_check_secure bluetooth
    alias symbol:hci_conn_security bluetooth
    alias symbol:hci_conn_switch_role bluetooth
    alias symbol:hci_free_dev bluetooth
    alias symbol:hci_get_route bluetooth
    alias symbol:hci_mgmt_chan_register bluetooth
    alias symbol:hci_mgmt_chan_unregister bluetooth
    alias symbol:hci_recv_diag bluetooth
    alias symbol:hci_recv_frame bluetooth
    alias symbol:hci_register_cb bluetooth
    alias symbol:hci_register_dev bluetooth
    alias symbol:hci_reset_dev bluetooth
    alias symbol:hci_resume_dev bluetooth
    alias symbol:hci_set_fw_info bluetooth
    alias symbol:hci_set_hw_info bluetooth
    alias symbol:hci_suspend_dev bluetooth
    alias symbol:hci_unregister_cb bluetooth
    alias symbol:hci_unregister_dev bluetooth
    alias symbol:l2cap_add_psm bluetooth
    alias symbol:l2cap_chan_close bluetooth
    alias symbol:l2cap_chan_connect bluetooth
    alias symbol:l2cap_chan_create bluetooth
    alias symbol:l2cap_chan_del bluetooth
    alias symbol:l2cap_chan_list bluetooth
    alias symbol:l2cap_chan_put bluetooth
    alias symbol:l2cap_chan_send bluetooth
    alias symbol:l2cap_chan_set_defaults bluetooth
    alias symbol:l2cap_conn_get bluetooth
    alias symbol:l2cap_conn_put bluetooth
    alias symbol:l2cap_is_socket bluetooth
    alias symbol:l2cap_register_user bluetooth
    alias symbol:l2cap_unregister_user bluetooth
~ >>> bluetoothctl                                                                                                                                     
Waiting to connect to bluetoothd...

Also tried the following as suggested in another topic…

~ >>> sudo pacman -Qqn | sudo pacman -S -

Also I cannot connect any Gamepads via USB anymore. Feels like something f*ed up my mainboard controller or so. I dunno…

I hope somebody can help me.

btusb module does not load on startup.
Loading the module and starting the service gives me the following status:

~ >>> systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-23 19:24:30 CEST; 3s ago
       Docs: man:bluetoothd(8)
   Main PID: 10880 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38428)
     Memory: 724.0K
     CGroup: /system.slice/bluetooth.service
             └─10880 /usr/lib/bluetooth/bluetoothd

Apr 23 19:24:30 rq-workstation systemd[1]: Starting Bluetooth service...
Apr 23 19:24:30 rq-workstation bluetoothd[10880]: Bluetooth daemon 5.58
Apr 23 19:24:30 rq-workstation bluetoothd[10880]: src/main.c:check_config() Unknown group Controller in /etc/bluetooth/main.conf
Apr 23 19:24:30 rq-workstation systemd[1]: Started Bluetooth service.
Apr 23 19:24:30 rq-workstation bluetoothd[10880]: Starting SDP server
Apr 23 19:24:30 rq-workstation bluetoothd[10880]: Bluetooth management interface 1.19 initialized

But no controller is available:

~ >>> bluetoothctl show
No default controller available

That sould look like this:

rfkill list
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no

Well, except the yes as my Bluetooth is disabled right now :grin: but as you didn’t post an

inxi --admin --verbosity=7 --filter --no-host --width

I can only conclude with the information being given that your Bluetooth device is dead


Sorry, I didn’t check back for a while :man_shrugging:
It looks like my bluetooth controller kicked the bucket. I tried a few other distros and even found an old windows hard drive and none of them were able to detect bluetooth on my mb.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.