Bluetooth services

I have Plasma 5.24, and I want to share the GPS from my phone to my laptop. I downloaded an app on my phone, and it says to enable the Serial Port service, but I can’t find that option in the Bluetooth app. A guide says to use blueman, but I want to use the default app. Is there any way I can do this. Any help will be appreciated.

i have had nonstop issues with bluetooth. i dont know if its my hardware or if its software. It worked a couple months ago. One day it just didnt. In kde settings it says its disabled but clicking enable does nothing. trying to enable/reload the bt service does nothing. tries to search for devices sometimes but never finds. on linux515 and linux 519

not a good combination
a guide describing the process
to insist on using an app that is different and you don’t know how to use …

where is that guide, btw? :wink:

so you have the KDE equivalent of that Blueman app
which I don’t know because I do not have KDE
but it is likely pretty similar.

The guide is

I do not know the KDE bluetooth app (Bluedevil)

maybe this helps:

Bluetooth - ArchWiki

from the guide:

a) Simply pair Your phone with linux.

seems easy enough

b) Run ShareGPS with bluetooth sharing enabled.

is a matter of your app on the phone (I guess)

c) Then choose in blueman interface Device → Settings.

If ShareGPS works with “USE Bluetooth” enabled You should find “Serial Port” over there.

that is where it might be slightly different
but it is probably “findable” by looking for rfcomm or serial adapter or something like it
in the available settings menus

I do not know it.

Yes, thanks for reminding me of that. I would have used it, but unfortunately it is deprecated.

that does not mean you can’t use it, though

see the link to the Arch wiki - that section I linked to
and other places


from the AUR

Yes, I could do that, but now we’re drifting off-topic. My original question was can you do this with the default Bluetooth app?

I cannot answer that question.
If blueman can do it, bluedevil likely can as well.
But my installation of blueman is “contaminated” - because I simply chose to get the tools I need some time ago
(I replaced bluez-utils with bluez-utils-compat)

that guide you found is probably old enough to be from a time where rfcomm was still part of the regular bluez-utils,
was not yet “depreciated”

… perhaps this helps you to locate what you need:
in blueman it can be configured under Extensions → SerialManager

the following written some time later:

I do know that there is a bluetooth related rfcomm kernel module which comes with every standard kernel.
So you do have that.

The rfcomm from bluez-utils-compat is likely just a command line tool by the same name and may not be needed.

The mention of it might have mislead both me and you.

you do have the rfcomm kernel module - the capability
you do not have the (depreciated) rfcomm command line tool - but you probably don’t need it

I couldn’t find any option like that in bluedevil.

Ok, I tried blueman, but when I couldn’t connect to the serial port. It errored out with “Connection Failed: Connection failed with reason: bt-failed”.

try to use kernel 5.4 or even better 4.19 lts. every kernel like 5.10 and higher are a piece of crap if it’s related to bluetooth. the malfunctions with these kernels are annoying and disappointing.

That’s odd. Don’t newer kernels have more bugfixes and aren’t they better?

not in this case. they frickled around bluetooth and now it’s a desaster. this whole “optimizing” of bluetooth did a mess.

I guess I’ll file a feature request at KDE and report a bug to the kernel developers. Thanks for your help anyway :slight_smile:.

after what he said
and what I could find out
without personally checking out the capabilities of bluedevil
(just looked at online available documentation …)
I now very much doubt that bluedevil (as opposed to blueman)
actually includes the feature that is wanted and needed here.

… nothing to do with different kernels - they all include the rfcomm module for serial communication

@geodic you’ll probably have to bite the bullet and install the depreciated (but very much working) tools
or use something other than bluedevil :wink:

Actually, bluez deprecated the command line tools. It seems for those functions it switched to a DBus interface, so bluedevil should be able to do it (Of course considering that the function actually works :wink: ). As I said in the previous post, I’ll file a feature request at KDE.

… right
but then there would need to be a function (in bluedevil)
which is supposed to do that - but is not working …
But there does not appear to even be one
which suggests to me that this functionality was not even intended to be implemented.

it’s not just not working - it’s not even there

but go ahead and see how they respond