Bluetooth on Manjaro Gnome Doesn't Work

Hey again @kagetora13!

Thanks for getting back to me. That’s very interesting and I’m going to looking that thread. Honestly, I’m not knowledgeable enough to know if we should be looking for an official bug here.What makes you think that is the case?

It could be something I have done. Let me check the thread and perhaps other folks with comment on this tread.

EDIT: Understandably, I don’t know how to downgrade packages :sweat_smile:

@clarkkozak @The_Quantum_Alpha

I was looking through the Arch bug database and I noticed the below defect which describes after successfully pairing with the bluetoothctl command that after a reboot and trying to re-use that device the person could not re-connect (unless they re-paired). In my case this is what is happening to me. Ofcourse I an using the 5.4.67-1-MANJARO LTS.

FS#68346 : [linux] bluetooth device drops after sleep or reboot)

You will see that I can use bluetoothctl to connect to my headphones with correct audio settings once I manually trust the device. If I don’t trust it will thing the headphones are a keyboard.

@clarkkozak Clark can you try the below routine which exercises the bluetooth functionality of your device? Note I captured the output of when i ran it to show my bluetooth fuctionality.

I hope you updated your Bios too!

(1) Start bluetoothctl and verify that your bluetooth controller turns on.

bluetoothctl 
Agent registered
[CHG] Controller DC:53:60:4A:00:5A Pairable: yes

(2) Check paired devices to see if anything is registered.

[EDIFIER W830BT]#paired-devices
Device 5C:C6:E9:18:5D:4E EDIFIER W830BT
[EDIFIER W830BT]# info
Device 5C:C6:E9:18:5D:4E (public)
Name: EDIFIER W830BT
Alias: EDIFIER W830BT
Class: 0x00240404
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)

(3) Shut off Bluetooth Radio and makes sure it shuts down cleanly.

[EDIFIER W830BT]# power off
[CHG] Device 5C:C6:E9:18:5D:4E ServicesResolved: no
[CHG] Device 5C:C6:E9:18:5D:4E Connected: no
Changing power off succeeded
[CHG] Controller DC:53:60:4A:00:5A Powered: no
[CHG] Controller DC:53:60:4A:00:5A Discovering: no
[CHG] Controller DC:53:60:4A:00:5A Class: 0x00000000

(4) Turn in Bluetooth Radio and make sure it starts cleanly.

[bluetooth]# power on
Changing power on succeeded
[CHG] Controller DC:53:60:4A:00:5A Powered: yes
[CHG] Device 5C:C6:E9:18:5D:4E Connected: yes
[CHG] Device 5C:C6:E9:18:5D:4E UUIDs: 00001108-0000-1000-8000-00805f9b34fb

(5) Run paired device command to list all paired devices.

[EDIFIER W830BT]# paired-devices
Device 5C:C6:E9:18:5D:4E EDIFIER W830BT

(6) Connect to Paired Devices.

[EDIFIER W830BT]# connect 5C:C6:E9:18:5D:4E
Attempting to connect to 5C:C6:E9:18:5D:4E
Connection successful

(7) Turn on Bluetooth scanning to see if you see other bluetooth devices to pair.

[EDIFIER W830BT]# scan on
Discovery started
[CHG] Controller DC:53:60:4A:00:5A Discovering: yes
[NEW] Device 71:CE:B8:B7:5C:91 71-CE-B8-B7-5C-91
[NEW] Device 5C:F9:38:BF:BF:EC 5C-F9-38-BF-BF-EC
[NEW] Device FF:FF:1A:01:CD:7F HTZM
[NEW] Device FF:FF:3A:00:EE:E4 HTZM
[NEW] Device C8:69:CD:D9:0C:9B C8-69-CD-D9-0C-9B

(8) Turn off Bluetooth scanning.

[EDIFIER W830BT]# scan off
Discovery stopped

Hi again!

I really appreciate your engagement. I’m updating my bios this weekend. In the meantime, bluetoothctl hangs

~ $ bluetoothctl
Waiting to connect to bluetoothd...

I noticed on a cold boot the Bluetooth is sometimes not in a good state. So can you reboot and have a second go? Thanks.

Still no good :confused:

~ $ bluetoothctl 
Waiting to connect to bluetoothd...
~ $ uptime
 19:43:44 up 0 min,  1 user,  load average: 2.15, 0.63, 0.21

Is bluetooth activated in BIOS??

@clarkkozak @GaVenga

The Bluetooth radio issue that Clark is seeing (where you can’t connect to it when starting ‘bluetoothctl’ is also reproducible by me as well.

In my case it happens on:

(1) Cold boot.

(2) Gnome Settings > Bluetooth will indicate Bluetooth is not turned on.

(3) Go to terminal and run ‘bluetoothctl’ and it will not be able to find the bluetooth radio.

(4) Reboot the laptop and then I will See Bluetooth is turned on in “Gnome Settings > Bluetooth” will be turned on and I will see the different bluetooth devices in the air.

(5) Go to terminal and run 'bluetoothctl" and then I will get:

bluetoothctl
Agent registered
[CHG] Controller DC:53:60:4A:00:5A Pairable: yes

(6) I can then power on and off the radio. This is what I was trying to help Clark do.

[bluetooth]# power off
Changing power off succeeded
[CHG] Controller DC:53:60:4A:00:5A Powered: no
[CHG] Controller DC:53:60:4A:00:5A Discovering: no
[CHG] Controller DC:53:60:4A:00:5A Class: 0x00000000
[DEL] Device E6:95:68:8E:59:9F E6-95-68-8E-59-9F
[DEL] Device 51:AF:D1:C8:74:A3 51-AF-D1-C8-74-A3
[DEL] Device F6:8C:BE:CA:D9:FA N09YF
[DEL] Device FF:FF:1A:01:CD:7F HTZM
[DEL] Device 69:C1:26:F2:72:FC 69-C1-26-F2-72-FC
[DEL] Device 5D:1F:C6:A1:8C:CA 5D-1F-C6-A1-8C-CA
[DEL] Device D1:23:68:81:3D:D5 N01CM
[DEL] Device 1B:FB:46:3F:59:42 1B-FB-46-3F-59-42
[DEL] Device 5C:F9:38:BF:BF:EC 5C-F9-38-BF-BF-EC
[DEL] Device C0:28:8D:91:5F:57 C0-28-8D-91-5F-57

[bluetooth]# power on
Changing power on succeeded
[CHG] Controller DC:53:60:4A:00:5A Powered: yes

So as long as Clarke and I are both on the same Kernel 5.4.67-1 then I thought we would have the same symptoms. So yeah this is a frustrating but definitely a real issue. Perhaps hard for some people to picture it unless your in front of the laptop.

So three issues I can see:

(a) Bluetooth Radio does not always start in a good state from cold boot (need reboot to be able to see the bluetooth radio.

(b) Paired Bluetooth headphones fail to connect after reboot (current work around is to put headphones in pairing mode or use bluetoothctl to trust the device so it connects.

© Bluetooth Headphones will be mis-detected as a headset and only allow mono sound.

https://bugs.archlinux.org/task/53903?string=bluetooth&project=1&type[0]=&sev[0]=&pri[0]=&due[0]=&reported[0]=&cat[0]=&status[0]=open&percent[0]=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

So perhaps some retailers are going to lose out on some black friday headphone sales.

Some more bugs on Bluetooth:
https://bugs.archlinux.org/index.php?string=bluetooth&project=1&type%5B%5D=&sev%5B%5D=&pri%5B%5D=&due%5B%5D=&reported%5B%5D=&cat%5B%5D=&status%5B%5D=open&percent%5B%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=&do=index

Anything but!

I just updated my BIOS to see if that does have any effect.

Machine:   Type: Laptop System: LENOVO product: 20BVCTO1WW v: ThinkPad T450 serial: <filter> 
           Mobo: LENOVO model: 20BVCTO1WW v: SDK0E50512 STD serial: <filter> UEFI [Legacy]: LENOVO 
           v: JBET73WW (1.37 ) date: 08/14/2019 

Still have the issues with cold boots though as @kagetora13 pointed up.

I ran these commands:

sudo modprobe btusb
systemctl start bluetooth

And it worked here! First time ever! Here’s the output.

Update:

I rebooted my computer and I tried again. Now the device I previous connected to is not discoverable :thinking:

Well sounds like we are half way there (till we get a fix upstream).

So after I have paired my headphones the first time and reboot I also cannot re-connect to my paired device using Gnome Bluetooth tool. It will connect and disconnect in 1 second.

I end up using the bluetoothctl terminal command to connect to the device. Its important to make sure you use the ‘trust’ command in bluetoothctl to trust the bluetooth device.

**(To be clear, this is just a work around till the fix comes from upstream. The expectation is that once a device is paired it will automatically connect again between reboots\sessions. **

I just did the latest stable update for manjaro (release 11/4/2020) and bluetooth seems to be working better.

Suggest forgetting all bluetooth devices, update, reboot, then test.

Oooo thank you! I’ll give it a shoot and report back

@kagetora13

Experiencing the same problem after updating:

Generated on 2020-11-18 15:58:1605740289

#################### inxi -Fxzc0 ########################

System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.1 
           Distro: Manjaro Linux 
~ $ bluetooth
bluetooth = on
~ $ bluetoothctl 
Waiting to connect to bluetoothd...
# CTRL-D out of endless waiting
~ $ sudo modprobe btusb
[sudo] password for clark: 
~ $ bluetoothctl 
Agent registered

Then, I can use bluetooth-manger’s GUI to connect my bluetooth device.

It’s strange that I have to do sudo modprobe btusb each time I want to use a bluetooth devices after booting.

Sounds like we are still both seeing the bluetooth radio not start dependably in Linux (100% in Windows 10). Sometimes these kind of issues get my goat. With my T430s and x230 the past 6 months the 5ghz wifi radio would connect but then would not resolve DNS\web site URLs unless I rebooted or switch to the 2.4GHZ band. 2.4 Ghz worked 100%. These are the issues which wear us down and we end up going to another operating system. Technically I left Ubuntu 3 years ago because of flaky wifi. Maybe someone up there is telling me hey how about trying Mac OS. We know MAC OS will not work with your wifi … but get a wifi dongle and you are set. LOL.

XD LOL yep! I feel similarly. Luckily this isn’t a deal breaker for me and I can happily go without bluetooth as I preferred wired headphones either (except for a quiet movie. Then I would love to use my bluetooth speaker because my laptop is old and doesn’t have great speakers). Perhaps one day I’ll learn enough about Manjaro / Linux / Gnome that I’ll be able to fix the problem myself. At this time, I can only relay what I am experiencing.

Update:

Still not working perfect. Using the workaround provided above, I created an alias in my .bashrc file.

alias fix-bluetooth='sudo modprobe btusb'

Any time I want to use bluetooth, I run this then go to the gui bluetooth manager.

I got a new SSD this week and I did a fresh install of the latest Manjaro Gnome:

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.2 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20BVCTO1WW v: ThinkPad T450 serial: <filter> 

It seems that the native Gnome Bluetooth system now works! Marking this as solved.