Bluetooth not working (Failed to start Bluetooth service)

I am unable to activate Bluetooth on my laptop, and whenever I turn the laptop off, it shows the following error:

[FAILED] Failed to start Bluetooth service.

I tried the following, but it did not seem to work;

systemctl restart bluetoothd
Failed to restart bluetoothd.service: Unit bluetoothd.service not found.

I had a similar behaviour in the past, which seemed to be linked to the bluetooth quick connect gnome extension. Disabling that extension seemed to fix it, but now I don’t have that extension installed any more, so i don’t know if the errors are linked.

Here is my System Information:

 ✘  ~  inxi --admin --verbosity=7 --filter --width
  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=e980b863-ca1f-4e22-bb6b-665a19ddff2d rw quiet apparmor=1
    security=apparmor resume=UUID=3a5c48ea-fa12-4147-b57e-4dbdb9d07104
  Desktop: GNOME v: 41.4 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Timi product: TM1701 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Timi model: TM1701 v: MP serial: <superuser required> UEFI: INSYDE
    v: XMAKB5R0P0502 date: 10/13/2017
  ID-1: BAT0 charge: 21.5 Wh (52.1%) condition: 41.3/60.0 Wh (68.8%)
    volts: 7.3 min: 7.6 model: SUNWODA R15B01W type: Li-ion serial: <filter>
    status: discharging
  RAM: total: 7.65 GiB used: 4.63 GiB (60.5%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 712 high: 800 min/max: 400/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 700 3: 700 4: 700
    5: 700 6: 700 7: 700 8: 700 bogomips: 32012
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Xiaomi driver: i915 v: kernel
    ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:5917 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Xiaomi Mi Notebook Pro
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:1d12 class-ID: 0302
  Device-3: Chicony XiaoMi USB 2.0 Webcam type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 04f2:b59a class-ID: 0e02
  Display: x11 server: X.Org v: compositor: gnome-shell driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0747 built: 2017 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Xiaomi
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-5:2 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 1 state: down
    bt-service: enabled rfk-block: hardware: no software: no address: N/A
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 704.24 GiB used: 376.43 GiB (53.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: Extreme Pro 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 101200RL temp: 44.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung
    model: MZVLW256HEHP-00000 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: CXB7401Q temp: 28.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 456.66 GiB size: 448.5 GiB (98.21%)
    used: 376.43 GiB (83.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: e980b863-ca1f-4e22-bb6b-665a19ddff2d
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 316 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 592C-3652
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
    uuid: 3a5c48ea-fa12-4147-b57e-4dbdb9d07104
  ID-1: /dev/nvme1n1p1 maj-min: 259:5 size: 499 MiB fs: ntfs label: N/A
    uuid: A68E15988E15625B
  ID-2: /dev/nvme1n1p2 maj-min: 259:6 size: 100 MiB fs: vfat label: N/A
    uuid: A27D-5F71
  ID-3: /dev/nvme1n1p3 maj-min: 259:7 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/nvme1n1p4 maj-min: 259:8 size: 237.87 GiB fs: ntfs label: N/A
    uuid: 40AE7F22AE7F0FA0
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-2: 1-6:3 info: Chicony XiaoMi USB 2.0 Webcam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b59a class-ID: 0e02
  Device-3: 1-7:4 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-4: 1-8:5 info: Elan Micro ELAN:Fingerprint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04f3:0c1a class-ID: 0000
  Device-5: 1-9:6 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 40.0 C pch: 33.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 315 Uptime: 18m wakeups: 2 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 2320 pacman: 2228 lib: 521
  flatpak: 73 snap: 19 Shell: fish v: 3.3.1 default: Zsh v: 5.8.1
  running-in: gjs inxi: 3.3.14

you need sudo to run it
sudo systemctl restart bluetoothd

And if you type it correctly
systemctl start bluetooth
gives you the same error?

The binary is bluetoothd but the service is bluetooth.service and the service should start automatically when the bluetooth USB device is connected.

gives me exactly the same output:

sudo systemctl restart bluetooth.serivce
Failed to restart bluetooth.serivce.service: Unit bluetooth.serivce.service not found.

It gives me this error:

systemctl start bluetooth
Job for bluetooth.service failed because the control process exited with error code.
See "systemctl status bluetooth.service" and "journalctl -xeu bluetooth.service" for details.

So I tried to look at systemctl status bluetooth.service with this output:

systemctl status bluetooth.service
× bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
    Drop-In: /etc/systemd/system/bluetooth.service.d
     Active: failed (Result: exit-code) since Mon 2022-04-04 12:38:22 CEST; 1min 1s ago
       Docs: man:bluetoothd(8)
    Process: 8204 ExecStart=/usr/libexec/bluetooth/bluetoothd -E none (code=exited, status=203/EXEC)
   Main PID: 8204 (code=exited, status=203/EXEC)
        CPU: 40ms

Apr 04 12:38:22   systemd[1]: Starting Bluetooth service...
Apr 04 12:38:22   systemd[8204]: bluetooth.service: Failed to locate executable /usr/libexec/bluetooth/bluetoothd: No such file or directory
Apr 04 12:38:22   systemd[8204]: bluetooth.service: Failed at step EXEC spawning /usr/libexec/bluetooth/bluetoothd: No such file or directory
Apr 04 12:38:22   systemd[1]: bluetooth.service: Main process exited, code=exited, status=203/EXEC
Apr 04 12:38:22   systemd[1]: bluetooth.service: Failed with result 'exit-code'.
Apr 04 12:38:22   systemd[1]: Failed to start Bluetooth service.

Throughout this thread, you mistyped the command a lot of times, the actual command is

sudo systemctl restart bluetooth

Your last post tells you that the executable /usr/libexec/bluetooth/bluetoothd doesn’t exists.
Did you modify anything from any config file? This file is not in any repo:

$ LANG=C pamac search --files /usr/libexec/bluetooth/bluetoothd
No package owns /usr/libexec/bluetooth/bluetoothd

And it should be in /usr/lib/bluetooth/bluetoothd which is provided by bluez.

1 Like

Just for information systemctl doesn’t need sudo anymore (if it ever needed it) it will ask for password when needed

Have you installed bluez ?

I enabled experimental features in bluez according to this guide on the github page of gnome bluetooth quick connect

It looks to me like that has deleted the executable.

I reversed that process and now Bluetooth seems to be working again.
Even though that executable is still missing

Yes I have.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.