Bluetooth not working ( Bluetooth failed to set mode: Failed (0x03) )

I’ve been having this very weird and annoying issue with my laptop’s bluetooth, and I just can’t pinpoint what’s causing it.

I have no problems when I open the Blueman manager, but when I try to search for new devices, a red bar at the bottom of the window appears saying “Resource Not Ready…”. If I ask for more information, a window with the following information appears:

Resource Not Ready
Traceback (most recent call lat):
File “/usr/lib/python3.9/site-packages/blueman/bluez/”, line 78, in callback
value = proxy.call_finish(result).unpack()
gi.repository.GLib.GError: g-io-error-quark:
GDBus.Error:org.bluez.Error.NotREady: Resource Not REady (36)

I can enable/disable bluetooth with the command “bluetooth power on” or by interacting with the system tray icon, however, if I try to power it on with bluetoothctl I get the following error:

[errantoverflow@ErrOvflw-manjaro ~]$ sudo bluetoothctl
Agent registered
[CHG] Controller D4:D2:52:81:39:71 Pairable: yes
[bluetooth]# power on
Failed to set power on: org.bluez.Error.Busy

I’ve tried to restart any bluetooth related services with systemctl:

[errantoverflow@ErrOvflw-manjaro ~]$ sudo systemctl restart bluetooth
[errantoverflow@ErrOvflw-manjaro ~]$ sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-07-28 23:45:26 CEST; 32s ago
       Docs: man:bluetoothd(8)
   Main PID: 13677 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19002)
     Memory: 892.0K
        CPU: 17ms
     CGroup: /system.slice/bluetooth.service
             └─13677 /usr/lib/bluetooth/bluetoothd

jul 28 23:45:26 ErrOvflw-manjaro systemd[1]: Starting Bluetooth service...
jul 28 23:45:26 ErrOvflw-manjaro bluetoothd[13677]: Bluetooth daemon 5.60
jul 28 23:45:26 ErrOvflw-manjaro systemd[1]: Started Bluetooth service.
jul 28 23:45:26 ErrOvflw-manjaro bluetoothd[13677]: Starting SDP server
jul 28 23:45:26 ErrOvflw-manjaro bluetoothd[13677]: Bluetooth management interface 1.19 initialized
jul 28 23:45:26 ErrOvflw-manjaro bluetoothd[13677]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSink/sbc
jul 28 23:45:26 ErrOvflw-manjaro bluetoothd[13677]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/sbc
jul 28 23:45:29 ErrOvflw-manjaro bluetoothd[13677]: Failed to set mode: Failed (0x03)

I’ve also tried to unblock it with rfkill, but it was never blocked from the beginning:

[errantoverflow@ErrOvflw-manjaro ~]$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
[errantoverflow@ErrOvflw-manjaro ~]$ sudo rfkill unblock bluetooth

I’ve reinstalled bluez, bluez-libs, bluez-utils, blueman, pulseaudio-bluetooth several times, and sometimes if I do that, after restarting, it will work, however, whenever I turn off bluetooth it stops working.

Weirdest thing is that I would turn on bluetooth, connect my ps4 controller, play a bit, and when I turn off bluetooth, the controller is still on, so I have to turn bluetooth on and off twice.

I hope I did a decent job explaining myself, and I would greatly appreciate any help!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Does this issue also manifest itself when you cold boot into Manjaro?


Thanks a lot, although it looks like in the end that won’t be necessary! After doing more research, I found this arch post that said it had to do with tlp. I did just as @momu said, I first listed my USB devices with lsusb:

$ lsusb
Bus 002 Device 002: ID 0bc2:ab26 Seagate RSS LLC Backup Plus Slim Portable Drive 1 TB
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0b05:1866 ASUSTek Computer, Inc. N-KEY Device
Bus 001 Device 004: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 002: ID 258a:1007 SINOWEALTH Ozone NEON X40
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And after that, I simply edited “/etc/tlp.conf” by adding the following line right below the comment:

#USB_BLACKLIST="1111:2222 3333:4444"

I am not sure if this has 100% fixed the issue, but I’ve been using Bluetooth the past 2 days, turning it on and off, connecting multiple devices just to see if something would break, and so far I’ve had no problems.

Also, I am sorry for not posting enough information, I don’t know how I missed the pinned post, but don’t worry, I will make sure to post the right information next time. Thanks for your help either ways!

1 Like

Well, this is awkward . . . looks like it wasn’t fixed after all. After a few days, the issue came back. I’ll dump some info, hopefully we can find what’s causing this.

[errantoverflow@ErrOvflw-manjaro ~]$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.13.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=d9238cea-2bb8-4d29-9507-f2ff6f424cca rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: ASUSTeK product: ROG Strix G531GU_G531GU v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: G531GU v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: G531GU.309 date: 04/29/2020 
  ID-1: BAT0 charge: 55.8 Wh (98.9%) condition: 56.4/66.0 Wh (85.4%) 
  volts: 15.7 min: 15.7 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A 
  status: Not charging 
  RAM: total: 15.48 GiB used: 2.65 GiB (17.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 12 MiB bogomips: 62431 
  Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK 
  driver: nvidia v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:2191 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting,nvidia display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.57.02 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.8-1-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.19 running: no 
  Sound Server-4: PulseAudio v: 15.0 running: yes 
  Sound Server-5: PipeWire v: 0.3.33 running: no 
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel 
  port: 5000 bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 2.73 TiB used: 353.79 GiB (12.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P2SSD8 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: P2CR033 temp: 30.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LX001-1RG174 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 664.9 GiB size: 653.46 GiB (98.28%) 
  used: 291.01 GiB (44.5%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 
  label: N/A uuid: d9238cea-2bb8-4d29-9507-f2ff6f424cca 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: N/A uuid: CEC6-AA50 
  ID-3: /mnt/2TB_Firecuda raw-size: 1.82 TiB size: 1.79 TiB (98.37%) 
  used: 62.76 GiB (3.4%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 264d61bd-dfe4-4f54-b99a-a2c5c93146ec 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A 
  uuid: 1df1f593-d4a0-440d-8463-2b13376ab51b 
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 250 GiB fs: ntfs label: N/A 
  uuid: 9CB0C7F9B0C7D842 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 508 MiB fs: ntfs label: N/A 
  uuid: BEFE66A7FE665823 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: SINOWEALTH Ozone NEON X40 type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 480mA chip-ID: 258a:1007 class-ID: 0301 
  Device-2: 1-3:3 info: Microdia USB DEVICE type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 400mA chip-ID: 0c45:7664 class-ID: 0301 
  Device-3: 1-8:4 info: ASUSTek N-KEY Device type: Keyboard 
  driver: asus,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 0b05:1866 class-ID: 0301 
  Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 8087:0aaa class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): cpu: 2500 
  Processes: 292 Uptime: 5m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1421 lib: 428 flatpak: 0 
  Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06 

Regarding that cold boot part, the issue goes away after 1 or 2 restarts, but it’s not guaranteed :thinking:

Seems like the latest update to blueman fixed it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.