Bluetooth: "no default controller available", Intel version command failed (-110) after update

Hey everyone,

I need some help figuring out how to get the OS to discover the bluetooth controller. It is visible using lsusb but for some reason it is not visible using bluetoothctl. It has worked fine in the past and does not work since updating. I tried different kernels (6.1, 6.2, 5.15) but the issue persists.

lsusb | grep -i bluetooth                                                     
Bus 005 Device 005: ID 8087:0025 Intel Corp. Wireless-AC 9260 Bluetooth Adapter
sudo systemctl status bluetooth                                                                                                                          ξ‚² βœ”  
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Wed 2023-04-12 21:02:09 CEST; 3min 59s ago
       Docs: man:bluetoothd(8)
   Main PID: 1440 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38394)
     Memory: 2.3M
        CPU: 16ms
     CGroup: /system.slice/bluetooth.service
             └─1440 /usr/lib/bluetooth/bluetoothd

Apr 12 21:02:09 ms7b85 systemd[1]: Starting Bluetooth service...
Apr 12 21:02:09 ms7b85 (uetoothd)[1440]: ConfigurationDirectory 'bluetooth' already exists but the mode is different. (File system: 755 ConfigurationDirectoryMode: 555)
Apr 12 21:02:09 ms7b85 bluetoothd[1440]: Bluetooth daemon 5.66
Apr 12 21:02:09 ms7b85 bluetoothd[1440]: Starting SDP server
Apr 12 21:02:09 ms7b85 systemd[1]: Started Bluetooth service.
Apr 12 21:02:09 ms7b85 bluetoothd[1440]: Bluetooth management interface 1.21 initialized
sudo dmesg | grep -i bluetooth                                                                                                                                                    
[    5.490785] Bluetooth: Core ver 2.22
[    5.490802] NET: Registered PF_BLUETOOTH protocol family
[    5.490803] Bluetooth: HCI device and connection manager initialized
[    5.490806] Bluetooth: HCI socket layer initialized
[    5.490808] Bluetooth: L2CAP socket layer initialized
[    5.490809] Bluetooth: SCO socket layer initialized
[    5.901444] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.901446] Bluetooth: BNEP filters: protocol multicast
[    5.901448] Bluetooth: BNEP socket layer initialized
[    7.704346] Bluetooth: hci0: Reading Intel version command failed (-110)
[    7.704346] Bluetooth: hci0: command 0xfc05 tx timeout
Agent registered
[bluetooth]# scan on
No default controller available
[bluetooth]# list

Any help would be very much appreciated, thanks!

1 Like

Hi @codenob, welcome to the forum!

Could you try the following?

sudo rmmod btusb
sudo modprobe btusb

Already tried that as well as

rmmod btintel
modprobe btintel

Both did not work

Have you tried shutting down your computer, waiting a couple of minutes, and restarting?

There are known hardware issues with Bluebooth in certain machines which are generally solved with power cycling the Bluetooth. Restarting the machine isn’t enough for this to occur.

Yes, the issue persists even if the computer was shut down for hours before turning it back on. I will try power cycling it a few times later though to be safe.

I just tried to revert back to kernel 5.10 and there Bluetooth seems to work fine. After switching to 6.2 this still works. I think this is a kernel bug (215167 – Bluetooth: hci0: command 0xfc05 tx timeout) but for now this seems to be a workaround.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.