Bluetooth mouse (Tecknet BM308) connection error

Using Manjaro Linux 20.1.1 (Mikah) with kernel version 5.4.64-1, on a ThinkPad T460, with i3wm as my window manager.

I have a bluetooth mouse (Tecknet BM308) which is discoverable and pairs with my machine, but does not “connect” and hence cannot be used. Through the blueman app, I receive one of two errors each time I try to connect:

  • Connection failed: Input/output error
  • Connection failed: Protocol not supported

I have been able to get the mouse to work on e.g Ubuntu 18.04, so I know that it’s functional. I have been able to connect wireless headphones via bluetooth, so I don’t think there is a hardware issue on that end.

I’ve looked through the forum at related issues but the problems are not quite the same. Has anyone had any experience with this issue, or even better, found a fix?

1 Like

:+1: Welcome to Manjaro! :+1:

Ubuntu 18.04 comes with kernel version 4.18 so have you tried installing kernel 4.19 yet using the Manjaro kernel GUI or the mhwd-kernel cli?

(try removing and pairing it your mouse on 4.19 and then rebooting back into 5.4: That might work too. If not, stay on 4.19 and file a bug with the kernel team or wait until someone else does)

:scream:

Thanks for your answer!

In fact, I was previously using 4.19 on this machine a year ago, and I now recall the mouse working back then – slipped my mind.

Indeed, reverting to 4.19, the mouse automatically paired and worked fine. I switched back to 5.4 and unfortunately the error remains.

I’ll have a look at filing a bug report or seeing if anyone else has reported the issue. It never occurred to me that the kernel update broke this, though I guess this should have been one of the first checks. Thanks again.

1 Like

@nonreligious Did you read latest update #announcements for your branch before updating?

Update: After a system upgrade and another restart, the machine is now running kernel 5.4.67-1, and the mouse again connects and works.

1 Like