Bluetooth Mouse randomly disconnects

I’m sorry because the only stable Real-time kernel is 5.4, and as you said anything prior to 5.5 is bad, I’m all out of ideas!



1 Like

I’m also having a similar problem lately with my bluetooth headphones. They seem to disconnect randomly while watching a video or listening to music, and it is really annoying.

I’m on kernel 5.9 btw.

That one is EOL, so upgrade to 5.10 LTS (Long Time support) or 5.4 LTS if the 5.10 doesn’t solve your issue…


I’m also experiencing bluetooth speaker randomly disconnecting but automatically reconnects.

OP never came back whether 5.4 LTS or 5.10 LTS solved the issue for him/her/other.

So did you try that out yet?


Up this, have the same problem with bluetooth headphones no matter the kernel (tried 5.9,10,11)

Edit: here’s my info:

  Kernel: 5.10.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=9f999d06-e924-4157-8621-cce32c64f4c3 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: LightDM 1.30.0, SDDM Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: AB350-Gaming v: N/A serial: <filter> 
  Mobo: Gigabyte model: AB350-Gaming-CF serial: <filter> 
  UEFI: American Megatrends v: F50a date: 11/27/2019 
  RAM: total: 15.64 GiB used: 4.19 GiB (26.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001138 L2 cache: 3 MiB 
  bogomips: 76672 
  Speed: 1363 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 1363 2: 2547 3: 1374 4: 1366 5: 1362 6: 2051 7: 1364 8: 1372 9: 1373 
  10: 2152 11: 1360 12: 1703 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 09:00.0 
  chip ID: 1002:731f class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: DisplayPort-1 res: 1920x1080 dpi: 90 size: 544x303mm (21.4x11.9") 
  diag: 623mm (24.5") 
  Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 476x268mm (18.7x10.6") diag: 546mm (21.5") 
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0 5.10.19-1-MANJARO 
  LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 09:00.1 chip ID: 1002:ab38 class ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 0b:00.3 chip ID: 1022:1457 class ID: 0403 
  Device-3: Microsoft LifeCam HD-3000 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 3-1:2 chip ID: 045e:0779 class ID: 0102 
  Sound Server: ALSA v: k5.10.19-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus ID: 04:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 
  bus ID: 05:00.0 chip ID: 8086:2723 class ID: 0280 
  IF: wlp5s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus ID: 1-7:3 
  chip ID: 8087:0029 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Message: No RAID data was found. 
  Local Storage: total: 3.87 TiB used: 161.53 GiB (4.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 3B7QCXE7 temp: 36.9 C 
  scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
  ID-4: /dev/sde maj-min: 8:64 type: USB vendor: Toshiba model: MQ04UBD200 
  size: 1.82 TiB block size: physical: 512 B logical: 512 B rotation: 5400 rpm 
  serial: <filter> scheme: MBR 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 50.02 GiB size: 48.99 GiB (97.93%) used: 39.46 GiB (80.5%) 
  fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A 
  uuid: 9f999d06-e924-4157-8621-cce32c64f4c3 
  ID-2: /boot/efi raw size: 99 MiB size: 95 MiB (95.96%) 
  used: 25.3 MiB (26.6%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 5401-DA0E 
  ID-3: /home raw size: 931.51 GiB size: 915.82 GiB (98.31%) 
  used: 122.05 GiB (13.3%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A 
  uuid: 226ed7c0-ffac-4077-b9b7-dcfb2ff5f114 
  ID-4: /run/timeshift/backup raw size: 50.02 GiB size: <superuser required> 
  used: <superuser required> fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 
  label: N/A uuid: 9f999d06-e924-4157-8621-cce32c64f4c3 
  Alert: No Swap data was found. 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 499 MiB fs: ntfs label: N/A 
  uuid: 520279E40279CE0B 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 182.26 GiB fs: ntfs label: N/A 
  uuid: 6840031A4002EF1E 
  ID-4: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: ntfs 
  label: Riservato per il sistema uuid: 00183E97183E8BA2 
  ID-5: /dev/sda2 maj-min: 8:2 size: 930.97 GiB fs: ntfs label: N/A 
  ID-6: /dev/sda3 maj-min: 8:3 size: 450 MiB fs: ntfs label: N/A 
  uuid: BA56B62C56B5E971 
  ID-7: /dev/sde1 maj-min: 8:65 size: 1.82 TiB fs: ntfs label: TOSHIBA EXT 
  uuid: 8CF67907F678F336 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 12 Mb/s 
  chip ID: 05e3:0610 class ID: 0900 
  Device-1: 1-7:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 class ID: e001 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Device-1: 2-1:2 info: Toshiba America External USB 3.0 type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s chip ID: 0480:0901 
  class ID: 0806 serial: <filter> 
  Hub-4: 2-2:3 info: Genesys Logic USB3.1 Hub ports: 4 rev: 3.1 speed: 5 Gb/s 
  chip ID: 05e3:0626 class ID: 0900 
  Device-1: 2-2.4:4 info: Genesys Logic SD Card Reader and Writer 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s 
  chip ID: 05e3:0749 class ID: 0806 serial: <filter> 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 3-1:2 info: Microsoft LifeCam HD-3000 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 045e:0779 class ID: 0102 
  Device-2: 3-2:3 info: Corsair M65 Gaming Mouse type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 1b1c:1b05 class ID: 0300 
  Device-3: 3-3:4 info: Logitech G413 Gaming Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c33a class ID: 0300 serial: <filter> 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 40.9 C mobo: N/A gpu: amdgpu temp: 56.0 C 
  mem: 70.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 348 Uptime: 5h 04m wakeups: 0 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: 1505 pacman: 1500 lib: 485 flatpak: 0 
  snap: 5 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.3.01

When trying kernels, look here first:

so try 5.4 LTS as that has been an LTS kernel for far longer than 5.10.

(and then feed back, please?)

1 Like

i’m testing on 5.4 right now gonna let you know! Also noob question (i’m still pretty new to all this linux thing) going back to an older kernel won’t downgrage my drivers? Or they are bound to the majaro updates and not the kernel ones?

I was using 5.10 when this issue started happening. I think it started when the stable update that had the changes to the nvidia drivers came out. I’m not sure. I’m now on 5.11 and it’s still happening. Haven’t tried 5.4 though because I have some things that work better with 5.10 or above.

Another weird thing about this bug is when I’m playing a game and I have say spotify running, so there’s 2 different audio sources, and I have them both going to my earphones. In the background I have the bluetooth speaker connected but again I have both audio sources going to my earphones, so no audio coming out of the bluetooth speaker. Suddenly, out of no where, the bluetooth speaker disconnects, automatically connects, takes away the game audio, but for some reason the spotify audio is still going to my earphones. So the spotify audio is coming out of my earphones, the game audio is coming out of the bluetooth speaker. Even if I only have the bluetooth speaker running, it will randomly disconnect and reconnect.

so 3 hours in and it seems like everything is working as intended, installing 5.4 solved the problem

1 Like

It’s not an older kernel it’s an LTS kernel.

Please read this:

especially the section “Linux has multiple kernels”

also read Alessio’s post above cc @wildcard

FYI there is a bug right now with AX200/AX201 chipset bluetooth modules. See for more info. Downgrading linux-firmware seems to help, according to the arch forum

1 Like

Thank you, very useful resource!

1 Like

for me the problem still is the same.
On Kernel 5.4 my machine won’t boot at all.
The other versions all give me the behaviour as written in the first post.
Have tried a different BT Mouse with the same result.
All the same hardware still works fine under Win10, as this is a dual boot setup.

I can try a different Linux fron a live version in the next days.
But thanks for into it!


There are variants of this issue floating around in the internet, especially on the Arch forums. It looks like the blast radius is pretty large.

Here, it’s claimed that the root cause is a bug in bluez, which was patched 2 days ago.

Question to Manjaro devs: how can we get this patch in the quickest way? This is impacting a lot of us.

  • if it’s been patched in Arch, it’ll take 1-2 weeks before showing up in stable.
  • Having said the above, the devs don’t commit to timelines as they’ll release when it’s ready (I.E. out of testing)
  • If you want patches faster, subscribe to the testing branch (but that’s not stable so you could switch now and then switch back to stable once the issue gets releesed to stable)


I don’t think even testing has it yet. We need Bluez to officially release a new version, no?

I just got confirmation from ArchLinux folks that the patch in question made it into bluez 5.56-2. The current version in Manjaro is 5.56-1. Hopefully this will be fixed soon in the next update.

edit: 5.56-2 already in Manjaro unstable.

1 Like

By the way, while we are waiting for the real fix, I noticed that downgrading linux-firmware makes the disconnects much less frequent for me.

pamac install downgrade

sudo DOWNGRADE_FROM_ALA=1 downgrade linux-firmware

I went with the last version from 2020, which seems to work fine.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.