Bluetooth mouse not seen or pairing

It’s a Logitech MX Master 3, and worked on a previous install. The blue tooth keyboard works fine, so it is not the blue tooth (I don’t think) - is there something that has changed with the latest updates to XFCE to cause this?

Cannot find much at Logitech either. If the keyboard did not work then I could troubleshoot the blue tooth, but it does work

no-one else experiencing this?

Double checked and the mouse pairs to the windows tablet I have. So its not the mouse.

The Bluetooth adaptor picks up the keyboard, my wifes phone, even the bloody TV !! But not the mouse…

Are there specific Logitech drivers to ensure the mouse works? It worked straight away with a previous manjaro install…

Well yep, lots of help here, obviously no one uses blue tooth mice much…now I am forced to buy a new mouse that is wi-fi or wired simply because this BT detector does not work! Well it selectively works, on everything in the house EXCEPT the mouse!

I even tried different kernels with no result.

Did you try to use tips from ArchWiki?

Thanks, I did look at the Arch wiki…but gave up after about halfway as I could not find directly related info…thanks for highlighting that section with the link - solution might be there…

Nope, none of that did anything, mostly as the commands were not recognised, used deprecated commands, and or gave errors in the build sequence
for example this section (the first listed and seemed the best ) I had no idea how to run this, and further the commands were not recognised.

Some devices using Bluetooth low energy do not appear when scanning with bluetoothctl, for example the Logitech MX Master. You can use transport le to scan it.

# bluetoothctl

[bluetooth]# menu scan
[bluetooth]# transport le
[bluetooth]# back
[bluetooth]# scan on
[bluetooth]# devices
Device XX:XX:XX:XX:XX:XX DA V2 X <---- low energy device here

Nope, a totally different thing… this is bluetooth not wi-fi

It is scanning ok, it is seeing devices it is just NOT seeing the MX master mouse…

On the previous Manjaro install, it (MX Mouse) was the first thing that came up in discover, just by the by.

Finally got that bluetoothctl working - ran through its steps - it “seemed” to find what I think is the MX, as the only other two bt devices are already identified but it goes to a [del] line soon after it is discovered and In have no time to enter the device ID next to device command as indicated in that wiki…

Thing is,I have no idea why this is so tough, when in all previous Manjaro (and other Linux installs) it worked immediately!! What makes this version such a pita

Ok, seemed the issue must have been with the 6.x RT kernel - went to a lower (non RT) kernel, and it now works again!

well this is another disappointing thread where users didn’t provide basic informations like the mandatory

inxi --admin --verbosity=7 --filter --no-host --width

that would have shown that a RT kernel was used. It is not supposed to use RT (real-time) kernels for general use ! that said i’ll mark your last post as solution.

okay - thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.