Bluetooth keyboard falls asleep

Hi there,

My Bluetooth keyboard randomly seems to fall asleep for about 10 seconds or so and then quickly does the last couple of keystrokes. This happens every few minutes.

I have also noticed that when the keyboard falls asleep, running the command lsusb gives no output until the keyboard works again. Also the entire problem seems to get better if the keyboard has been connected for longer. i.e. the interruptions are not as often then.

Originally I noticed these problems on Kubuntu after an update. Sadly switching to Manjaro has not fixed the problem.

If anyone would know a solution I would be very grateful!!


here are my system infos:

inxi --full --admin --verbosity=7 --filter --no-host
System:    Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=4c2e8cd5-51c7-4c44-81de-8832c7a73f00 rw 
           quiet apparmor=1 security=apparmor resume=UUID=82ad94cd-20eb-4dd2-94aa-a220d37f2ad2 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20BTS06G08 v: ThinkPad X1 Carbon 3rd serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: LENOVO model: 20BTS06G08 v: SDK0E50510 WIN serial: <filter> UEFI-[Legacy]: LENOVO 
           v: N14ET26W (1.04 ) date: 01/23/2015 
Battery:   ID-1: BAT0 charge: 44.9 Wh (100.0%) condition: 44.9/50.1 Wh (89.6%) volts: 17.1 min: 15.2 
           model: SMP 00HW003 type: Li-poly serial: <filter> status: Full 
Memory:    RAM: total: 7.46 GiB used: 3.91 GiB (52.5%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Dual Core model: Intel Core i7-5600U bits: 64 type: MT MCP arch: Broadwell family: 6 
           model-id: 3D (61) stepping: 4 microcode: 2F cache: L2: 4 MiB bogomips: 20761 
           Speed: 2595 MHz min/max: 500/3200 MHz Core speeds (MHz): 1: 2595 2: 2594 3: 2595 4: 2594 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
           clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
           est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht ibpb ibrs ida intel_pt invpcid 
           invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat 
           pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp 
           rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
           tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:1616 class-ID: 0300 
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 2-8:4 chip-ID: 04f2:b45d 
           class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting 
           alternate: fbdev,intel,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1921x2160 s-dpi: 96 s-size: 506x570mm (19.9x22.4") s-diag: 762mm (30") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") diag: 354mm (13.9") 
           Monitor-2: HDMI-2 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8") 
           OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
           chip-ID: 8086:160c class-ID: 0403 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:   Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: kernel port: 3080 bus-ID: 00:19.0 
           chip-ID: 8086:15a2 class-ID: 0200 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0 bus-ID: 04:00.0 
           chip-ID: 8086:095b class-ID: 0280 
           IF: wlp4s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 2-7:3 
           chip-ID: 8087:0a2a class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
Logical:   Message: No logical block device data found. 
RAID:      Message: No RAID data found. 
Drives:    Local Storage: total: 238.47 GiB used: 59.25 GiB (24.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNTE256HMHP-000L7 size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8L6Q scheme: MBR 
           Message: No optical or floppy data found. 
Partition: ID-1: / raw-size: 229.67 GiB size: 225 GiB (97.97%) used: 59.25 GiB (26.3%) fs: ext4 dev: /dev/sda1 
           maj-min: 8:1 label: N/A uuid: 4c2e8cd5-51c7-4c44-81de-8832c7a73f00 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 
           maj-min: 8:2 label: N/A uuid: 82ad94cd-20eb-4dd2-94aa-a220d37f2ad2 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 
           class-ID: 0900 
           Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s chip-ID: 8087:8001 
           class-ID: 0900 
           Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 
           class-ID: 0900 
           Device-1: 2-7:3 info: Intel Bluetooth wireless interface type: Bluetooth driver: btusb interfaces: 2 
           rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0a2a class-ID: e001 
           Device-2: 2-8:4 info: Chicony Integrated Camera type: Video driver: uvcvideo interfaces: 2 rev: 2.0 
           speed: 480 Mb/s power: 500mA chip-ID: 04f2:b45d class-ID: 0e02 serial: <filter> 
           Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s chip-ID: 1d6b:0003 
           class-ID: 0900 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 0.0 C 
           Fan Speeds (RPM): cpu: 3961 
Info:      Processes: 229 Uptime: 1m wakeups: 1 Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 
           Packages: 1350 pacman: 1338 lib: 351 flatpak: 6 snap: 6 Shell: Bash v: 5.1.8 running-in: konsole 
           inxi: 3.3.06 

:+1: Welcome to Manjaro! :+1:

  1. Thank you for the inxi! You’ve been paying attention before posting! :grin:

  2. Execute:

    pamac install tlpui
    tlpui &

    and ensure the bluetooth adapter doesn’t go to sleep

  3. Alternatively, edit the /etc/tlp.conf as root and ensure same as in #2


Thank You for your Answer! :+1:
I had disabled the Bluetooth sleep already but the problem still was there.

I experimented with some different kernel versions, and on 5.14.rc6, the problem seems to have disappeared.

Anyway I installed tlpui anyhow, I did not know about that and it seems to be very useful.

1 Like

Which kernel are you running now so that the next person that has the same problem can apply the same kernel?


I am running the experimental Kernel 5.14.rc6.d0815.g7c60610-1

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.