Bluetooth is disabled by default after upgrading to the latest stable

The bluetooths is disabled by default after upgrade to the latest stable from 2022-05-13.
Before upgrade bluetooth was enabled and it was possible to use bluetooth mouse/keyboard for login. Now I have to first login using laptop keyboard, enabled it and then use my bluetooth devices. I tried to search for some setting but did not find anything.

1 Like

Same with me …
maybe a new security policy???

Always read #announcements posts:

Possible solution:

Edit: /etc/bluetooth/main.conf
Find this variable and set it to true.


In Gnome-settings this seems to enable Bluetooth and Gnome remembers the setting it was in last in my case.
The bar menu does not register bluetooth to be on in my case.

I found this as well but I was not sure about the description of that option:

AutoEnable defines option to enable all controllers when they are found.
This includes adapters present on start as well as adapters that are plugged in later on. Defaults to ‘false’.

What is the “Controller”? Is it a bluetooth adapter which accepts incoming connections or is it also a device which tries to connect to an adapter?
I don’t want to allow all bluetooth devices in my surrounding to automatically connect to my laptop :slight_smile:

I’ve never delved that deeply into bluetooth and mostly like to use cables (since they always just work) so I cannot help you with that question.

So I tried that and seems to be working fine. Bluetooth is enabled after booting and only known devices are connected automatically. Unknown devices remains unconnected.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.