Bluetooth Headset br-connection-unknown

i get the error message br-connection-unkown if i try to connect my bluetooth headset. There is a possible solution mentioned in this forum, to downgrade bluez to 5.61-1. But i have no idea how to do this?

It works if you previously installed that package before

tx, thats a very good instruction :). Unfortunatly the downgrade didn’t solve my problem. Even after restart i still get the same error. Any ideas?

An other question. i did follow the instruction. After the downgrade command i was asked in the terminal if i want to exclude bluez from upgrade. Therefor i didn’t use the add bluez to ignorPkg command.
Now i tried to add bluez zu upgrade again and searched the pacman.conf file.
There is no entry for ingnorePkg= .
Since the downgrade didn’t help, how do i undo the changes and update bluez and keep it updated in the future?

Have you installed pulseaudio-bluetooth package ? Assuming you use Pulseaudio, do you ?


Try updating it manually to latest version you have got
sudo pacman -U <location of your latest bluez>
sudo pacman -S bluez bluez-utils
What does it say ?

sudo pacman -S bluez bluez-utils
Warnung: bluez-5.63-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Pakete (2) bluez-5.63-1  bluez-utils-5.63-1

Gesamtgröße des Downloads:             0,94 MiB
Gesamtgröße der installierten Pakete:  6,11 MiB
Größendifferenz der Aktualisierung:    3,74 MiB

:: Installation fortsetzen? [J/n]

I’m confused. It says bluez 5.63-1 is actual but i had 5.63-3 installed before the downgrade.

You are sure ?
mine says

 pacman -Q bluez                                                                                  127 ✘ 
bluez 5.63-1

and my system is fully upgraded as well

pacman -Ss pulseaudio-bluetooth
extra/pipewire-pulse 1:0.3.45-1
    Low-latency audio/video router and processor - PulseAudio replacement
extra/pulseaudio-bluetooth 15.0-1 [Installiert]
    Bluetooth support for PulseAudio

yes seems to be installed

thought i checked it. But nevermind, perhaps just blindly followed the other br-connection-unknown topic :D.
edit: checked the /var/log/pacman.log . You’re right. i never actual downgraded it :face_with_spiral_eyes:

Note pacman -Ss doesnot return the packages that are insalled in your system
try Qs instead of Ss

pacman -Qs pulseaudio-bluetooth
local/pulseaudio-bluetooth 15.0-1
    Bluetooth support for PulseAudio

1 Like

ControllerMode = bredr

Look if you have 5.63.1 version in your cache

ls /var/cache/pacman/pkg/bluez*

In my case I have those:

Then install that package with

sudo pacman -U /var/cache/pacman/pkg/bluez-5.63-1-x86_64.pkg.tar.zst  

sry I didn’t have the package there

tried, but didn’t help.

gjoe, i think u missed a part of this conversation? 5.63-1 is installed at my system. Or is there a special reason to reinstall it?

I just gave you the answer for this question… I don’t know what you did whilst downgrading which you described as undoing the process to be a question…

Would you like to take a look at #23 in Arch Forum
I don’t know how to recompile stuff but recompiling the btusb module worked for a guy…
Or this bluez is a bugous version
I too use a bluetooth headset
Try forcing connection using cli of bluetoothctl
or I force using the blueman-applet to connect
tap on connection more than once
That’s how I am doing lately… since I receive similar message like yours and even after connection it gets disconnected
Hope you make it
Have a great day :slight_smile: