Bluetooth enables itself


I noticed recently (probably since last update) that my laptop’s bluetooth turns on itself quite often, which tends to highly annoy me. After a few tests I found out that it happens when it wakes up from sleep, and after booting as well.
I don’t really know what info to provide, so let’s start with inxi:

  ~ $ inxi -SMCE 
  Host: ZaManjaro Kernel: 5.10.136-1-MANJARO arch: x86_64 bits: 64 
    Desktop: bspwm v: 0.9.10 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X570ZD_R570ZD 
    v: 1.0 serial: <superuser required> 
  Mobo: ASUSTeK model: X570ZD v: 1.0 serial: <superuser required> 
    UEFI: American Megatrends v: X570ZD.310 date: 07/04/2019 
  Info: quad core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 
    bits: 64 type: MT MCP cache: L2: 2 MiB 
  Speed (MHz): avg: 1487 min/max: 1600/2000 cores: 1: 1457 2: 1558 3: 1368 
    4: 1698 5: 1502 6: 1357 7: 1554 8: 1403 
  Device-1: IMC Networks type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 

Anyone has an idea about how to fix this ??
Thank you

Hi @oguere,

You can try disabling the service:

systemctl disable bluetooth.service


This will disable the bluetooth service completely, requiring you to turn it on when you want to use it:

systemctl start bluetooth.service

Hope this helps!


I had thought of this solution but as you said it makes bluetooth completely unavaiable, which is quite unconvenient when I need to use it. Thanks anyway

Then I think you’d need a udev rule, or similar, to run on unlock, login, opening it, or whatever, that checks the status and enable it if disabled.

another possibility is to set


in grub and update grub

1 Like

Do I have to set this in /etc/default/grub or /boot/grub/grub.cfg ?

Edit /etc/default/grub with sudo:

sudo nano /etc/default/grub

Add the in between the quotes to the value for GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_CMDLINE_LINUX_DEFAULT="... rfkill.default_state=0"


The ... there is just to say you should add it there, not replace the whole value.

Save, Ctrl+OY and Exit, Ctrl+X.

Then update grub:

sudo update-grub

Followed by a reboot to test.

Here’s me, hoping it helps!

1 Like

Thank you for the details,
I tried it, bluetooth still enables itself =( I guess I’ll have to live with it …

search and change something here

sudo nano /etc/bluetooth/main.conf

end of this file …

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'true'.

after reboot, BT is disabled


It worked \m/ thanks a lot mate =)
For anyone who would read this thread, the line to modify was commented in my case, so mak sure to uncomment it (delete the “#” at its beginning)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.