Bluetooth doesn't recognize all my tws devices

I’ve just acquired my new laptop, and installed manjaro,
I would like to know how to properly install the bluetooth driver that allows my bluetooth module to work properly,
My bluetooth connects to one of my true wireless earphones, but doesn’t even recognize the other one while scanning for it
Also when connected to one of my tws, the voice quality is bad, I gets cut down frequently
Note: I don’t experience any connection problem with my tws devices when connected to my mobile or even another laptop with the same manjaro distro, my new laptop is HP, the old one is dell
I would appreciate your help so much, thank you

Hi @karam4134

Welcome to the Manjaro forum.

While I can’t help with your issue, if you post the output from:

inxi --admin --verbosity=7 --filter --no-host --width

… this might help others to find a solution.


Hi @soundofthunder, thank you for your response, here’s the output of the command

  Kernel: 6.5.13-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=d53af080-83ee-49f2-8eeb-8d5b99af207b rw
    resume=UUID=9aaf043e-303e-4532-9d02-46b5e7c1adc8 quiet splash
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 15s-fq5xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8A20 v: 20.19 serial: <superuser required> UEFI: AMI
    v: F.17 date: 10/20/2022
  ID-1: BAT0 charge: 19.3 Wh (47.1%) condition: 41.0/41.0 Wh (99.9%)
    volts: 11.1 min: 11.3 model: HP Primary type: Li-ion serial: <filter>
    status: discharging cycles: 8
  System RAM: total: 64 GiB note: est. available: 62.48 GiB
    used: 4.71 GiB (7.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-1255U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x430
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 519 high: 792 min/max: 400/4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 792 2: 671 3: 647 4: 400
    5: 667 6: 400 7: 400 8: 400 9: 400 10: 400 11: 658 12: 400 bogomips: 62688
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid
    waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:46a8 class-ID: 0300
  Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2
    chip-ID: 30c9:0064 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: BOE Display 0x0991 built: 2020 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a8 memory: 61.02 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: N/A device: 0 type: integrated-gpu
    name: Intel Graphics (ADL GT2) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:46a8 surfaces: xcb,xlib
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.5.13-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IF-ID-1: crc state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-2: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:3 chip-ID: 0bda:b00e
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 239.35 GiB (25.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: SaiChi G800 NVME 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: T1103L0L temp: 39.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 60.54 GiB size: 59.28 GiB (97.93%) used: 11.87 GiB (20.0%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: d53af080-83ee-49f2-8eeb-8d5b99af207b
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 6.4 MiB (1.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 6E71-9D6B
  ID-3: /home raw-size: 863.03 GiB size: 848.41 GiB (98.31%)
    used: 227.47 GiB (26.8%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
    label: N/A uuid: 9eaa1af0-344a-45da-a83e-2a67133470e9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 29.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
    uuid: 9aaf043e-303e-4532-9d02-46b5e7c1adc8
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-3:2 info: Luxvisions Innotech HP TrueVision HD Camera
    type: video driver: uvcvideo interfaces: 3 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 500mA
    chip-ID: 30c9:0064 class-ID: fe01 serial: <filter>
  Device-2: 1-10:3 info: Realtek Bluetooth Radio type: bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 500mA chip-ID: 0bda:b00e class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 366 Uptime: 1d 22h 23m wakeups: 0 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1286 libs: 341 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 running-in: tmux: inxi: 3.3.31

Anybody could help?

That could indicate that the issue is with your laptop.

I notice you’re using kernel 6.5 which has now reached EOL; you should remove that and update to either kernel 6.6 or 6.1 (LTS). It’s also possible that updating the kernel might automagically solve your issue, see Manjaro Kernels.

Beyond that, I’m afraid I can’t offer any further help as I don’t use bluetooth; therefore, there is no common frame of reference.

Good luck.

Thank you @soundofthunder, I will try updating the kernel and let you know if that helped


Do you have two Bluetooth?

If so, what if you unplug the external one and pairing again with the onboard Bluetooth

more config info

Hi terashy,
Thank you for your response,
I don’t have an external Bluetooth module, it’s just the builtin one

1 Like

I have some updates,
I’ve redirected the bluetooth device to a windows virtual machine and tried to connect to my handsfree that I couldn’t connect to directly through manjaro, and it’s successfully recognised and connected,
So it’s a matter with manjaro, not the laptop,
I also tried multiple versions of Linux kernels, 6.1, 6.6, and 5.15 but it’s not recognized, could somebody direct me on how to find the suitable kernel module for my HP laptop bluetooth chip?
Thank you all for your help

Maybe Firmware Manager can help.

sudo pacman -Syu firmware-manager

… Do you have a Friend, family where you could borrow a similar earphone to test with?

And also try to reset your tws?

Mind has to keep turn on for more than 5 second, some are over 15 second
therefor, you have to check your tws manual.

This is not the way to install packages.

sudo pacman -Syu firmware-manager
1 Like



1 Like

have been wondering - quoting from the topic title

Bluetooth doesn’t recognize all my tws devices

What is a tws device?
And what impact would such a device have on the bluetootd protocol?

Hi @terashy88,
I’d like to thank you so much for your response,
I really would like to say that this command solved the issue,
But I had a very strange behavior, I had this command run, then searched for my tws, and … It was found successfully, clicked connect and actually got connected, but no sound is working!!!
I thought a reboot would solve the problem, but after rebooting, I got the adapter not found !!!
I faced that problem before, and a poweroff then start my laptop solved that and I got the adapter attached again :thinking:
But can’t connect to my previously identified tws :thinking:
So forgot it and searched for it again, and couldn’t find it :sob:

I have an update,
After switching to kernel version 5.15, and ran the following command:

sudo pacman -Syu firmware-manager

The Bluetooth detected my TWS and I started hearing voice from it,
But it still has some glitches or cutting offs and it’s not really usable especially during meetings, and I found the following errors flooding:

Output ommitted
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: firmware failed to leave lps state
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:18 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:19 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:19 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:19 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:20 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:20 xxxx kernel: rtw_8821ce 0000:01:00.0: failed to send h2c command
Dec 28 12:50:20 xxxx kernel: rtw_8821ce 0000:01:00.0: firmware failed to leave lps state
Output ommitted

Appreciate your recommendations

Then i suggest strongly to install and test : 6.1(LTS), 6.6(LTS) 6.7(new) (and remove 6.5(EOL))
→ Stay where it works best