Bluetooth does not work on Lenovo Thinkpad e15 gen 3 amd ryzen 7


I’ve just installed Manjaro on my new laptop Lenovo Thinkpad e15 gen 3 amd ryzen 7.

Everything has worked quickly : trackpoint, backlit keyboard, wifi, screen brightness keys, etc.

Everything… EXCEPT bluetooth :slightly_frowning_face:

I don’t know what to do. My fresh install had linux-kernel 5.13, I tried to install linux-kernel 5.14 but that did not solve the problem.

I don’t know what to do and I wondered if anyone has already met this issue and know how to fix that problem

Thanks in advance for advices

To solve this problem I had to install the linux-kernel 5.15, still in RC (rc3). linux-5.15.rc3 fixed the problem : now bluetooth works
thank you gog and zbe


I’m answering myself, as the problem is solved thanks to nice people, gog and zbe on chat.

The lsusb command gives the id of bluetooth controller. It is : ID 0489:e0cd Foxconn / Hon Hai Wireless_Device

zbe sent me this page https:/ /
about a recent implementation of bluetooth driver in linux kernel. Look at line :

  • { USB_DEVICE(0x0489, 0xe0cd), .driver_info = BTUSB_MEDIATEK |

… that is a same ID than in lsusb.

Then installing the linux-5.15.rc3 kernel solved the issue. Now bluetooth adapter works

Hope it will be useful !

1 Like