Bluetooth disconnection

I’m experiencing strange behavior with my bluetooth earbuds. For example I’m listening to a video and after I pause it several times the earbuds stop listening and the bluetooth icon on my panel disappears. The service is running and everything seems to be ok but no audio. Then I close the laptop screen, wait for 3 seconds, open it, login to the system and the bluetooth icon is there and I can connect the earbuds again, and if the time is fast they connect automatically, as if anything happened.

this is the output of my system

 Kernel: 5.13.0-176-tkg-bmq x86_64 bits: 64 compiler: gcc v: 11.1.0  
 parameters: intel_pstate=passive BOOT_IMAGE=/boot/vmlinuz-linux-tkg-bmq  
 root=UUID=40f5b289-abc6-4f15-922a-a6915ac9cfd4 rw quiet apparmor=1  
 security=apparmor udev.log_priority=3 lsm=lockdown,yama,apparmor,bpf  
 Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: plank wm: kwin_x11 vt: 1  
 dm: SDDM Distro: Manjaro Linux base: Arch Linux  
 Type: Laptop System: HP product: HP Laptop 15-da0xxx v: Type1ProductConfigId  
 serial: <filter> Chassis: type: 10 serial: <filter>  
 Mobo: HP model: 84A6 v: 80.38 serial: <filter> UEFI: Insyde v: F.17  
 date: 01/18/2019  
 ID-1: BAT1 charge: 34.3 Wh (100.0%) condition: 34.3/41.9 Wh (81.7%)  
 volts: 12.9 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion  
 serial: <filter> status: Full  
 RAM: total: 11.61 GiB used: 7.75 GiB (66.8%)  
 RAM Report: permissions: Unable to run dmidecode. Root privileges required.  
 Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP  
 arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10)  
 microcode: E0 cache: L2: 6 MiB bogomips: 28824  
 Speed: 798 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 798 2: 1226  
 3: 785 4: 868 5: 800 6: 800 7: 800 8: 800  
 Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art  
 avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid  
 cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est  
 f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window  
 hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm  
 mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat  
 pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts  
 rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1  
 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust  
 tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt  
 xsaves xtopology xtpr  
 Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
 Type: l1tf  
 mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
 Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
 Type: meltdown mitigation: PTI  
 Type: spec_store_bypass  
 mitigation: Speculative Store Bypass disabled via prctl and seccomp  
 Type: spectre_v1  
 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
 Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,  
 IBRS_FW, STIBP: conditional, RSB filling  
 Type: srbds mitigation: Microcode  
 Type: tsx_async_abort status: Not affected  
 Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915  
 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300  
 Device-2: Chicony HP TrueVision HD Camera type: USB driver: uvcvideo  
 bus-ID: 1-5:3 chip-ID: 04f2:b65d class-ID: 0e02 serial: <filter>  
 Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver:  
 loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0  
 screens: 1  
 Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")  
 s-diag: 414mm (16.3")  
 Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")  
 diag: 389mm (15.3")  
 OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.2  
 direct render: Yes  
 Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard  
 driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3  
 chip-ID: 8086:9d71 class-ID: 0403  
 Sound Server-1: ALSA v: k5.13.0-176-tkg-bmq running: yes  
 Sound Server-2: JACK v: 0.125.0 running: no  
 Sound Server-3: PulseAudio v: 14.2 running: yes  
 Sound Server-4: PipeWire v: 0.3.30 running: yes  
 Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet  
 vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0  
 chip-ID: 10ec:8168 class-ID: 0200  
 IF: eno1 state: down mac: <filter>  
 Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi  
 v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 8086:24fb class-ID: 0280  
 IF: wlo1 state: down mac: <filter>  
 IF-ID-1: br-201b31e9839c state: down mac: <filter>
 IF-ID-11: enp0s20f0u1 state: unknown speed: -1 duplex: half mac: <filter>  
 IP v4: <filter> type: dynamic noprefixroute scope: global  
 broadcast: <filter>  
 IP v6: <filter> type: noprefixroute scope: link  
 WAN IP: <filter>  
 Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8  
 bus-ID: 1-6:12 chip-ID: 8087:0aa7 class-ID: e001  
 Report: bt-adapter ID: hci0 rfk-id: 15 state: up address: <filter>  
 Permissions: Unable to run lvs. Root privileges required.  
 Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci  
 v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104  
 Local Storage: total: 1.93 TiB used: 1.57 TiB (81.4%)  
 SMART Message: Unable to run smartctl. Root privileges required.  
 ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: HP model: SSD EX900 120GB  
 size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s  
 lanes: 4 rotation: SSD serial: <filter> rev: S0614B0 scheme: GPT  
 ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174  
 size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s  
 rotation: 5400 rpm serial: <filter> rev: RDM4 scheme: GPT  
 Message: No optical or floppy data found.  
 ID-1: / raw-size: 111.49 GiB size: 109.24 GiB (97.98%)  
 used: 101.57 GiB (93.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2  
 label: N/A uuid: 40f5b289-abc6-4f15-922a-a6915ac9cfd4  
 ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)  
 used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
 Alert: No swap data was found.  
 Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0  
 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900  
 Device-1: 1-1:8 info: Xiaomi Mi/Redmi series (RNDIS) type: CDC-Data  
 driver: rndis_host interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA  
 chip-ID: 2717:ff80 class-ID: 0a00 serial: <filter>  
 Device-2: 1-5:3 info: Chicony HP TrueVision HD Camera type: Video  
 driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA  
 chip-ID: 04f2:b65d class-ID: 0e02 serial: <filter>  
 Device-3: 1-6:12 info: Intel Wireless-AC 3168 Bluetooth type: Bluetooth  
 driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA  
 chip-ID: 8087:0aa7 class-ID: e001  
 Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s  
 chip-ID: 1d6b:0003 class-ID: 0900  
 System Temperatures: cpu: 47.0 C mobo: 29.8 C  
 Fan Speeds (RPM): N/A  
 Processes: 316 Uptime: 21h 40m wakeups: 28 Init: systemd v: 248  
 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1671 lib: 421  
 rpm: 0 flatpak: 0 Shell: fish v: 3.2.2 running-in: yakuake inxi: 3.3.04

Well, that kernel is not an official kernel. Have you tried to reproduce the issue with official kernels already?

A post was split to a new topic: Bluetooth is automatically enabled and disabled

I don’t test with the official kernel. The thing is that with the official kernel the laptop freezes to much with intense CPU workloads, so I have to stay with the unofficial one. But the disconnecting of Bluetooth is recently, with that kernel worked fine, but maybe a previous version.

I’m assuming you’re managing your bluetooth earbuds from your desktop manager.
It that’s the case, see if unpairing the device and pairing it again via CLI makes any difference.

For the above, I recommend you follow the instructions on Arch Wiki