Bluetooth devices wont reconnect after waking up from sleep

After waking up from sleep, bluetooth mouse and headphones will not reconnect. I have to restart the bluetooth service after which it will reconnect the peripherals or I have to connect them manually trough cli. When the PC is rebooted or is cold booted, the peripherals connect just fine. It worked fine a month or two ago. When it stopped working, an update was applied. There was a lot of upgrades so I don’t know which one broke it. I thought it was because I have to restart the PC or a bug caused it and future updates will fix it, but it hasn’t changed since then.

Here are my details:

 ~  inxi -Fxxxza --no-host                                                                                                                    ✔  21:22:10 
System:    Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=63659453-d0b7-4ce8-a827-b25a9ca74815 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: GNOME 3.36.5 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: X570 Pro4 serial: <filter> UEFI: American Megatrends v: P2.00 date: 11/08/2019 
Battery:   Device-1: hidpp_battery_4 model: Logitech Wireless Mouse MX Master 3 serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701013 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 115246 
           Speed: 2583 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2716 2: 1867 3: 1867 4: 1866 5: 1858 
           6: 2522 7: 1860 8: 1862 9: 1865 10: 1866 11: 2163 12: 2291 13: 2140 14: 2136 15: 2800 16: 1863 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 08:00.0 chip ID: 1002:67df 
           Display: x11 server: 1.20.8 compositor: gnome-shell driver: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.37.0 5.7.17-2-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.6 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine driver: snd_hda_intel 
           v: kernel bus ID: 08:00.1 chip ID: 1002:aaf0 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.7.17-2-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.6.0-k port: f000 bus ID: 04:00.0 
           chip ID: 8086:1539 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: br-63a15dfa64da state: down mac: <filter> 
           IF-ID-2: br-64bd4328747f state: down mac: <filter> 
           IF-ID-3: br-dc0242a63d45 state: down mac: <filter> 
           IF-ID-4: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 206.92 GiB (43.4%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 476.94 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 42AZS6AC scheme: GPT 
Partition: ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) used: 206.92 GiB (44.2%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 62.2 C mobo: 39.0 C gpu: amdgpu temp: 45 C 
           Fan Speeds (RPM): fan-1: 770 fan-2: 0 fan-3: 1564 fan-4: 790 fan-5: 0 fan-6: 2647 fan-7: 0 gpu: amdgpu fan: 1207 
Info:      Processes: 402 Uptime: 4h 23m Memory: 15.57 GiB used: 6.73 GiB (43.2%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: 1372 pacman: 1366 lib: 391 flatpak: 0 snap: 6 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05 

 ~  hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"              ✔  21:22:13 
  Model: "Intel I211 Gigabit Network Connection"
  Driver: "igb"
  Device File: enp4s0
  Link detected: yes
    Driver Status: igb is active
    Driver Activation Cmd: "modprobe igb"
  Model: "Cambridge Silicon Radio Bluetooth Dongle (HCI mode)"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

There’s nothing useful in the journal.

Well I stumbled upon this post while searching for a solution to my own issue. I too have a MX Master 3, however I can not even get it to connect through Bluetooth setup. Setup says Failed when trying to connect it. I am Kernel 5.8.

I am beginning to suspect it may be a Manjaro Kernel cause??? I have tried it on Endeavour OS, PopOS, Elementary OS and Windows. All on the same device (XPS 13 9300). All without issues.

Unfortunately I am not fluent enough in Linux to troubleshoot with out some guidance so I too am hoping the forum can help.