Bluetooth audio choppy, muffled & staticky using A2DP

Hi all, first time Manjaro (21.1.6 KDE) user here. I tried to connect some Bluetooth earphones and sound is really terrible. Issue persisted between different headphones, after restarts (including pulseaudio --k & --start) etc.

The arch docs suggested it was probably an A2DP vs HFP issue but no luck - they’re definitely using A2DP.

Pulseaudio docs suggested changing resampling mode (turning ON) and changing sampling rate in /etc/pulse/daemon.conf but no change there.

After reading lots of forum posts, I also tried commenting out some ifs (and endifs) in /etc/pulse/, as well as a suggestion that it was due to some Pipewire conflict (given both Pipewire and PulseAudio appear as running when I run inxi -F). I tried their suggestion of masking pipewire.socket and stopping pipewire.service. Also no change (have since undone).

I have Windows installed on a different partition on the same machine (XPS 9350) and Bluetooth works all fine, so not a hardware issue. Any suggestions? I’m new to Manjaro and Linux in general. Cheers!!

SOLVED: For anyone with an XPS-13 9350 (2016 I think?) you have to install a proprietary driver - available on AUR. See here:

All sounds good now!