Bluetooth adapter not available

Im not exactly sure what happened but ill get to the point, the other day i was using bluetooth just fine, the day after it wouldnt start and i fiddled with systemctl and btusb commands and after a reboot something had worked, now today nothing is working and bluetooth cant even be detected despite being loaded, Gnomes bluetooth settings just say “No Bluetooth found”, bluetoothctl just waiting on bluetoothd, and rfkill doesnt list it.

output of inxi -Fxz

  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  Desktop: GNOME 40.5 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X570ZD_K570ZD
  v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X570ZD v: 1.0 serial: <filter>
  UEFI: American Megatrends v: X570ZD.312 date: 02/25/2020
  ID-1: BAT0 charge: 16.8 Wh (41.7%) condition: 40.3/48.1 Wh (83.9%)
  volts: 11.7 min: 11.7 model: ASUSTeK ASUS Battery status: Discharging
  Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
  bits: 64 type: MT MCP arch: Zen rev: 0 cache: L2: 2 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 31952
  Speed: 1369 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz):
  1: 1369 2: 1367 3: 1369 4: 1368 5: 1403 6: 1622 7: 1369 8: 1368
  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
  driver: nvidia v: 470.63.01 bus-ID: 01:00.0
  Device-2: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
  vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0
  Display: x11 server: 1.20.13 driver: loaded: modesetting,nvidia
  unloaded: nouveau resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.42.0
  5.14.10-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  v: kernel bus-ID: 05:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.38 running: no
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
  vendor: AzureWave driver: rtw_8822be v: N/A port: e000 bus-ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
  Local Storage: total: 238.47 GiB used: 134.31 GiB (56.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-00000
  size: 238.47 GiB temp: 32.9 C
  ID-1: / size: 39.11 GiB used: 21.85 GiB (55.9%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 512 MiB used: 288 KiB (0.1%) fs: vfat
  dev: /dev/nvme0n1p1
  ID-3: /home size: 188.35 GiB used: 112.45 GiB (59.7%) fs: ext4
  dev: /dev/nvme0n1p4
  ID-1: swap-1 type: partition size: 5.57 GiB used: 0 KiB (0.0%)
  dev: /dev/nvme0n1p3
  System Temperatures: cpu: 45.6 C mobo: 45.0 C gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): cpu: 2300
  Processes: 284 Uptime: 5m Memory: 6.73 GiB used: 1.63 GiB (24.2%)
  Init: systemd Compilers: gcc: 11.1.0 Packages: 1486 Shell: Zsh v: 5.8
  inxi: 3.3.08

Hi @Lillie,

Have you tried a different, older kernel? That’d be my first guess. Perhaps version 5.10 seeing as it’s LTS?

on 5.10 the same thing occurs though bluetoothctl actually manages to run (though backlighting on my laptop doesnt work, which it does on 5.14)


Then I’m extremely sorry, but I’ve got no more ideas. I don’t have, use, or have any requirements for bluetooth, so don’t have any experience with it, whatsoever.

That was just a thought.

I seriously hope you come right!

well, i seemed to have somewhat if not mostly fixed it, basically i found something saying to add a bluetooth group, ill detail the step i did here

first, make a bluetooth group
sudo groupadd bluetooth

open /etc/dbus-1/system.d/bluetooth with your favorite text editor (i use nano for smaller stuff in the terminal)

add/append the following

<policy group="bluetooth">
<allow send_destination="org.bluez"/>

then save and add your user to the group
sudo usermod -a -G bluetooth <loginuser>

and then you just reboot and see if it worked, though i had to enable and start bluetooth with systemctl and reboot again

1 Like

Welp, next day and nothing is working at all anymore, i dont even know what is causing this

Off the top of my head:

  • Check if your user is still in the bluetooth group, and if not see if you can find out why it was removed.
  • Check if the /etc/dbus-1/system.d/bluetooth file is still there and has the right permissions/

Anything else, I don’t know honestly.

everything seems fine, it just seems like something is blocking it, systemctl shows that after a reboot it gets blocked by rfkill, but i cant seem to unblock it

Are the permissions and ownership of the policy file correct?

According to me:
User: root
Group: root
Permissions: 0644

Other than that, I have absolutely no idea whatsoever. Sorry.

How would i check this?

Well, I’m sure there are other ways, but I use stat. For example:

$ stat /etc/dbus-1/system.d/org.freedesktop.NetworkManager.Manjaro.conf

File: /etc/dbus-1/system.d/org.freedesktop.NetworkManager.Manjaro.conf
Size: 1470            Blocks: 8          IO Block: 4096   regular file
Device: 259,2   Inode: 11929137    Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2020-09-14 13:01:06.331471121 +0200
Modify: 2018-09-05 23:30:54.000000000 +0200
Change: 2020-09-14 13:01:06.331471121 +0200
Birth: 2020-09-14 13:01:06.331471121 +0200

In line #4 you can see the mode of the file as well as the User and Group the file belongs to.

It shows 0644 with root as user and group, so im not sure why its just blocking bluetooth now, sometimes it works and there doesnt seem to be an issue outside gnome not showing an adapter, sometimes rfkill blocks it on boot, sometimes it just fails outright, but everytime it does i manage to get something to fix it only for it to not work at all the next day when i turn my laptop on

My humblest of apologies, then. Looks like I won’t be able to help you.

okay so ive figured how it manages to randomly start working, its not any commands or anything, its that bluetooth is outright disabled if my laptop is unplugged when it boots

I believe that’s power-saving settings in the BIOS. (Or UEFI or WhatEverYouWannaCallIt)

didnt see that in the bios, i hate how laptop bios’ dont have everything compared to the same bios on a desktop

It’s, I think, because they get limited/locked to certain functions only by the manufacturers.

Run the command rfkill and note the output, everything should be unlocked as in this image: Selection_660

If it is blocked, unblock by running: rfkill unblock bluetooth

You can also list the devices with rfkill list all

i have already mentioned that it doesnt show up in rfkill

So apparently the issue was caused by Laptop-mode-tools breaking something, after removing it everything seems to be working fine