Bluemail save attached file window unreadable (squares instead of letters)

Hi everyone,

I have been using Manjaro KDE for over two years now without any issue (any issue that I couldn’t solve on my own, that is :wink:). I looked up the forum for an answer to the question I have today but I couldn’t find any.

I installed Bluemail a few days ago through snap. It works like a charm except for one thing : whenever I try to save an attached document to an email I have received, the window that pops up (which is supposed to allow me to chose where the file should be saved) is unreadable : all the letters it contains in the folder names are replaced by small square symbols, making it impossible for me to navigate through my folders.

I am running X11 in case this has anything to do with my problem…

Any help would be greatly appreciated. Thanks !


Unless there’s a very good reason to specifically use the Snap, Flatpak, or App Image version of a program, you should lean towards the official repositories and then the AUR.

Bluemail is available from the AUR, and the PKGBUILD was updated a couple weeks ago.

I’m like 90% certain this will resolve your issue.

(Just double-check to make sure your inboxes are safe. I would go ahead and make a copy of your mailbox folder.)

Thanks for your reply. I read somewhere that installing software from the AUR on Manjaro could result in a broken system after some updates so I have always been afraid of enabling the AUR. Maybe this is not true and I should just give it a go, just to see…
I still don’t understand why the characters in the snap version I have are replaced by small squares. If anyone has an idea, I am interested. Otherwise, I will follow Winnie’s advice and install Bluemail from the AUR. Thanks !

Hi everyone,

I tried something after reading about it somewhere but it didn’t work. Here is what I did:
I refreshed my font cache:

rm -rf ~/.cache/fontconfig
fc-cache -r -v

Then I deleted the font cache of Bluemail:

rm -rf ~/snap/bluemail/common/.cache/fontconfig/

The reason why I did this is because I recently had to install MS fonts for work (yeah, I know…) and I thought this might explain my problem of bluemail not displaying fonts correctly. What is strange is that the only part of Bluemail that doesn’t work is the “save attached files” window, the rest of the app is working as expected.

Anyway, this didn’t solve my problem. If anyone has another idea…

Thanks !

Most users (obviously not all) go

  1. Official repos
  2. AUR
  3. Flatpak
  4. App image
  5. Snap

Those that have the skill/knowledge will build from source.

I’ve been running bluemail from the AUR for 12 months with zero issues. In fact in 3 years on Manjaro I’ve never had a serious problem with any AUR program. Yes the AUR isn’t officially supported but many of the apps in the AUR are maintained by Manjaro team members and users. The chances of a broken system are quite slim and even slimmer if you read the pkg build and pinned comments on the AUR page

Thanks for your answer. I understand why people tend to avoid snaps, flatpaks and app images. I usually always go for the version in the repositories myself and I resort to flatpaks, app images or snaps only when the app I am looking for does not exist in the official repositories. I also understand the reasons why developers could prefer using flatpak, snap or an App image to deliver their apps to Linux users.

Thanks for sharing about your personal experience with the AUR. I totally understand why people love the AUR so much. I just don’t personally feel 100% at ease with it. Installing Bluemail from the AUR could solve my issue but I am still trying to make the snap version work on my system. It looks like the issue I am experiencing is a wider problem related to font rendering in dialogs in snaps on Arch-based systems and on Fedora.
I am continuing my research and I will post my solution here should I eventually find any, in case other people are experiencing the same issue. In the meantime, if anybody does have a solution to this font rending problem on snap apps, I am still interested…

Take care

This is the PKGBUILD.

You can review everything it does. It’s not that large or complex.

It uses the Snap from Bluemail’s website itself as the source for the binaries.

1 Like

I had already had a look at the pkgbuild and I had seen it was using the Snap.
I wondered if it really made sense to build an app from its snap version through the AUR. I am not sure to understand where the interest lays. Thanks for enlightening me in my journey to understanding Arch based systems better.

Yep exactly that :point_up_2::point_up_2:

I use the Bluemail Snap on Gnome and I found that if you copy over everything from


and replace what is in


with it then it fixes the weird box issue. I am not sure which file fixes it exactly but if you just copy over everything then it should hopefully fix it.

P.S. I have no idea if this will work on KDE Plasma. I only discovered this by doing a system wide search for fontconfig and seeing what there was and just messing with stuff.

This worked for me on Plasma! Thank you very much, it was pretty annoying. I am not sure whether this will do the trick forever but for now, it works.
I will see if this also fixes an issue of the same kind I had on another machine running i3wm (I had the same empty unicode boxes instead of font in the menu from bluemail’s tray icon).

Thank you !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.