Blasphemous crashes on my manjaro

Can someone help me? When I open Blasphemous through steam, it opens for a bit, but when it starts really it crashes and closes steam with it. Could someone help me with it? I’m kinda worried cause I’m coming from MacOS and there blasphemous worked really good.

Hi @Artie and welcome to the Manjaro community

I’m afraid you haven’t given much information to enable anyone to help. We only presume it’s a game that you’re talking about because you happened to mention Steam; and we further presume you are using KDE Plasma, due to the categories you’ve placed this thread into.

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit:

When you have worked your way through those links you should better understand the types of information needed, and how you can provide it.


I played Blasphemous (from Steam) just a moment ago and it was fine. I played native version but according to ProtonDB Windows version also should be ok. If you have Xbox controller, you should enable Steam Input – default mapping is broken :wink:

Please provide more informations about your system, game logs or crash messages and what you exactly did, which version you tried etc.