Blank screen and cursor when booting into simple desktop enviroment for installing

Hi, I’m changing my distro from Debian to Manjaro, wont get into details but yeah. I made a manjaro bootable drive, popped it into my computer, booted up, selected propietary drivers because i have an nvidia card (i deleted all the nvidia drivers i had installed in debian), all the installation thingys were a green OK, and then it just booted into a blank screen with a mouse pointer. Help me im screwed

Hello @OnceAgajn,

what do you mean by this? If you install a fresh manjaro and format your hdd/ssd there is no need to delete any driver. Could you explain exacly what you did while and after installation? :wink:

Nono i didnt even get to the installation program, i just booted the usb and clicked on the propriatary driver setup and after the checkups finish it starts this “basic desktop enviroment” (the one that has the installer on it where i will actually be doing the formatting and installing), problem being, said desktop enviroment doesnt even start it just shows me a blank screen with the mouse pointer. Before i installed it i uninstalled all the nvidia drivers and even the kde desktop enviroment from my debian installation

Ah ok, are you on a laptop or a desktop machine? And/Or does it start with free drivers?

P.S. “laptop or desktop” cause of, are there two GPUs which work at the same time/monitor?

Nope im on a desktop

Does it start if you choose free drivers? And what nVidia card you use?

Im using a gtx 1050, i tried booting without any disks connected and it still did the same thing, im now going to reinstall my usb but im going to use a different link, not the torrent. Im going to try booting with the free drivers and im going to give you an update

Hm, perhaps there are no more propriatary drivers for your card available. A time ago manjaro drop support for legacy nvidia drivers, cause it takes a lot of time to maintain.

So I guess last propriatary drivers for you card are version 375.20. And the oldest one supported by manjaro are 390.xx. So I suggest to use at first the free drivers to get your system started. :neutral_face:

Hmm give me a second

Are the open source drivers any good

for normal use they are ok I guess … but for gaming I guess its not so good. Till now I never used the free drivers on my system.

Cant i just manually download my drivers afterwards because on debian i was using the newest nvidia drivers as far as i know

“the newest” means what version? If I remenber right, there where a HowTo to install 370 nvidia drivers somewhere in the forum. … time for bed for me … perhaps someone else supports you further … or we will meet tomorrow. :stuck_out_tongue_winking_eye:

No, they said they use a GTX 1050, well that is still supported with the very latest nvidia driver 525.60. (I myself use 750 Ti with it)

Ah, ok. my bad. Sorry.

@OnceAgajn can you try to disable SecureBoot and CSM in your UEFI and retry?
Sometimes these interfere with driver loading…
But keep UEFI enabled and don’t switch that off…

I’m using nvidia also see my profile, although im now on Kubuntu again

You could try installing the dkms version instead, make sure to install dkms and the kernel headers first…
(Yes dkms installs quite a lot of stuff)

Okay so after a lot of tinkering around and with some of the help of you people, here’s how I solved this problem for anyone looking at this page with a similar problem.
If you’re distro hopping and had proprietary nvidia drivers, uninstall them all.
After that, on the manjaro installation screen click “Setup with open source drivers”.
When you’ve installed manjaro you can setup your proprietary nvidia drivers manually

Why would anyone need to uninstall anything from their previous disto at all :thinking:
That’s just nonsense, because you can have multiple distro’s setup and running side-by-side on same computer (different partitions)

But yes if the default install option of a distro doesn’t properly initializes your video card, then you need to choose a “compatibility” option ofcourse which is what you selected with open source drivers…

Anyhow glad you fixed your issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.