Blank Screen after wakeup

When i wake up the laptop from sleep, it allows me to enter the password but after that the screen is blank.
Mouse cursor is visible, and nothing else only black screen, only thing i can do is go to tty (Alt+Ctrl+F2) or push the power button.

I used to have similar problem before (it used to freeze rarely instead of black screen), but now after the recent update its happening very frequently. Please help me find the issue and solve it

Hello, how are you? Could you show the output that inxi -G shows you?

    ~  inxi -G                                                                                                                                                                         ✔ 
  Device-1: AMD Renoir driver: amdgpu v: kernel
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.25-1-MANJARO)

Switched back to 5.15 kernel, still has the same issue

Did you try using the amd_iommu=off kernel boot parameter?

Another possibility …

If this happens after login, try another user account.

(sorry to almost repeat myself)

Also you can try


Which in theory will work for the things that work, and let the rest fail passively.

will try and let you know hot it goes for both of those

Another thing i seems to have noticed is, when i put the laptop into sleep by pressing the sleep button this issue doesn’t seem to happen, but It happens when the laptop goes into sleep by itself when left inactive.

Hi Mate, i have tried both of those and they didn’t work :frowning:

unfortunately, this didn’t work either

You can try to install sddm-git and see if it helps. If not, revert to sddm from repo. Of course, reboot after the package change.

processor.max_cstate=1 adding this kernel parameter reduced the frequency of blank screen occurance

Thanks michaldybczak, after you mentioned sddm, i found that the update changed something and might be causing my video wallpaper lockscreen to crash the amd driver.
“Wallpaper Type” option in “Screen Locking” has lost the dropdown list and had to reset the setting to get back…

Will monitor for a couple of days to see if it solved or not

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.