Blank screen after update. (Xorg: No devices/screens found)

Hi! I am kinda noobish with Linux terminal, so would appreciate your help.

I just updated my OS recently and it boots to a blank screen. I pressed Alt+F2 and consulted some posts online to figure out how to trouble shoot.

First, I made sure to update, and got a warning that my optimus-manager was a version ahead from community (1.4.2), so running pacman -S optimus-manager helped fix this issue.

However, after rebooting, it still went to a blank screen.

Google led me to a post here which recommended using startx and check the error log for Xorg for any errors (EE), and I got 2 different logs depending on whether I ran it with sudo.

Th first log from running startx gave me the following error (I am typing this on mobile):

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(EE) no screens found
Server terminated with error (1)

Runnung sudo startx gives the following log:

(EE) No devices found
(EE) no screens found
Server terminated with error (1)

Running nvidia-smi fails because “it couldn’t communicate with the NVIDIA driver.”

I am not sure what to do. I tried running sudo mhwd -f and it did not print anything. Rebooted to the same blank screen.

Running mhwd -li gives the following (typing from mobile so making a list instead of the table):



I am not sure what to do here. Is it because the video-modesetting is installed? Should I remove it?

An explanation of what might be going on would be great. Thanks!

Before the update, I was prompted to remove something gstreamer because it breaks a dependency with something else that uses something different.
Cannot recall what it said. I apologize.

  1. If you have 5.10 LTS installed, add 5.4 LTS and boot into that and see if the problem goes away. If you have anything else, please advise and stop here!

    sudo mhwd-kernel --install linux510
  2. video-modesetting is a fall-back driver, and as you have nothing that works anyway, let’s remove everything and start from scratch if you have an Internet connection. If not, please stop here!

    sudo mhwd --remove pci video-hybrid-intel-nvidia-prime
    sudo mhwd --remove pci video-modesetting
    sudo reboot

    log in again into TTY2:

    sudo mhwd --install pci video-hybrid-intel-nvidia-prime


P.S. Instead of typing everything on your phone, go to a friend’s place, download and burn the latest Manajaro ISO on an USB stick on their computer and boot with that on your own computer.
P.P.S. If you have no friends, ask if you can use mum’s computer. :grin:

1 Like

I have 5.11 rt, and booting into 5.10 via grub works fine.
What could be causing this issue in 5.11 rt?

5.11 is EOL, though 5.11-RT isn’t yet, so we’ll probably never know for sure.

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Thanks a lot for your time and effort, Fabby!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.