Blank log-in screen after update(Gnome)

Basically my problem is similar to this one here Gnome shows blank log-in screen, after update the system using sudo pacman -Syu Gnome loaded up with my mouse working fine but it doesn’t show any user logins. It just show blank grey background and the top-bar functions correctly. I tried to follow some guide online by going in to tty mode but the system instantly freezes when I press Ctrl+Alt+F2. It’s pretty urgent as this is my working laptop, hope someone can help me!!

Since I can’t get into the system I can’t provide much information but it’s a Thinkpad X1 Carbon 2017 running Manjaro with Gnome as DE.

I think I narrow down the problem to my fingerprint reader service(FPrint Daemon) failing to start and it keeps trying, but I can’t find a way to stop it.

If I hold down Ctrl+Alt+F2 during boot I get to a black screen saying [FAILED] Failed to start Open FPrint Daemon but I can’t login or do anything.

Can you use the Manjaro USB stick to boot and chroot into the system.
Then you can access the log files.

Thanks a lot I did just that and solved it! For the record I’m writing here how I fixed it:

I flashed a USB drive with freshly download Manjaro minimal ISO. Change the booting option to boot in the OS on the USB and did
sudo manjaro-chroot -a
and successfully got access to the broken system. I then run systemctl to check the corrupted service. Turns out it’s the fingerprint service that is causing the problem(GitHub - uunicorn/python-validity: Validity fingerprint sensor prototype). I removed it using yay and reboot, the login prompt showed up!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.