Blackscreen due to wrong driver and locked out

hi i think i lost mi manjaro installation (latest LTS kernel) due to me being dumb…
it happened that i had manjaro running for several days (enjoying every second of it) and then yesterday i thought i´d look if MHWD is giving my slow 2.5gbit ethernet a driver boost. i installed every driver even those for my gpu (because why not) and then in the night i went to go to bed. i clicked the shutdown but nothing moved. i clicked the shutdown again and again nothing moved. this repeated 4 times until my pc finally shutdown. today i booted into a black screen with nothing but a blinking white “_”
i searched google for aid and came to the ctrl, alt, F2 thing to open the terminal and fix things BUT here is where things get REALLY bad. i cant log in since i never set any password. since my machine is always at home and only used by me (and i cant remember stuff) i went for the no password auto-login route. so when i opened the Mate terminal in GUI and it asked for a password i could just hit enter and go my way. now in this situation i cant seem to get anywhere since everything is set up to hate me.

(sorry english is not my main tongue)

Possibly ctrl alt F3
Set root-Password:
passwd
(passwd › Wiki › ubuntuusers.de)
((and write Password down on a pice of paper, place this under your keyboard for emergency )) :innocent:

wont that prompt me for a login again? i mean it asks for a login and a password and i have neither

This is the root login. TTY2 is your konto only…
test: login as user root in TTY3
… other tipp:
https://de.manjaro.org/index.php?topic=736.0
(USB-liveISO is sufficient)

oh okay thank you i´m gonna try that in a second. first i need to shutdown this “emergency” windows leftover and boot in that wonderful manjaro. i am gonna come back and tell you how it went

Edit: soo i tried it and it is greeting me with login:
But i cant do anything because i dont have a login.

If typing root at the prompt, asks for password? Try empty PW or manjaro.

Else:
https://de.manjaro.org/index.php?topic=736.0
USB-liveISO is sufficient)

The screen goes :

Login:. (i can type what i want) then
Password: (still doesnt really matter)
Login incorrect.

Happens with login: root
Password: blank/Manjaro

Login: root
Password: manjaro
Login: root
Password: just hit “return”
Else:
https://de.manjaro.org/index.php?topic=736.0

I did. It too asks for a password. No matter what i enter it ends the same

Then you can root your system by: wie rootet man die Maschine ? (Paßwort vergessen) ?!
.
or simpler:
How to Reset Forgotten Root Password in Arch Linux
.
or this:
Forgot sudo password in MANJARO - Stack Overflow

God bless you i managed to set a massword with your link behind “or simpler:” now for that driver error🤔
So the tipp i read online said to go with “StartX”

My output is like :
Xauth : file /root/.xauthority does not exist

And way further down the screen:
Vesa: refusing to run on uefi (EE) fatal server error: (EE) no screens found

My pleasure:
grapic driver (in german:)
.
* Falscher Grafikkartentreiber, beheben: *

Währen des Startvorgang, wenn Grub angezeigt wird, die E taste drücken
und dem Kernel folgende Bootoption: 3 nomodeset hinzufügen.
Mit F10 weiter.
So gelangst du zu einen Eingabe prompt in dem du dich einloggst

und folgende Befehle nacheinander ausführst:

sudo mhwd -r pci $(mhwd -li | grep ‘video-’ | awk ‘{print $1}’
sudo mhwd -a pci free 0300

und zum Schluss

reboot

1 Like

That is the wrong way…

Error: cant find command ‘nomodeset’

NOT in the terminal- in GRUB-menu as shown here:


(Runlevel 3)

I have no grub menu. I can either start manjaro, or hit
E to go into the grub.
Oh and i can enter boot options. But none seem to take the nomodeset

That is what I mean…
Hit E as described in

I did and it says “minimal BASH-like line editing is supported” but there is just a blank screen and if i type nomodeset it says “cant find command”

This means your grub is broken…
It can be repaired easily.
But you better call: @stephane by message - he is some where expert - My time today expires shortly, sorry.

Thanks for everything i managed to fix it all in one swift move. The grub really was done for but i googled a fix and found commands to chroot into it (skipped that) and to reinstall it (skipped that too) then there was a simple one to update it and that fixed it. Sadly i dont find it anymore. BUT i still had the driver error to be fixed. So i went into TTy2 and did a quick uninstall (mhwd command thing) and after that i swiftly put a sudo mhwd -a pci free 0300 in to install the RIGHT driver. Thank you i am back in my most loved OS :heart::heart::heart::heart: