Blackscreen after login

Hi there,
I have a small issue. After losing my home partition, I created a new partition, copied the files from my timeshift snapshot to the new partition and changed the UUID in /etc/fstab. Of course I also reinstalled grub, but it somehow still pointed to the wrong partition, that’s why a un-commented this:

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

in /etc/default/grub.

Currently I’m able to boot manjaro and the login screen pops up, though after logging in nothing happens. I can still move the mouse and also open tty. When using startx following message appears:

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux Manji-home 6.1.31-1-MANJARO #1 SMP PREEMPT_DYNAMIC Tue May 30 23:14:35 UTC 2023 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64 root=/dev/sdd3 rw quiet nowatchdog apparmor=1 security=apparmor resume=UUID=6697a587-6eda-4f18-88a9-1ba83fc20b33 udev.log_priority=3
Current version of pixman: 0.42.2
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Jun  4 16:33:25 2023
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Failed to connect to bus: Operation not permitted
dbus-update-activation-environment: error: unable to connect to D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/etc/X11/xinit/xinitrc: line 52: xclock: command not found
/etc/X11/xinit/xinitrc: line 53: xterm: command not found
/etc/X11/xinit/xinitrc: line 55: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 54: xterm: command not found
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

You can find the output of journalctl -p 3 -xb here and the log file /var/log/Xorg.1.log here
If you need further information, please let me know.

EDIT: Two more things:

  • I tried to add a new user to make sure that it’s not my user account that is bugged or something. Unfortunately it still results in a black screen
  • I noticed when reinstalling grub that they released a big update for the stable branch today, maybe that broke something in my system ?

I was able to fully restore my system using timeshift. I’m still not sure why this did not work the first time, but I’m glad it did now :slightly_smiling_face:

Remeber, you might have been very lucky this time, timeshift is NOT a backup…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.