Blacklisted radeon module on kernel to force amdgpu, get black screen

I have a radeon r7 260x and i’m trying to force my system to use amdgpu drivers. In the grub default line i added modprobe.blacklist=radeon to block radeon, also enabled cik compat for amdgpu, tried with 5.4 and 5.7 kernels, none work, any idea?

Device-1: AMD Bonaire XTX [Radeon R7 260X/360] vendor: PC Partner Limited
driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0
chip ID: 1002 6658
Display: x11 server: XOrg 1.20.8 compositor: kwin_x11 driver: radeon
FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0
screens: 1
Screen-1: 0 s-res: 2726x768 s-dpi: 96 s-size: 721x203mm (28.4x8.0")
s-diag: 749mm (29.5")
Monitor-1: HDMI-0 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1")
diag: 470mm (18.5")
Monitor-2: DVI-1 res: 1360x768 hz: 60 dpi: 85 size: 406x229mm (16.0x9.0")
diag: 466mm (18.4")
OpenGL: renderer: AMD BONAIRE (DRM 2.50.0 5.7.19-2-MANJARO LLVM 10.0.1)
v: 4.5 Mesa 20.1.7 direct render: Yes


volcanic islands should be supported … but I think there was another similar thread about amdgpu not starting with it …
maybe also check for anything setting radeon in /etc/X11/{mhwd,xorg.conf}.d/ ?

Your pastebin link is dead, FYI.
EDIT: Fixed it.

You could try the amdgpu-experimental repo package, it should set everything properly. If you can’t boot after installing it, just switch to a TTY, uninstall it and reboot.

Experimental worked, but now I have a new problem, my second monitor wont work. If it matters, its being recognized… In KDE settings I can see it, windows are on it, and I can disable it to bring everything to one monitor… There is just no image at all, it goes into power saving mode immediately after grub, never showing anything

thats the new dmesg, with one screen working and the other just in eco mode, if there is anything else I can provide, please tell me so