Black screen XFCE LDM failed after ceph update

Hello, last night I let update of ceph running, today morning I came back and black screen welcomed me, no response on mouse/keyboard.
After restart I saw “[FAILED] Failed to start Light Display Manager”.
I managed to log into bash via ctrl + alt + F2 and ran sudo lightdm Same message again: “[FAILED] Failed to start Light Display Manager”
Next I went to journalctl -xe and was looking for some clue, but I see only that ldm exited with 1, no further details.
I will add screenshot into next post in this thread. And that’s it. Don’t know what’s next. Anyone has a clue?

messing around with journalctl -u lightdm.service showed that LDM is restarting all over again, until it reaches approx 150 attempts, then it shuts down.

This Is the journalctl -xe output where I’ve spotted ldm exited with 1.

ive seen recently so many issues with xfce/lightdm after a update…
from tty remove the ceph package:
sudo pacman -Rs ceph-libs
and rerun update again:
sudo pacman -Syyu
if you are up to date post picture of:
mhwd -l -li

I think you provided the answer in your topic subject.

Try searching for ceph - there has been several topics - I think moved to AUR?

Thank you, that worked! Here is the output of mhwd -l -li
Visible on the top that pacman -Syyu had nothing to update.
I have managed to start ldm now and managed to restart with ldm starting automatically.

you have installed only video-linux, why dont you have also installed the nvidia drivers? is there a reason for it?

I don’t need them. This is a laptop for work, and I took this variant with nvidia graphics only in case I’d like to play games at some point in the future.

well, you are now using the open source drivers, which are bad… so your nvidia is still powered, the open source drivers probably dont even have any proper power saving features, so your nvidia is consuming more power that it should, your pc is overheating more than it should… and they can cause also all kinds of other issues…

i would install the proper nvidia drivers:
sudo mhwd -a pci nonfree 0300
then install envycontrol for switching to intel and disabling nvidia (thats what im using)
pamac build envycontrol
switch to integrated:

sudo envycontrol -s integrated

it will prompt you for reboot so do it, and then verify with:
inxi -G
if nvidia is disabled/not detected

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.