Black screen with the only the cursor on suspension in intel graphics

Hi everyone , i am new to linux and this forum.The hardware and software details of my pc are

System:    Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 
           wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Vostro 3491 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 02P5GF v: A00 serial: <filter> UEFI: Dell v: 1.13.0 date: 11/13/2020 
Battery:   ID-1: BAT0 charge: 32.2 Wh (89.0%) condition: 36.2/42.0 Wh (86.1%) volts: 12.3 min: 11.4 
           model: SWD-ATL3.618 DELL WJPC407 type: Li-ion serial: <filter> status: Discharging 
Memory:    RAM: total: 7.54 GiB used: 2.33 GiB (30.9%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake rev: 5 cache: L2: 6 MiB 
           bogomips: 19048 
           Speed: 1201 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1201 2: 1200 3: 1200 4: 1201 5: 1200 6: 1201 7: 1201 
           8: 1200 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 
           avx512_bitalg avx512_vbmi2 avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma avx512vbmi 
           avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts 
           epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp 
           hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
           monitor movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni 
           popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse 
           sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes 
           vme vmx vnmi vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:8a56 
           class-ID: 0300 
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-6:3 chip-ID: 0bda:5675 class-ID: 0e02 
           serial: <filter> 
           Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel s-res: 1920x1080 s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:34c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
           Sound Server-2: sndio v: N/A running: no 
           Sound Server-3: JACK v: 1.9.19 running: no 
           Sound Server-4: PulseAudio v: 14.2 running: yes 
           Sound Server-5: PipeWire v: 0.3.32 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 3000 
           bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: 3000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 0cf3:e009 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Logical:   Message: No logical block device data found. 
RAID:      Message: No RAID data found. 
Drives:    Local Storage: total: 1.14 TiB used: 18.26 GiB (1.6%) 
           ID-1: /dev/nvme0n1 model: CL1-3D256-Q11 NVMe SSSTC 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 type: SSD 
           serial: <filter> rev: 22301114 temp: 35.9 C scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB speed: 6.0 Gb/s type: HDD rpm: 7200 
           serial: <filter> rev: SDM2 scheme: GPT 
           Message: No optical or floppy data found. 
Partition: ID-1: / size: 233.38 GiB used: 18.26 GiB (7.8%) fs: ext4 dev: /dev/nvme0n1p2 label: N/A 
           uuid: 3e5b22d8-9c7d-49ce-931b-9de17e9a039b 
           ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 label: NO_LABEL uuid: B137-A015 
Swap:      Alert: No swap data was found. 
Unmounted: ID-1: /dev/sda1 size: 128 MiB fs: <superuser required> label: N/A uuid: N/A 
           ID-2: /dev/sda2 size: 931.39 GiB fs: ntfs label: DATA uuid: B8DA480CDA47C57A 
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
           Device-1: 1-5:2 info: Shenzhen Goodix Fingerprint Reader type: Abstract (modem),CDC-Data driver: cdc_acm 
           interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 27c6:5301 class-ID: 0a00 serial: <filter> 
           Device-2: 1-6:3 info: Realtek Integrated_Webcam_HD type: Video driver: uvcvideo interfaces: 2 rev: 2.0 
           speed: 480 Mb/s power: 500mA chip-ID: 0bda:5675 class-ID: 0e02 serial: <filter> 
           Device-3: 1-10:4 info: Qualcomm Atheros type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
           power: 100mA chip-ID: 0cf3:e009 class-ID: e001 
           Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 251 Uptime: 15m wakeups: 1 Init: systemd v: 248 Compilers: gcc: 11.1.0 Packages: pacman: 1153 
           Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

My xorg config files for intel is

Section "Device" 
Identifier "Intel Graphics" 
Option "AccelMethod" "uxa"
Driver "intel" 

On suspension , i just get a black screen with just the cursor. I am using Ctrl+Alt+F2 and startx command to start the GUI .But all the previously opened windows are lost . Can someone please help me with this?

1 Like

Hello mate,

I had the exact same issue (albeit on ryzen cpu, not intel) on the 5.10 kernel. I solved it by moving on to 5.14 version.

I’ve been using it for a while and things work fine (it says experimental right now, so my 2 cents).

1 Like

I will try switching to 5.14 version of the kernel . Thanks for your idea,

I tried switching to linux 5.14 , but i still get the same black screen with just a cursor.Issue was not solved.

what’s the output of

systemctl status sddm

The output for systemctl status sddm is

`● sddm.service - Simple Desktop Display Manager
     Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-08-06 12:17:09 IST; 38min ago
       Docs: man:sddm(1)
   Main PID: 412 (sddm)
      Tasks: 7 (limit: 9243)
     Memory: 99.7M
        CPU: 7.598s
     CGroup: /system.slice/sddm.service
             ├─412 /usr/bin/sddm
             └─548 /usr/lib/Xorg -nolisten tcp -background none -seat seat0 vt1 -auth /var/run/sddm/{96618abf-d44b-48c7-96f8-46f49c7fee0c} -noreset -displayfd 17

Aug 06 12:17:12 linux sddm-helper[766]: [PAM] returning.
Aug 06 12:17:12 linux sddm-helper[766]: pam_systemd_home(sddm-autologin:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Aug 06 12:17:12 linux sddm[412]: Authenticated successfully
Aug 06 12:17:12 linux sddm-helper[766]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
Aug 06 12:17:12 linux sddm-helper[766]: pam_unix(sddm-autologin:session): session opened for user kathir7(uid=1000) by (uid=0)
Aug 06 12:17:13 linux sddm-helper[766]: pam_env(sddm-autologin:session): deprecated reading of user environment enabled
Aug 06 12:17:13 linux sddm-helper[766]: gkr-pam: gnome-keyring-daemon started properly
Aug 06 12:17:13 linux sddm-helper[766]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: pam_sm_open_session
Aug 06 12:17:13 linux sddm-helper[766]: Starting: "/usr/share/sddm/scripts/Xsession \"/usr/bin/startplasma-x11\""
Aug 06 12:17:13 linux sddm[412]: Session started`

did you try to restart the sddm service ‘sudo systemctl restart sddm’ via console ?

I tried restarting the sddm service , but i still get the black screen error

what is output of journalctl -b -p 0..3

The output for journalctl -b -p 0..3 was

-- Journal begins at Thu 2021-07-29 22:18:21 IST, ends at Fri 2021-08-06 13:53:02 IST. --
Aug 06 12:17:08 linux kernel: x86/cpu: SGX disabled by BIOS.
Aug 06 12:17:09 linux kernel: tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead
Aug 06 12:17:09 linux kernel: psmouse serio1: elantech: elantech_send_cmd query 0x02 failed.
Aug 06 12:17:09 linux kernel: psmouse serio1: elantech: failed to query capabilities.
Aug 06 12:17:14 linux kwin_x11[840]: kwin_xkbcommon: XKB: couldn't find a Compose file for locale "en_IN"
Aug 06 12:31:46 linux pulseaudio[932]: module-x11-xsmp may not be loaded twice.
Aug 06 12:31:46 linux pulseaudio[932]: Failed to load module "module-x11-xsmp" (argument: "display=:1 xauthority=/home/kathir7/.Xauthority session_manager=local/linux:@/t>
Aug 06 12:34:24 linux systemd-coredump[3427]: [🡕] Process 3345 (systemsettings5) of user 1000 dumped core.
                                              Stack trace of thread 3345:
                                              #0  0x00007f0ed7111c4b _ZN14QObjectPrivate13addConnectionEiPNS_10ConnectionE ( + 0x2e2c4b)
                                              #1  0x00007f0ed71166fc _ZN14QObjectPrivate11connectImplEPK7QObjectiS2_PPvPN9QtPrivate15QSlotObjectBaseEN2Qt14ConnectionTypeE>
                                              #2  0x00007f0ed7116bd6 _ZN7QObject11connectImplEPKS_PPvS1_S3_PN9QtPrivate15QSlotObjectBaseEN2Qt14ConnectionTypeEPKiPK11QMeta>
                                              #3  0x00007f0eb5640fb9 n/a ( + 0x39fb9)
                                              #4  0x00007f0ed5fab456 _ZN17QQmlObjectCreator14createInstanceEiP7QObjectb ( + 0x2fb456)
                                              #5  0x00007f0ed5fae56a _ZN17QQmlObjectCreator18setPropertyBindingEPK16QQmlPropertyDataPKN3QV412CompiledData7BindingE (libQt5>
                                              #6  0x00007f0ed5faeb10 _ZN17QQmlObjectCreator13setupBindingsEb ( + 0x2feb10)
                                              #7  0x00007f0ed5faa9c4 _ZN17QQmlObjectCreator16populateInstanceEiP7QObjectS1_PK16QQmlPropertyData ( + 0x2fa9c4)
                                              #8  0x00007f0ed5fab9e5 _ZN17QQmlObjectCreator14createInstanceEiP7QObjectb ( + 0x2fb9e5)
                                              #9  0x00007f0ed5fac676 _ZN17QQmlObjectCreator6createEiP7QObjectP26QQmlInstantiationInterrupti ( + 0x2fc676)
                                              #10 0x00007f0ed5fabdff _ZN17QQmlObjectCreator14createInstanceEiP7QObjectb ( + 0x2fbdff)
                                              #11 0x00007f0ed5fae56a _ZN17QQmlObjectCreator18setPropertyBindingEPK16QQmlPropertyDataPKN3QV412CompiledData7BindingE (libQt5>
                                              #12 0x00007f0ed5faeb10 _ZN17QQmlObjectCreator13setupBindingsEb ( + 0x2feb10)
                                              #13 0x00007f0ed5faa9c4 _ZN17QQmlObjectCreator16populateInstanceEiP7QObjectS1_PK16QQmlPropertyData ( + 0x2fa9c4)
                                              #14 0x00007f0ed5fab9e5 _ZN17QQmlObjectCreator14createInstanceEiP7QObjectb ( + 0x2fb9e5)
                                              #15 0x00007f0ed5fac676 _ZN17QQmlObjectCreator6createEiP7QObjectP26QQmlInstantiationInterrupti ( + 0x2fc676)
                                              #16 0x00007f0ed5fabdff _ZN17QQmlObjectCreator14createInstanceEiP7QObjectb ( + 0x2fbdff)
                                              #17 0x00007f0ed5fac676 _ZN17QQmlObjectCreator6createEiP7QObjectP26QQmlInstantiationInterrupti ( + 0x2fc676)
                                              #18 0x00007f0ed5f37fa5 _ZN20QQmlComponentPrivate11beginCreateEP15QQmlContextData ( + 0x287fa5)
                                              #19 0x00007f0ed5f389fb _ZN13QQmlComponent6createEP11QQmlContext ( + 0x2889fb)
                                              #20 0x00007f0ed87769e4 n/a ( + 0x229e4)
                                              #21 0x00007f0ed877212e _ZN14KCModuleLoader10loadModuleERK12KCModuleInfoNS_14ErrorReportingEP7QWidgetRK11QStringList (libKF5K>
                                              #22 0x00007f0ed877dc2a n/a ( + 0x29c2a)
                                              #23 0x00007f0ed877e8cb _ZNK13KCModuleProxy10realModuleEv ( + 0x2a8cb)
                                              #24 0x00007f0ed87bb719 _ZN10ModuleView20updatePageIconHeaderEP15KPageWidgetItemb ( + 0x14719)
                                              #25 0x00007f0ed87bcbfd _ZN10ModuleView9addModuleEP12KCModuleInfoRK11QStringList ( + 0x15bfd)
                                              #26 0x00007f0ed87bd0b6 _ZN10ModuleView10loadModuleERK11QModelIndexRK11QStringList ( + 0x160b6)

Try to switch to Wayland, if it works?

i downloaded wayland using sudo pacman -S plasma-wayland-session but to enable wayland i need that login screen which i don’t arrive at . Any other way to go over this?

I had to restart twice after changing kernel for the issue to settle down. Maybe give that a shot once ?

yeah @lePAT i tried restarting multiple times , now the kernel version is 5.14 but the issue still persists.
As a temporary fix i had disabled the lock screen option .

If you do not arrive the login, you have to press Strg + Alt + F4 to open TTY terminal, there you can login then you disable wayland. Then press Strg + Alt + F1 to back normal Desktop login.

@Zesko i tried enabling and disabling wayland , but the problem still persists. Thanks for you idea though

Try creating a new user in the console: It’s your session that is crashing, not the boot so:

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • All the commands that follow are root commands, so precede them with sudo

  • Execute:

    useradd kathir2
  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups kathir
    groups kathir2

    (Where obviously, kathir is your old user and kathir2 is your new one.)
    E.G. if kathir is a member of operator and kathir2 isn’t, execute:

    usermod --append --groups operator kathir2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/kathir/Documents/* /home/kathir2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/kathir/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/

    After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock kathir

    If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the same issue crops up again, roll back your last change and thus you’ve now pinpointed the exact setting that made your old user misbehave. :thinking:

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

@Fabby i just found out that if i changed my AccelMethod to “sna” the login issue gets resolved.But setting the AccelMethod to “sna” causes the screen sharing issue where while sharing the screen in some platform like google meet some random previous instance of the screen gets shared.So the problem is in the Intel GPU configuration . I tried setting AccelMethod to “blt” and i get the screen sharing issue.I am stuck in a deadlock as how to assign a method to AccelMethod.In “uxa” screen sharing works normal but the login fails , in the other two methods screen sharing doesn’t work but the black screen bug is resolved. Can someone provide a solution for this please?

Thread hijacking is against the forum rules, but you can push the Tracking or Watching on the bottom of any post to be kept informed and then you can apply the same Solution once one gets posted.

Although I’m a moderator, this is not an official warning; just helping you get accustomed to the forum.