Black screen with movable pointer on each resume

I’m constantly facing the issue “Black screen with movable pointer” each time I open up my laptop lid (resume action).
(Yes, I’m able to open another TTY with ctrl+alt+F2 - but how does it help me?)

Details:

$ inxi -Fb
System:    Host: roman-pc Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: G3 3779 v: N/A serial: <superuser/root required>
           Mobo: Dell model: 04R93M v: A00 serial: <superuser/root required> UEFI: Dell v: 1.2.1 date: 07/18/2018
Battery:   ID-1: BAT0 charge: 31.8 Wh condition: 31.8/56.0 Wh (57%)
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP L2 cache: 9216 KiB
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
           9: 800 10: 800 11: 800 12: 800
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 450.66
           Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 1060 with Max-Q Design/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66
...

Besides of resume phase, the problem now occurs even on/after “Lock screen” action.

Adding .xinitrc contents for additional info:

$ cat .xinitrc
nvidia-settings --load-config-only
exec startplasma-x11

All information edited into one question for your convenience.

There is no silver bullet to debug these kinds of issues, so the best we can do is to point you to the kernel debugging page for suspension and hibernation:

https://www.kernel.org/doc/html/latest/power/basic-pm-debugging.html

If you would run into issues over there, please feel free to post additional specific questions in this thread: no need to open a new one.

:innocent:

Today it’s happened even on reboot (after “boot” menu - before/preventing login page) phase.
When switching to another TTY with ctrl+alt+F2 I faced the message:

...
The X11 connection is broke (error 1). Did the X11 server die?

After executing startx the Login page emerged.

Right after you get that error a:

journalctl --catalog --pager-end | grep --ignore-case X11 | tail --lines=20

would be beneficial…

:innocent:

Sure, here it is:

$ journalctl --catalog --pager-end | grep --ignore-case X11 | tail --lines=20
вер 19 10:44:39 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 8457, resource id: 88080391, major code: 18 (ChangeProperty), minor code: 0
вер 19 10:44:40 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 8461, resource id: 88080393, major code: 18 (ChangeProperty), minor code: 0
                                                      #4  0x00007ffa79fc84b9 _XReply (libX11.so.6 + 0x414b9)
вер 19 10:44:41 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 8462, resource id: 2097253, major code: 20 (GetProperty), minor code: 0
вер 19 10:44:41 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 8463, resource id: 2097253, major code: 15 (QueryTree), minor code: 0
вер 19 10:44:46 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 13870, resource id: 109051905, major code: 15 (QueryTree), minor code: 0
вер 19 10:44:55 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 24560, resource id: 2097272, major code: 15 (QueryTree), minor code: 0
вер 19 10:45:03 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 30928, resource id: 102760454, major code: 15 (QueryTree), minor code: 0
вер 19 10:45:03 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 31465, resource id: 79691796, major code: 18 (ChangeProperty), minor code: 0
вер 19 10:45:08 roman-pc kwin_x11[365952]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 35985, resource id: 60817446, major code: 15 (QueryTree), minor code: 0
вер 19 10:46:30 roman-pc kwin_x11[365952]: file:///usr/lib/qt/qml/org/kde/plasma/components/Button.qml:52: ReferenceError: PlasmaCore is not defined
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:406:376: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:407:126: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:408:126: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:408:385: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:409:125: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:410:124: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:411:125: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:411:371: Could not add child element to parent element because the types are incorrect.
вер 19 10:46:31 roman-pc kwin_x11[365952]: qt.svg: <input>:411:619: Could not add child element to parent element because the types are incorrect.

Weird! Does this also happen when you create another user, log in there and try suspending there?

If yes, please go back to the kernel Hibernate debugging manual

If no, please report back.

:innocent:

I’ve created another test user and it gets into the same trouble on resume phase.
How the mentioned debugging helps in terms of “fixing the issue”?
Any chance that additional info I could provide here can clarify the further ways of resolving the issue?

Sorry: trying to answer too many new questions at the same time.

This started out as a suspend / resume issue but it’s worsening into an X11 issue which I don’t know enough about yet to help you any further.

:sob:

Got some “new” errors on today’s morning start:

$ journalctl --catalog --pager-end | grep -iE 'x11|plasma|xcb' | tail --lines=60
                                                 Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.
вер 21 08:42:20 roman-pc systemd-coredump[9806]: Process 9160 (plasmashell) of user 1000 dumped core.
                                                    #14 0x00007f86807fd68b _dl_fini (ld-linux-x86-64.so.2 + 0x1168b)
                                                    #17 0x00007f867d4e4642 _XDefaultIOError (libX11.so.6 + 0x43642)
                                                    #18 0x00007f867d4e48ee _XIOError (libX11.so.6 + 0x438ee)
                                                    #19 0x00007f867d4e28fa _XReply (libX11.so.6 + 0x418fa)
░░ Subject: Process 9160 (plasmashell) dumped core
░░ Process 9160 (plasmashell) crashed and dumped core.
вер 21 08:42:22 roman-pc systemd-coredump[9714]: Process 3139 (kwin_x11) of user 1000 dumped core.
░░ Subject: Process 3139 (kwin_x11) dumped core
░░ Process 3139 (kwin_x11) crashed and dumped core.
вер 21 08:42:23 roman-pc kglobalaccel5[9881]: qt.qpa.xcb: could not connect to display :2
вер 21 08:42:23 roman-pc kglobalaccel5[9881]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
                                                 Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.
вер 21 08:42:24 roman-pc kglobalaccel5[9885]: qt.qpa.xcb: could not connect to display :2
вер 21 08:42:24 roman-pc kglobalaccel5[9885]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
                                                 Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.
вер 21 08:43:15 roman-pc plasmashell[1369]: file:///usr/lib/qt/qml/QtQuick/Controls/Styles/Plasma/ToolButtonStyle.qml:209:13: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
вер 21 08:43:15 roman-pc plasmashell[1369]: file:///usr/lib/qt/qml/QtQuick/Controls/Styles/Plasma/ToolButtonStyle.qml:209:13: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
вер 21 08:43:17 roman-pc kwin_x11[1307]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 48839, resource id: 62914565, major code: 18 (ChangeProperty), minor code: 0
вер 21 08:43:18 roman-pc kwin_x11[1307]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 49040, resource id: 62914565, major code: 18 (ChangeProperty), minor code: 0
вер 21 08:43:23 roman-pc kwin_x11[1307]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 50206, resource id: 62914565, major code: 18 (ChangeProperty), minor code: 0
вер 21 08:43:25 roman-pc kwin_x11[1307]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 50600, resource id: 62914565, major code: 18 (ChangeProperty), minor code: 0
вер 21 08:43:38 roman-pc plasmashell[1369]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:151: TypeError: Cannot read property 'ports' of undefined
вер 21 08:43:38 roman-pc plasmashell[1369]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/main.qml:550:39: QML DeviceListItem: Binding loop detected for property "width"
вер 21 08:43:46 roman-pc dbus-daemon[3030]: [session uid=1000 pid=3030] Activating service name='org.kde.KSplash' requested by ':1.129' (uid=1000 pid=10043 comm="startplasma-x11 ")
вер 21 08:43:47 roman-pc dbus-daemon[3030]: [session uid=1000 pid=3030] Activating service name='org.kde.ActivityManager' requested by ':1.137' (uid=1000 pid=10090 comm="/usr/bin/kwin_x11 ")
вер 21 08:43:48 roman-pc NetworkManager[740]: <info>  [1600667028.3928] agent-manager: agent[119f9bf84f119981,:1.751/org.kde.plasma.networkmanagement/1000]: agent registered
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: Detected XRandR 1.6
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: Event Base:  89
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: Event Error:  147
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: RRNotify_OutputChange
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Output:  445
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         CRTC:  441
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Mode:  446
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Rotation:  "Rotate_0"
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Connection:  "Connected"
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Subpixel Order:  0
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: RRScreenChangeNotify
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Window: 44040197
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Root: 606
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Rotation:  "Rotate_0"
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Size ID: 0
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Size:  1920 1080
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         SizeMM:  602 343
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper: RRNotify_OutputChange
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Output:  445
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         CRTC:  441
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Mode:  446
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Rotation:  "Rotate_0"
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Connection:  "Connected"
вер 21 08:43:49 roman-pc kscreen_backend_launcher[10210]: kscreen.xcb.helper:         Subpixel Order:  0
                                                     #1  0x00007f896b8f563b n/a (libxcb.so.1 + 0xc63b)
                                                     #2  0x00007f896b8f708f n/a (libxcb.so.1 + 0xe08f)
                                                     #3  0x00007f896b8f7203 xcb_wait_for_reply64 (libxcb.so.1 + 0xe203)
                                                     #4  0x00007f896b9594b9 _XReply (libX11.so.6 + 0x414b9)
                                                     #1  0x00007f4ba2da063b n/a (libxcb.so.1 + 0xc63b)
                                                     #2  0x00007f4ba2da208f n/a (libxcb.so.1 + 0xe08f)
                                                     #3  0x00007f4ba2da2203 xcb_wait_for_reply64 (libxcb.so.1 + 0xe203)
                                                     #4  0x00007f4ba2e044b9 _XReply (libX11.so.6 + 0x414b9)

Additionally, some peculiar issue also comes in:
when I try to lock-screen with my standard command Ctrl+Alt+L - the screen is just gets frozen (making desktop space like a screenshot) having mouse pointer active but nothing is clickable/responsive.

Re-iterating what I said before:

:man_shrugging:

OK, can we add (or replace kde with) “X11” keyword/tag to the title post?
(I don’t have a privilege of editing my posts)

Today my system went badly further:
After 20 minutes idling it made “Dim screen” action with “Lock screen” automatically (due to the settings) and the primary issue happened again.
Switching to ctrl+alt+F2 has shown the screen ended with errors like:

Could not load Qt platform ...
...
can't open display
Failed to run xrandr ...
Gtk-warning ** ...
Startup Error: Unable to detect graphics environment