Black screen with mouse pointer after login after screen lock, again

lot of gratitude for your energy, time and effort, it’s been encouraging for me to continue :+1:

1 Like

So the session is there, but has no TTY on it.

I have NOT gotten my nvidia + hibernate to work, I simply gave up and ONLY use sleep and shutdown, and have no problem with that.
But I AM on KDE, not xfce so…

I have very limited knowledge about these stuff, but the session IS there, the question is why no TTY.

My guess is it has something to do with PAM and security.

Sorry, that is my previous/original post when I got the issue for the first time.
I linked that topic in the initial post of this topic.
Sorry if I was not more clear/explicit that this is a continuation of that one.
My apologies!

I’ll check that wiki, thanks

I am using manjaro with xfce since 2019 and suspend, hibernate, lock, shutdown, reboot worked always fine, as far as I recall, until this issue.

Sorry, I have no more input, maybe someone else can help. :frowning:

lot of gratitude for your help as well, much encouraging to continue :+1:

I’ll be posting my progress, hope this topic not get closed so quickly.

Thanks for everyone helping!!!


Tried EndevorOS latest version with Xfce. Works fine, no issues after multiple poweroff, reboot, suspend, lock and normal work (browser, editor, terminal, etc.) It does not use light-locker.

Tried Manjaro GNOME 23.1.0 with kernel 6.6 and linux66-nvidia 545.29.06-24. I am testing this installation last two days and works with no problem after many combinations of poweroff, reboot, suspend, lock and normal work (browser, editor, terminal, etc.) Until now this is best candidate to switch to.

Tried Manjaro 23.1.0 with kernel 6.6 and linux66-nvidia 545.29.06-24. Result: Issue appears after few combinations of reboot, suspend, lock.

Next, I’ll try Manjaro KDE. If this also works, I’ll have to decide between GNOME and KDE.

New update.

Tested Manjaro KDE 23.1.0 but did not like the mixed resolution multi-display support, and too many cluttered setting panels.

So, finally decided for Manjaro KDE GNOME. Until now everything works fine: Suspend, lock, multi-display setup is acceptable. Hope it continues like that and this is my last post on this topic.

Thanks to every one that helped and shared knowledge. That convinced me to stay with Manjaro!


Wow…I hope I don’t have to do anything as drastic as switching to another DM. I repro’ the XFCE issue described here and I’ve been trying various workarounds. Sounds like this is still unresolved? I’ll keep poking around, but if a resolution is found, please link or describe it here. Thanks very much.

UPDATE: I lasted 3 days after rolling back to 5.15.144-1-MANJARO, but got a repro’ this morning, so just disabling power options for the dual displays for now, just to stabilize. I’ll give the next big patch a try when the nvidia driver is updated, but I gather that root cause hasn’t been identified (?). Thanks.

FINAL UPDATE (I hope): Well, the last round of patches–including Nvidia and 5.15.145-1-MANJARO updates–failed to address the issue. In fact, I got the black screen repro’ after the first light-locker screen lock. So…
I installed lxdm and set it to default. I don’t want to jinx anything, but I’m on Day 3 without any problems. I didn’t uninstall the light-locker / lightdm bits; I just disabled them in favor of lxdm which, it turns out, looks and performs much better than the previous XFCE default scheme. It’s much faster, and I haven’t noticed any perf degradation over time–increased response time was a precursor to lightdm / light-locker failure.
…Fingers Crossed.


Sorry, I’m a bit late here and most of the answers here have been going way over my head.

I have been suffering from an extremely similar problem for about a couple weeks, though in my case it appears it wasn’t specifically the screensaver + screen lock that was causing any problems; I increased the time before “sleep” to 60 minutes and, if I try inputting my password shortly after the screensaver starts and the screen locks (but before the computer goes to sleep), I do not get the “black screen with functional cursor”. Which makes me strongly suspect it’s the computer going to Suspend that is causing the “black screen and functional cursor” issue.

I don’t see any options to prevent the computer from going to sleep. In Power Management → Display there’s a setting (currently turned on) that, according to the floating tooltip, makes DPMS manage power instead of letting X11 do it. Presumably, turning that option off would let X11 take over power management, but I have no way to access X11 that I can tell.

I looked at that “lxdm” thing mentioned in the post right before mine and it says it’s an X11 display manager! Sounds like exactly what I needed (provided there’s an option to prevent the computer from going into Suspend).

Should I install it and try? I’m somewhat afraid to break things (I have no idea what I’m doing) but this problem is highly disruptive and I’d be willing to give it a shot.

I just followed the Manjaro article for installing lxdm and it worked great. Just two commands: one to install, the other to enable as default–that’s it. I didn’t bother to uninstall light-locker / lightdm.

sudo pacman -S lxdm
sudo systemctl enable lxdm.service --force

System has been stable since the install. btw: the article uses pamac, but I just installed via pacman. Good Luck!

You might have found KDE with Wayland to have better multi-monitor support. As with all DE’s, however, it usually takes more than a few days use to appreciate the benefits, and KDE is no exception to the rule.

Clearly. There is always a method to change or even disable suspend; often in combination with other related settings. The exact method and location of these settings will vary between DE’s, so, don’t give up!

Remember, you can always ask “What does this button do?” and someone will likely be able to tell you. Cheers.

I tried it, and… now my login screen is super weird (it’s blue and wants me to confirm my username before I can input my password), and I can’t lock my screen anymore, the button does nothing.

Can I uninstall this thing without breaking things further? At this point I’d rather keep searching for a way to disable Suspend.

You may wanna look at my solution for it.

1 Like


I uninstalled lxdm hoping to fix what was broken. And now everything that was broken is still broken, and on top of that my computer boots straight into the terminal. I had to access the internet on my laptop to find out how to even get to my DE from there (which fortunately is super simple, it’s “startx” if anyone wonders).

Can anyone please tell me how to revert what lxdm did, or at the very least restore my computer’s ability to lock the screen? Most importantly, how to do so without breaking anything further?

These were the lines that broke my login and my screen lock capabilities:

sudo pacman -S lxdm
sudo systemctl enable lxdm.service --force

Drat. Sorry about that. I described a fix that worked for me, but which obviously didn’t work on your system. Getting back to the default marriage of XFCE and lightdm / light-locker should be easy. I would just disable any suspend / sleep / lock in the power settings, then reinstall / force lightdm, then redo your preferred power scheme. I’m using only one setting: shut off display after one hour. Also, not that it’s necessarily related, but I’m back on 5.15.145-1-MANJARO.
FWIW, you’re doing exactly what I have been doing since I first migrated to this distro from Crux Linux three years ago: poking around on the boards whenever something breaks. …pretty much all you can do. I love using Linux, but I’ve learned to live with the fact that to one degree or another, it’s a time bomb. In case it helps the spec’s for my system are here:

Yeah, I didn’t think there was anything malicious to it, sometimes something works for someone and not for another.

I have lightdm installed, is the line to force it the same as lxdm’s except with lightdm?

I’m thankful that Linux exists, it’s the last usable OS. But every few months, even with Manjaro delaying releases in case there are issues, and even with me waiting an extra week for the issues that get by… some still get through the cracks, and trying to fix them is long, stressful, irritating, and as likely to break something else as it is to help. I’m just a normal person, not a tech expert. But I guess it’s the price I have to pay for having a computer.

EDIT: to fix the lxdm thing, I just had to reenable lightdm using

systemctl enable lightdm

That’s it.

However the black screen problem is back, and this time it happened without a Suspend (I literally locked the screen moved my mouse a couple seconds later, entered my password, and got the black screen). I’ll have to find a fix for that somewhere.

A post was split to a new topic: Black screen - only pointer is visible