Black screen with cursor after installing NVIDIA proprietary drivers

with 2 cards nvidia , this is not possible , no support of NV dual link
only one can works

1 Like

Okay, so do I just unplug one and it should work?
My main goal was to do a GPU passthrough to a VM for the GTX 950 anyways.

yes only one plugged it should works

you may get this log with iommu=pt

iommu: Default domain type: Passthrough (set via kernel command line)
kernel: pci 0000:0a:00.0: Adding to iommu group 26
kernel: pci 0000:00:00.2: AMD-Vi: Found IOMMU cap 0x40
kernel: AMD-Vi: Extended features (0x58f77ef22294a5a, 0x0): PPR NX GT IA PC GA_vAPIC
kernel: AMD-Vi: Interrupt remapping enabled
kernel: PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
kernel: software IO TLB: mapped [mem 0x00000000b1fb1000-0x00000000b5fb1000] (64MB)
kernel:LVT offset 0 assigned for vector 0x400
1 Like

For that indeed you will need later to do as @stephane explained.

To get your system booting, use just one card. Before you will add back the second one you will have to get the BusID PCI for that card and add it to the /etc/X11/mhwd.d/nvidia.conf file.

Sometimes booting with nomodeset instead of quiet helps, even without the nvidia.conf, but with multiple Monitors things will get unpredictable …

1 Like

Okay I just took out my GTX 950 and the monitor plugged into it. Now, were only dealing with one monitor plugged into my GTX 750 Ti. How do I get the BusID PCI? Also, I uninstalled all NVIDIA drivers from earlier. Do you want me to reinstall them?

After booting with just one card and one monitor I got the same result. I am still able to access tty2, as mentioned earlier.

If I really need to, I can reinstall Manjaro with the open source drivers, and at least have access to a desktop. But I’ll need to know how to get the proprietary drivers working correctly.

If you boot the live USB with Proprietary Drivers, is it working?
Might want to install from TTY the video-nvidia and see if after that you can boot.

I also recommend, as in my case never gave me troubles, to enable early KMS

The quickest way to get the BusID is via Nvidia Settings, i can’t recall right now the command :sweat_smile:

1 Like

if you have a terminal or console TTY

sudo mhwd -a pci nonfree 0300

No, booting from a live USB with proprietary drivers yields the same black screen.

After installing video-nvidia using

sudo mhwd --install pci video-nvidia

I got the same exact black screen.

can you recheck
on UEFI motherboard

advanced cpu
SVM is on

and retry , dont forget to add on boot kernel “iommu=pt” with USB iso live manjaro

1 Like

I can’t seem to find SVN. I see the following:

PSS Support
NX Mode
SVM Mode
SMT Mode
AMD fTPM switch

So do you want me to go into the grub file of the live USB and add iommu=pt?

this one
before booting grub , add “iommu=pt”
with non free drivers

1 Like

Oh okay. It was already enabled.

Wait! The live USB just worked with proprietary drivers! I am at a desktop right now.

If I install Manjaro from this, will it give me the proprietary drivers on my installation?

yes for the drivers
not for boot kernel
from USB live manjaro apply this and add option “iommu=pt”

from Terminal

sudo manjaro-chroot -a
nano /etc/default/grub
save (Ctrl+X)
exit ( end-chroot )
1 Like

Okay, I did all that in the chroot. Now I can install Manjaro again from the live USB?

you have already installed
boot kernel is changed

is nvidia drivers video installed on disk ?

1 Like

So then I don’t need to reinstall a new installation?

I did install nvidia drivers on the SSD yes.

then let try , reboot , remove USB live iso ,
and select from UEFI motherboard

1 Like

Okay I booted into the Manjaro on my system from the UEFI menu. Same black screen.

is there any flash _ on left upper corner ?

1 Like

No, just some frozen text and a movable cursor.