Black screen while boot


I’ve recently made updates of my software and updated kernel to 5.10 and I got a black screen after reboot.

So I thought the problem was in the kernel/drivers incompatibility so decided to switch back to oldest kernel.
Now I have 5.10.52-1, 5.4-134-1, 4.14.240-1 and 4.9.276-1 versions, but neither of them work.

I already used

sudo pacman-mirrors -f3
sudo pacman -Syyu

and all the soft for kernels mentioned including nvidia utilities was updated, but the problem is still here.

In logs I can see troubles with Xorg

sudo journalctl -p 3 -xb
Process 1254 (Xorg) of user 120 dumped core

my hardware:

Please help me to find the reason and to solve the issue with black screen.


Try this:

Hey @megavolt

Thanks for try, but it didn’t help. Still black screen :frowning:

Then please post a full xorg log.

cat /var/log/Xorg.0.log | curl -F'file=@-'

This will upload the log and print a short url. Please post the link here then.

@megavolt please find it here:

[     3.196] Current Operating System: Linux denis-zephyrus-g14 5.9.16-1-MANJARO #1 SMP PREEMPT Mon Dec 21 22:00:46 UTC 2020 x86_64

Linux59 is EOL and the nvidia driver for this kernel has been removed from the repo. I guess you miss the time to change it. Stable ones goes EOL after 3 Months.

Remove kernel:

mhwd-kernel -r linux59


pamac remove linux59

Reinstall the driver:

mhwd -l
mhwd -li
sudo mhwd -r pci <driver>
sudo mhwd -i pci <driver>

replace <driver> with config of mhwd -l like video-nvidia.

@megavolt I am booted on 5.10.52-1 (linux510) and the commands you’ve proposed are invalid:

upps… my failure… it is:

mhwd-kernel -r linux59

@megavolt I don’t know what is going here, but I’m getting:

Currently running: 5.10.52-1MANJARO (linux510)
The following kernels are installed in your system:

How is it possible?

I see you are using gnome with zsh, there it is different… (and you didn’t mention it)

Try this for xorg:

journalctl --grep="\([A-Z]{2}\)" --since=-30min | curl -F'file=@-'

@megavolt here it is:

No logs?

Used for 35 minutes:

I think I should extend more?

Update: also 45 minutes

So… this is the problem:

Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (II) Loading sub module "glxserver_nvidia"
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (II) LoadModule: "glxserver_nvidia"
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (WW) Warning, couldn't open module glxserver_nvidia
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA: Failed to load module "glxserver_nvidia" (module does not exist, 0)
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA(0):     you continue to encounter problems, Please try
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
Jul 25 01:45:13 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (II) NVIDIA: The X server does not support PRIME Render Offload.
Jul 25 01:45:14 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (WW) NVIDIA: No DRM device: Direct render devices found but none could be
Jul 25 01:45:14 denis-zephyrus-g14 /usr/lib/gdm-x-session[1276]: (WW) NVIDIA:     used.

Could you check if the module is there?

ls /usr/lib/nvidia/xorg/

I have there:


Do I need some other?

Update: I will try now to proceed what is proposed here:

No, they are there. No idea at the moment why it does not work.

How do you run the gpus? Is nvidia or amd primary?

I would try removing nvidia and all xorg configs of it:

sudo mhwd -r pci video-nvidia

and search in /etc/X11/ and /etc/X11/xorg.conf.d/ for configs and delete the nvidia ones.

Set AMD to primary (I guess at the UEFI?).

When it works try to do a clean install of the drivers again.

@megavolt I don’t see such configs in my UEFI for primary videocard
Thanks for help in such a late time!

Tomorrow I will try to work with configs and will post my results here. Maybe then we will get a working solution.

@megavolt hey again.
Since yesterday I’ve solved the problem with glxserver_nvidia loading, seems like it is loaded now correctly:
Used the topic: Nvidia graphics issues GLX not loading

But anyway, blackscreen is not solved. I can see in the Xorg logs:

[     3.218] (EE) Device(s) detected, but none match those in the config file.

So I am sure the reason is in configuration of Xorg.

Could you please help me to write a correct configuration? I see too many config files in /etc/X11 directory as well as in /etc/X11/mhwd.d & /etc/X11/xorg.conf & /etc/X11/xorg.conf.nvidia-xconfig-original
I am not sure which one is used when system is booting and what exactly should be defined in config file (I gues I need a correct “Device” section?)

mhwd --listinstalled
shows that my PCI config are:

  • video-hybrid-amd-nvidia-prime
  • video-linux

I guess theese are the lastest installed via

sudo mhwd -a pci nonfree 0300

Xorg choose the config by priority:

  1. /etc/X11/xorg.conf
  2. /etc/X11/xorg.conf.d/
    90 - high priority
    10 - low priority

As I know mhwd create a config in /etc/X11/mhwd.d and symlink it to /etc/X11/xorg.conf.d/90-mhwd-gpu.conf

If video-hybrid-amd-nvidia-prime is installed correctly then amd should be primary.

for x in /etc/X11/xorg.conf.d/* ; do echo -e "---$x---\n\n $(cat $x)\n\n"; done 
for x in /etc/X11/* ; do echo -e "---$x---\n\n $(cat $x)\n\n"; done 



are directories ofc, if needed I can show what is inside


If video-hybrid-amd-nvidia-prime is installed correctly

yes, I’ve removed and installed again this using mhwd - no errors, result was success

So /etc/X11/xorg.conf has only nvidia configs (so that it disables amd). Please remove it, so that the configs at /etc/X11/xorg.conf.d/ can take place.

With video-hybrid-amd-nvidia-prime it should use amd for display and nvidia for offload.

I removed /etc/X11/xorg.conf but still the same :frowning:
Also created a bakcup before (xorg.conf.bak)