Black screen when toggling Full Screen on Firefox (only if window is maximized)

EDIT: I already fixed this by downgrading from kwin 5.22.5 to 5.22.4 following these steps:

  1. Download downgrade from the AUR: yay -Sa downgrade
  2. Show kwin version list: sudo downgrade kwin
  3. Now you’ll have a list with kwin versions and a number corresponding to each version, you must type the number of version 5.22.4 and hit enter
  4. When asked if you want to install say Y
  5. Reboot your system: Reboot

PS: You might be tempted to use downgrade to install new version 5.22.90, don’t do it as it won’t work (you won’t be able to go past login screen).

Now we wait until 5.22.5 bug is solved.

Original thread:

Hi! I am getting this annoying behaviour whenever I have a Firefox window (I haven’t tried other browsers) maximized and I try to full screen a video, it just goes black and I have to hit ESC and then make the window smaller (as it keeps on being black).

I’ve already searched for it on the internet, even on this forum:

Sadly, that solution won’t fix the issue for me, in fact I didn’t even had Full Screen toggled on Desktop Effects, also there’s some posts saying this issue only happens on secondary monitors, but I actually only have one monitor, and it is happening there.

Just as a sidenote, I’ve got Latte Dock running, I thought it might be the issue causing black screen when full screening apps on top of it, or when it is hidden because of it, I’ve already tried to put the Firefox window on top of it so it hides and then toggling Full Screen but it doesn’t go black, so it’s definitely only happening when the window is maximized.

Any ideas on how can I fix this? I’ve just started using Manjaro (or any linux basically) and while I feel I’ve learnt a lot in a few days, I’m still pretty new to Linux.

EDIT: The issue has to do with the compositor, OpenGL 2.0 and OpenGL 3.1 cause this issue, while XRender won’t (but it lacks lots of OpenGL graphical effects and doesn’t run as smooth. I’ve got a NVIDIA GTX 1660 with the latest drivers installed and “Force composition pipeline” enabled (but it happened with it disabled and with “Force Full Composition pipeline” too.

EDIT2: Confirmed this behaviour is not Firefox specific but happens on every single maximized window that I try to Full Screen.

Thanks in advance!

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.


Apparently it’s fixed in 5.23.0. Currently, 5.23.2 is in Staging, so shouldn’t be too long before it lands in Stable.

1 Like

Sorry for the late response, I’ve been a little busy, it seems I am not able to edit the thread anymore, so I can’t actually change the title or move the response to a new comment.

That is great to know! I will make sure to update!

And it’s landed, just today. I can confirm the issue is gone for me in 5.23.3.