Black Screen w/cursor after login on original Manjaro KDE-Plasma profile

Hello new here - feel free to send me somewhere if I’m repeating an older issue.

I’m new to Linux, have worked with Ubuntu and bash in the past and know my way around Python and other languages. I installed a Manjaro KDE-Plasma on my old 2011 Macbook Pro which I’m trying to refurbish and use as a workstation (basic office work with some occasional vector graphics).

Screenfetch summary
 ██████████████████  ████████     root@user-macbookpro81
 ██████████████████  ████████     OS: Manjaro 23.1.3 Vulcan
 ██████████████████  ████████     Kernel: x86_64 Linux 6.6.10-1-MANJARO
 ██████████████████  ████████     Uptime: 1h 5m
 ████████            ████████     Packages: 1344
 ████████  ████████  ████████     Shell: sudo
 ████████  ████████  ████████     Resolution: 1280x800
 ████████  ████████  ████████     DE: KDE
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breeze [GTK3]
 ████████  ████████  ████████     Disk: 22G / 72G (32%)
 ████████  ████████  ████████     CPU: Intel Core i5-2415M @ 4x 2.9GHz [70.0°C]
 ████████  ████████  ████████     GPU: Mesa Intel(R) HD Graphics 3000 (SNB GT2)
 ████████  ████████  ████████     RAM: 5379MiB / 15910MiB
  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=d2890c80-064a-4d3a-9963-3b0513a55088 rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.113.0 wm: kwin_x11 vt: 7 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro8,1 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-94245B3640C91C81
    serial: <superuser required>
  Mobo: Apple model: Mac-94245B3640C91C81 v: MacBookPro8,1
    serial: <superuser required> uuid: <superuser required> UEFI: Apple
    v: date: 06/13/2019
  ID-1: BAT0 charge: 56.9 Wh (84.2%) condition: 67.6/62.9 Wh (107.5%)
    volts: 12.1 min: 10.9 model: SMP bq20z451 type: Li-ion serial: N/A
    status: charging cycles: 2
  Info: model: Intel Core i5-2415M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 800/2900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 800 3: 798 4: 800
    bogomips: 18367
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Apple driver: i915 v: kernel arch: Gen-6 code: Sandybridge
    process: Intel 32nm built: 2011 ports: active: LVDS-1 empty: DP-1, DP-2,
    DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0126 class-ID: 0300
  Device-2: Apple FaceTime HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:10 chip-ID: 05ac:8509
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositors: 1: kwin_wayland 2: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,vesa dri: crocus gpu: i915 display-ID: 0
  Monitor-1: LVDS-1 res: 1280x800 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
    device: 1 drv: swrast surfaceless: drv: crocus wayland: drv: crocus x11:
    drv: crocus inactive: gbm
  API: OpenGL v: 4.5 compat-v: 3.3 vendor: intel mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 3000 (SNB GT2)
    device-ID: 8086:0126 memory: 1.46 GiB unified: yes display-ID: :3.0
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:16b4 class-ID: 0200
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:4331 class-ID: 0280
  IF-ID-1: wlp3s0b1 state: up mac: <filter>
  Device-1: Apple Bluetooth Host Controller driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1.1.3:8
    chip-ID: 05ac:821a class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 333.94 GiB used: 20.23 GiB (6.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS545032A7E380
    size: 298.09 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: AC90 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: DataTraveler 3.0
    size: 7.2 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: USB 3.2Gen1
    size: 28.64 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1.00
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 64.43 GiB size: 62.87 GiB (97.57%) used: 20.21 GiB (32.1%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 200 MiB size: 196.9 MiB (98.45%)
    used: 24.1 MiB (12.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 67.0 C mobo: 0.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.54 GiB used: 5.77 GiB (37.1%)
  Processes: 310 Power: uptime: 1h 55m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 4 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 6.2 GiB daemons: upowerd,
    power-profiles-daemon, org_kde_powerdevil Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: 1345 pm: pacman pkgs: 1335 libs: 384 tools: pamac,yay pm: flatpak
    pkgs: 0 pm: snap pkgs: 10 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh
    v: 5.9 default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.32

I installed the distro 3-4 days ago, had to manually input the b43 WiFi driver and have since been modifying the software and aesthetics, mainly hooking in clouds (OneDrive, GDrive) without issues. Yesterday I tried to set up VNC remote desktop (tightvnc) which I need on occasion to monitor a different station. After rebooting the laptop, the system went to login screen but after proceeding through the Manjaro spinning wheel, it went to black screen with a regular pointer cursor (which I could move around). I waited 10-20 mins, no panels, no regular shortcuts working, I couldnt open the terminal.

Only after some searching I was able to get into TTY’s and verified that the system is updated with -Syu commands etc. Since I can get into login I imagine it is not a GRUP issue although I did proceed through the manjaro-chroot guides relating to similar issues, which did not resolve the problem.

I’m suspecting an update triggered after reboot broke the user profile? I attempted booting to X11 desktop environment - it worked but it is rather sluggish and I get logged out unexpectedly. I created another user with admin rights (from which I’m typing this message) and it works as expected although I’d like to access my old configuration.

Can I get some help to try and diagnose what is wrong with the original profile?

Welcome to the forum! :vulcan_salute:

Unfortunately, KDE Plasma does tend to mess up its own configuration files from time to time — you’re not the first one to experience this, and I regularly encounter this myself — and the exact culprit is hard to find. It appears to be happening the most during the logout or shutdown/reboot phase.

What you could try is log out of the broken session completely, log in at a tty, temporarily shut down the GUI session, and delete the contents of your ~/.cache folder, like so… :point_down:

sudo systemctl stop sddm
rm -rf ~/.cache/*
sudo systemctl start sddm

There is however no guarantee that it’ll work. Therefore, it is always best to, after a successful login, immediately make a full backup of your home directory, so that you can always restore it in situations like these.

Well, if it’s your actual data files that you seek to salvage, sudo will allow you to copy them over from your broken login to the new login.

If instead it’s the configuration files that you’re after, then you should first make that backup I spoke of here-above, and then you can try comparing them one by one with what’s in the configuration files of the new and working account.

In many cases — but not in all cases — things like these can be caused by a badly written or no longer compatible theme. But then again, it may just as easily be config file corruption during the (Plasma) shutdown process. Again, been there, have the T-shirt, the baseball hat and the bumper sticker. I always keep at least 5 full backups of my home directory, exactly because of the chance of Plasma going belly up on me again. :frowning_man:

Well - you were right, it didn’t work :sweat_smile:
I tried both without logging in from boot (going straight into tty) and signing in and then Ctrl+Alt+F3 to shutdown the GUI, clear cache + reboot. No luck.

I’m also experiencing strange, random and unprompted screen-locking of the alternative account I made (in Wayland mode)? It locked me out midway through writing this reply. Bizarre.

Presuming that I manage to log-in - what’s best to use to make the backup? Timeshift? Another piece of software?
You’re totally right about backups and immediately after the account crashed I thought I’ve done a major cock-up not sorting it just after setup.

Slight oddities over long periods … such as continued use of old extensions when plasma has been updated, maybe sure … but just randomly for no reason the desktop being broken is not ‘regular’.

These issues are much more likely depending on configuration.

To quote the Archwiki of the relevant section.

Many problems in KDE are related to its configuration.

In any case.

The real ‘if your profile is wonky’ steps are as follows:

cd ~/.config && for j in plasma*; do mv -- "$j" "${j%}.bak"; done && cd ~
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental

Note that this will reset most desktop configurations.

Extra note: deleting ~/.cache is very unlikely to have any real impact in the case of a weird/broken plasma profile. I wont say ‘impossible’, but its not usually included in the steps above because its rarely related.

1 Like

Upgrades always modify shared libraries and configurations for all users, if your new created user works fine both on X11 and Wayland then you messed with your user configuration files, and you assume total responsibility for it because it’s impossible for us to track your manual modifications.

Are you using modesetting driver?

There is nothing wrong with the initial user profile on Plasma.

Black screen is usually a driver issue - and unless you immediately riced the system with some plugin from - the driver is the likely cause.

Your system is using Intel GPU → Intel graphics - ArchWiki

If you have the package xf86-video-intel installed - remove it - it is generally not recommended.

sudo pacman -Rns xf86-video-intel

Check the value the environment variable QT_QPA_PLATFORM - you should get an empty result


Check the file /etc/mkinitcpio.conf in the HOOKS=() contains kms

cat /etc/mkinitcpio.conf | grep HOOKS=

Logout - check lower right corner - does it state Xorg / X11 or Wayland?

Your inxi - says you are using Wayland - continue there as Plasma 6 will be using Wayland.

As latest ISO has plasma-wayland-session package - Wayland is the default (W comes before X)

1 Like

OK so I followed through your instructions @linux-aarhus - removed the intel driver, indeed got the empty result after the QT query. Output of the cat command in tty - is as follows:

# HOOKS=(base)
# HOOKS=(base udev autodetect modconf block filesystems fsck)
# HOOKS=(base udev modconf block filesystems fsck)
# HOOKS=(base udev modconf keyboard keymap consolefont block mdadm_udev encrypt filesystems fsck)
# HOOKS=(base udev modconf block lvm2 filesystems fsck)
HOOKS=(base udev autodetect kms modconf block keyboard keymap consolefont plymouth filesystems fsck)

So I’m guessing kms in the final line confirms it’s fine?

On logout it says Wayland.

I rebooted and after sticking in credentials it did not freeze on the spinning wheel (on most login attempts it did) and took me through - still no dice though, black screen with mobile cursor persists. Having read around @medmedin 's suggestion - is there anything else that needs to be done to enable modesetting driver?

EDIT: re-reading some further suggestions - will update on progress

I’ve now installed/enabled the video-modesetting driver from Manjaro Settings GUI on the alternative account based on suggestions made in this post - How to use the modesetting driver? and rebooted.

An interesting development - after the spinning wheel post-login (into the faulty original profile, not the alternative used to set-up modesetting driver), I got the usual black screen w/cursor on my Display 1 (laptop). However, one half of the Display 2 screen (work monitor, hooked in through Mini DP port) I was greeted with a stock wallpaper and kded5 + kdewallet apps requesting a password!

Which I absolutely did not touch at all since installing Manjaro!

I pressed cancel and it defaulted back to the black screen. I stopped the GUI session via tty and rebooted again. Same thing.

This -

also persists despite the modesetting driver now installed.

Inxi updated
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositors: 1: kwin_wayland 2: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,vesa dri: crocus gpu: i915 d-rect: 3200x1080 display-ID: 0

Or should I have checked that it is disabled instead? Or disengage the video-linux?

Keep only video-modesetting installed and remove video-linux, KDE recommends modesetting driver instead of intel.

1 Like

Some apparent improvement on that front since I removed the driver.

No progress on the access to the original profile though. Might try @cscs suggestion tomorrow - I was trying to leave it till I find I absolutely have to reset the configuration