Black screen & unresponsive system after booting


I am running a desktop PC with an ASUS RIME A320M-K motherboard from 2019, an AMD Ryzen 5 2600 and an AMD RX 460 graphics card. So definitely nothing fancy or ‘new’.

I’ve installed Manjaro 2021. The first time it seemed to boot up from the USB stick just fine, though at some times, the screen will go black (no signal) and my keyboard will also be unresponsive.

I’ve tried several things in the BIOS, and reinstalled Manjaro when the change had no effect. I’ve switched between UEFI and classic BIOS. I’ve turned off safe boot, CSM, changed fast boot to normal, disabled and enabled secure boot. Changed the OS type from Windows to other OS… I must’ve reinstalled Manjaro about 6 times, lol.

I figured after this I’d try Kubuntu 20.04, and it did install okay the first time, but after a few seconds, sometimes a minute or 2, the screen will show me the login screen after booting, but will again turn black (no signal) and my keyboard will again be unresponsive. So it’s giving me the same issues as Manjaro 2021 did.

I was wondering what you guys would suggest I do. I’m running Manjaro on my laptop and I’m learning how to work with it bit by bit. I really enjoy the experience so far. I hadn’t worked with Linux since I was in college 10 years ago.

I’m guessing maybe it has something to do with the AMD drivers, but then again, upon installation I’ve tried proprietary drivers, community drivers–no luck. And as you can see, my GPU is nothing fancy or new.

After messing around with this until 1AM, I reinstalled Windows because I do need my computer for work… but it’s bumming me out.

Help a newby out? I’d greatly appreciate it.