Black screen on login after nvidia driver change

Hi, after some hours of log reading and research I’m quite lost.
Find the tl;dr at the bottom. :slight_smile:


During the fresh install a few weeks ago i installed the optimus-manager from official repositories and kept the default settings as i had not much time reviewing them.

I noticed that steam would not launch games after switching to the dGPU (which had weird behaviour) but i ignored that too - did i mention i had little time?

With a little more time at hand i wanted to set up Reaper following this guide: GitHub - chrismhampson/ManjaroProAudio: A complete guide to setting up Manjaro for professional audio..

However, wine would not launch with the iGPU enabled, complaining about a missing driver. I really had not much time thinking about that and just switched to the dGPU. This worked fine.

Where the problems started

Over time, i got annoyed with the erratic switching behavior from iGPU to dGPU.
What happened:
When logging in again, my usual desktop environment was gone.
KDE seemed to enter some kind of fallback mode, there was the default desktop background but no panels or launcher were visible. Trying to add new panels did not work either (they would show up later on my real desktop). The terminal was accessible though and right clicking the desktop resulted in a context menu. I could log out and try again, which finally would get me back to my desktop.

When i tried setting the default GPU to nvidia in optimus-manager, this seemed to be the default behavior for the first two login attempts at every startup.

Then I started trying things:
I changed the drivers more or less wildly (i was annoyed) with no effect at first.
Only after changing to the non prime driver i made it worse.
After restarting, and normal log in, i just got a black screen where only the cursor is visible. So i changed back to the original settings but to no avail, even after timeshiftig through some of my snapshots the issue stays. Which makes me wonder - did I miss some config file?

I am able to get a ui session using tty2 with startx.
My Question: How can i go back to my original misery, without having to reinstall everything?

I messed up.
Ignored some initial problems with switching GPUs with optimus-manager and had no time to fix them. After changing drivers in mhwd i got a black screen with working cursor after logging in.
I am able to start a ui session on tty2 with startx. I would like to just normally log in again without using tty2.

Any help would be greatly appreciated.

Updated title to better fit the problem description.

Also here is the output of inxi --admin --verbostiy=7 --filter --no-host --width
(Considering System, Machine, Battery, Mem, CPU, Graphics and Audio)

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=c00930cd-2246-450f-8253-a83dd04a03c2 rw quiet apparmor=1
  security=apparmor resume=UUID=b5e1dc9a-c9b2-4e19-a9de-244c979a90fe
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 2 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: N551JK v: 1.0
  serial: <superuser required>
  Mobo: ASUSTeK model: N551JK v: 1.0 serial: <superuser required>
  UEFI: American Megatrends v: N551JK.203 date: 10/06/2014
  ID-1: BAT0 charge: 39.8 Wh (95.2%) condition: 41.8/56.2 Wh (74.4%)
  volts: 10.8 min: 10.8 model: ASUSTeK N551-52 type: Li-ion serial: N/A
  status: Not charging
  RAM: total: 15.52 GiB used: 1.2 GiB (7.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: Intel Core i5-4200H bits: 64 type: MT MCP
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache:
  L1: 128 KiB L2: 512 KiB L3: 3 MiB bogomips: 22358
  Speed: 2504 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2504 2: 3011
  3: 2941 4: 3093
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good
  sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave
  xsaveopt xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: ASUSTeK
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
  Device-2: NVIDIA GM107M [GeForce GTX 850M] driver: nvidia v: 495.44
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1391
  class-ID: 0302
  Device-3: IMC Networks USB2.0 UVC HD Webcam type: USB driver: uvcvideo
  bus-ID: 3-7:9 chip-ID: 13d3:5188 class-ID: 0e02 serial: <filter>
  Display: server: X.Org compositor: kwin_x11 driver:
  loaded: modesetting,nvidia display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1080 s-dpi: 75 s-size: 869x366mm (34.2x14.4")
  s-diag: 943mm (37.1")
  Monitor-1: HDMI-1-2 res: 2560x1080 hz: 60 dpi: 79
  size: 820x345mm (32.3x13.6") diag: 890mm (35")
  OpenGL: renderer: NVIDIA GeForce GTX 850M/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
  direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
  class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
  class-ID: 0403
  Device-3: Mackie Designs Onyx Producer 2-2 type: USB driver: snd-usb-audio
  bus-ID: 3-3.1:7 chip-ID: 0a73:001f class-ID: fe01
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes

Update: Things work again (kind of).

Originally, my login screen froze after trying to log in (even with a newly created test user, this was the case). As said, i was able to login and start a gui session via ctrl + alt + F2 (tty2).

Wondering how i could attempt to force kill tty1 to try and log in again i followed this guide:

This worked! Stopping the user process in tty1 immediately landed me back on the log in screen.
Now log in on tty1 is possible again, even after reboot.
However, i experience the issues mentioned at the beginning of this topic.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.