Black screen on boot nvidia driver failed to start

Hello all. First off I brand new to Manjaro.

So when I install a fresh version manjaro xfce 21.05 - I have a gui and everything launches after updating the mirrors list and updating everything

sudo pacman -Syyu

The first thing I do is try to access the Manjaro Settings Manager gui to right click install drivers:

Display Controller
      GP102 [GeForce GTX 1080 TI] (nVidia Corporation)
       1.) video-nvidia
       2.) video-nvidia-390xx

Installing video-nvidia results in another black screen and can’t get the gui to run
installing video-nvidia-390xx results in another crash.

Next, I try to automatically install nvidia drivers following a tutorial

sudo mhwd -a pci nonfree 0300

After I did that it boots to a black screen but I can access tty2 to move around. I tried to follow guides to uninstall nvidia drivers and reinstall. No luck the only thing I can do is reinstall manjaro via flashdrive

I have an MSI motherboard (z170a) a friend mentioned that msi has issues with arch based linux distros.


OS: Manjaro Linux x86_64 
Host: MS-7977 1.0 
Kernel: 5.10.34-1-MANJARO 
Uptime: 9 mins 
Packages: 1059 (pacman) 
Shell: bash 5.1.4 
Resolution: 1920x1080, 1920x1080, 1920x1080 
DE: Xfce 4.16 
WM: Xfwm4 
WM Theme: Matcha-sea 
Theme: Matcha-sea [GTK2], Adwaita [GTK3] 
Icons: Papirus-Maia [GTK2], Adwaita [GTK3] 
Terminal: xfce4-terminal 
Terminal Font: Monospace 12 
CPU: Intel i7-6700K (8) @ 4.200GHz 
GPU: NVIDIA GeForce GTX 1080 Ti 
Memory: 1385MiB / 32074MiB

Update: when I fresh installed Manjaro Xfce and immediately did

sudo mhwd -a pci nonfree 0300

I managed to boot and then got
[ FAILED ] …Kernel failed to load


sudo systemctl status systemd-modules-load.service


Failed to insert module 'nvidia': exec format error
failed to insert module 'nvidia_drm': exec format error

I then run sudo pacman -Syyu
and reboot now I’m stuck with a non flashing cursor _ and I can’t boot into anything tty2 at all. I have to hard reset my computer by holding the power button

I have no clue why this works but…
I have a 3 monitor setting up 2 are display port and 1 is on hdmi. When I unplug both display ports it boots just fine…

then try

sudo pacman -Syyu
sudo mkinitcpio -P

what have you for

sudo mhwd-kernel -li
sudo mhwd -li 

I narrowed down the issue. The driver that the mhwd pulls with -a pci nonfree 0300 is 460.80 nvidia driver

I tried installing other drivers 465.31, and installing 390xx all of them have the same issue. At this point it seems that it will be a minefield of trying to find one driver that won’t crash my system so at this point I’m just going to call it for now and probably install Arch and see if it’s unique to Arch based systems or Manjaro specific.

Thank you for your help and I hope you have a nice day.

This sounds exactly like the issue I’m having. See my thread for that.

Only difference is I’m using a 3000 series. Let me know if you find any solutions.

I managed to solve my issue (for now). See my thread for what I did

TLDR: Display port kills the nvidia driver. Use HDMI and a non-4K display. Edit: I see the OP already found this solution.

This may be too late, but I had a similar issue in the past due to a previous graphics update and I’d like to share my documentation on how I fixed the issue previously. This is merely a dump of my txt doc, if you have any questions, or need any assistance, I’ll be monitoring.

So “lightDM” and I’m stuck at the TTY login.
I went and logged in as root and started looking at
mhwd -li to see what drivers were installed for my PC.
I saw video-linux and video-nvidia-455xx

I tried to uninstall and reinstall the linux video drivers.
Didn’t work.
I removed video-nvidia-455xx and then reinstalled the previous
version. video-nvidia-450xx

I was able to get that working again after

mhwd -r pci video-nvidia-455xx #This removes

mhwd -i pci video-nvidia-450xx #This installs.

After I installed the old nvidia driver my screen turned off and I waited about 3 minutes and rebooted after it wouldn’t come back up.

low and behold I have my GUI back.
Good job.

I have a question @vvbudh
Before you even installed the 450xx driver did it show you any options in the mhwd? Because for my 1080ti the only options I saw was
Latest Driver

Edit: Nevermind I installed 450xx and it boot no problems. Thanks guys

IIRC, I had videolinux or some generic, then I had nvidia 455xx, I had to remove it first by logging in without a gui then reinstalled another previous version manually.

But glad you got it working! :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.