Black screen on boot, but switching TTY fixes it

Since the stable update on 1 October, my laptop boots to a black screen. I can switch to a TTY with ctrl+alt+f2 and if I then switch back with ctl+alt+f1 it does work and I get the regular login screen (GDM, I’m using gnome). No other problems after that, but doing the switch every boot gets old. I guess something in either my xorg or my systemd config is set up wrong, but I don’t know how to find out.

Any ideas where to start looking? I’m happy that I have never had to mess around with the video driver/xorg side of my install, but that also means I don’t know how it works (yet).


  • HP Elitebook 8570w
  • Intel i7-3630QM
  • AMD FirePro M4000 (same chip as the HD7850 I think)
  • 14 GB RAM
  • Linux kernel 5.4.67-1-MANJARO
  • amdgpu 19.1.0 free driver
  • Gnome 3.36.6

System has been running without major issues for a year, until last week. Any ideas how to find out what’s happening?


Have checked here for a solution?

I have now, thanks for the link!
There were some black screen issues, but I think mine is different because
a) I don’t use Plasma
b) I do not have a cursor, the screen is just black

Im new in manjaro ,also my English not very good sorry for that
if its graphic configurations problem then from tty

Disable Xorg graphic configurations in /etc/X11/xorg.conf.d/
by rename file with .bak in last (if you need it in future )
like “intel.conf” to “intel.conf.bak” etc.

don’t worry if you didn’t see graphic file
don’t change any thing else like “00-keyboard.conf”

Disable Xorg graphic configurations in /etc/X11/
like above ,with rename file

change vesa file in “mhwd.d” folder
(cd mhwd.d -> “vesa.conf” to “vesa.conf.bak”)


this the way i restore my system work when i broke display configurations

note : if you install optimus-manager make sure you disabled it
optimus-manager --cleanup
sudo systemctl stop optimus-manager.service
sudo systemctl disable optimus-manager.service

this is worked for me i hope work for u

Thanks! However, those commands do not work for me because I use AMD, so i don’t have the intel.conf file, or anything optimus related.

But there is good news: Today there was an update of just gdm, and now everything works again! Maybe I’ll never know…

I have experienced similar behaviour and after I have installed both updates, I do not have the black screen in Gnome.

Disable Xorg graphic configurations
intel.conf was example

I hope you find way to slove it.

Well, those folders are just empty for me. No intel.conf, no vesa.conf

But like I said, there was an update for gdm and everything is fixed now!