Black screen on boot after updating

After I updated my system yesterday, I get a black screen after booting.
I have a Thinkpad X395 with a AMD Ryzen Pro 3700U with integrated graphics.
When I select Kernel 5.4.270-1-MANJARO in my grub menu, it works just fine, but when I select Kernel 5.15.150-1-MANJARO, it only shows a black screen and I can’t even select ttys. I found some similar threads here and tried removing or bypassing Plymouth, as that was the reason for similar sounding problems, but that didn’t work, or rather, when I tried to uninstall Plymouth, pacman showed that it’s not installed on my system.
What are my options? This should be some kind of driver issue, I have tried updating everything, including the UEFI BIOS, but I haven’t found anything that works yet.

Hi @francesco.schmitt,

I suggest booting into the working kernel, uninstalling the non-working one, and installing 6.1 which will be maintained for some time yet…

When booted, run the following to uninstall 5.15:

sudo mhwd-kernel --remove linux515

And, before rebooting, install 6.1:

sudo mhwd-kernel --install linux61

When successfully done, reboot into it.

Hope this helps!

1 Like