Black screen on boot after update

This morning I ran pacman -Syu and all seemed fine. However, after I rebooted my machine it now hits a black screen as soon as it leaves the Alienware screen. None of the Ctrl-Alt-F3 options (I’ve tried all of the numbers and F keys) work to get into a terminal from this black screen.

Notably, nothing displays after the Alienware logo, not even any text printed out momentarily.

I’ve been able to boot using my USB drive, and use manjaro-chroot to get access to a terminal for my installation. System details below.

[manjaro-gnome /]# inxi -GSa 
  12Kernel 5.15.60-1-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 12.1.1
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_GNOME_2137 quiet systemd.show_status=1 driver=free nouveau.modeset=1
    i915.modeset=1 radeon.modeset=1
  12Desktop GNOME 12v 42.5 12tk GTK 12v 3.24.34 12wm gnome-shell 12dm N/A 12Distro Manjaro Linux
    12base Arch Linux
  12Device-1 NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] 12vendor Dell 12driver nouveau 12v kernel
    12non-free 515.xx+ 12status current (as of 2022-10) 12arch Ampere 12code GAxxx 12process TSMC n7 (7nm)
    12built 2020-22 12pcie 12gen 4 12speed 16 GT/s 12lanes 8 12link-max 12lanes 16 12ports 12active HDMI-A-1
    12empty DP-1,DP-2,DP-3 12bus-ID 0b:00.0 12chip-ID 10de:2216 12class-ID 0300
  12Display wayland 12server 12v 12with Xwayland 12v 22.1.3 12compositor gnome-shell 12driver 12X
    12loaded nvidia 12gpu nouveau 12display-ID 0
  12Monitor-1 HDMI-A-1 12model BenQ GL2780 12serial <filter> 12built 2019 12res 1920x1080 12dpi 82 12gamma 1.2
    12size 598x336mm (23.54x13.23") 12diag 686mm (27") 12ratio 16:9 12modes 12max 1920x1080 12min 720x400
  12OpenGL 12renderer llvmpipe (LLVM 14.0.6 256 bits) 12v 4.5 Mesa 22.1.7 12direct render Yes

First thing I tried was these instructions:
wiki dot manjaro dot org/index.php/GRUB/Restore_the_GRUB_Bootloader

I also had a feeling it could be a graphics card issue, so based on wiki dot manjaro dot org/index.php/Configure_Graphics_Cards I tried

sudo mhwd -a pci nonfree 0300  -f

I may have tried a few other things too that I can’t remember.

might be the same case.

Resolution could be that for now use the video-nvidia-470xx
either way, quite strange to see

On the other hand

Nvidia and Wayland are not good friends yet …
But then, how did you update and remained with this kernel?

On all branches the linux515 is 5.15.72-1
sudo pacman-mirrors -f5 && sudo pacman -Syyu

1 Like

Thank you @bogdancovaciu , I think you are correct that it was the same issue.

Switching to video-nvidia-470xx did not work (required me to uninstall some other nvidia-related packages, after which I didn’t even make it past the Alienware screen).

However, I noticed that this was an HDMI-only issue. Switching to DisplayPort fixed this!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.