Black Screen Issues with KDE Plasma after Windows Update

Sorry I’m being really dense today, but what do you mean by target? Also would it be possible to expand upon what a mountpoint is? Its been awhile since I’ve used Manjaro and I would really like to use it again.

target - the destination of installed files
mount point - the point in the filesystem where something is mounted (ex: /boot/efi , etc)

all I was trying to say is the only thing grub will overwrite is itself.
(which would not be a concern because you are trying to reinstall grub)

Your Windows update didn’t do that.

So by reinstalling the GRUB you’re saying I will be able access all of my old files on Manjaro, correct? If so that is fantastic news! Is there way to do so without accessing a terminal or maybe I am not finding it? Where would the terminal be at? All Im seeing is access to Manjaro, to windows, and an advanced setting, GRUB commandline, but I’m not seeing a terminal. Any help with that?

You have to read the links…in the manjaro live session started from usb

Okay, I will check back with you to see if this will work.

Okay, so I have tried to get into the kernal to no avail, what can I do now? Whenever I try to do so the screen freezes at the loading screen. Any suggestions?

Trying to boot another kernel for example.
Generally, Windows, and GRUB, and broken kernel, have little to do with each other. So maybe i don’t understand the exact problem and you have to provide more information what have you done, what do you see etc.

So I have managed to get into the TTY using


whenever I typed in the command of:

sudo-pacman mirrors -f3

I would get the response back like :

-bash: sudo-pacman: command not found 

And then I tried using the command


and got the response to something that looks like this:

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux xxxxxxx-systemproductname 5.10.123-1-MANJARO #1 SMP PREEMPT Thu Jun 16 12:34:16 UTC 2022 x86_64
Kernal command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=91380c74-af96-4052-83e2-d1865778193e rw quiet apparmor = 1 security=apparmor udev.log_priority=3

Current version of pixman: 0.40.0
Before reporting problem, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 5 04:10:46 2023
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory: "/etc/X11/xorg.conf.d"
r help. (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information. (EE) (EE) Server terminated with 
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Any help or ideas on what to do what be incredibly helpful! Thank you everybody so far for your assistance!

sudo-pacman mirrors -f3

Is false, it should be

sudo pacman-mirrors -f3
1 Like

Just tried

sudo pacman-mirrors - f3

They are saying:

sudo: pacman-mirror: command not found

Okay, that prior response was a mistake and that was on me! I just got a huge list of countries.

Seems like a silly question but since I’m from the U.S. I would choose the mirror that corresponds to that one correct?

Hey Omano!

Thank you for showing me this link! But would anyone happen to know the command to update the mirror that is in the U.S is on by chance? I don’t want to cause any drama by downloading the wrong mirror

sudo pacman-mirrors --country United_States

And BTW, the whole point of the </> tag is copy button at the right in the box. And then middleclick or three finger tap to paste in terminal

It doesn’t matter which mirror you use anyway. The link I gave told you exactly what to do so I don’t know how much more we can help (beside literally spoon feeding you each and every command you want us to give). You need to try a little bit more or else you’ll never end up learning.

So also as I said initially, your Windows update did not create the issue you’re currently in, so provide good information now as requested by others in previous posts, or else this thread is going nowhere…

Provide info, we understand the issue, we help solve it. Simple as that.

From TTY (but it is easier from CHROOT with a live USB system as you can connect to the forum from web browser and copy paste things) update the system (and if you messed with mirrors I would do sudo pacman -Syyu to force refresh the package database) and see the result, if updating/finishing updating doesn’t help, there is no way around proving the maximum information possible.

So a bit of an update here!

After some digging around on these forums I’ve stumbled upon some instructions that were helpful in getting me to address my issue. I figured out how to connect to the internet via the numcli command, updated some of the dependencies following this guide. I also figured out how to which version my kernel is currently 5.10…which I may need to update that. [This guide](Manjaro Kernels - Manjaro seems to be promising lead!

My question to the rest of you, will updating my kernel delete any of the files that I have stored on Manjaro?

Also for what its’ worth and Im sorry if this doesn’t matter, but I’ve seen other people talk about it, but I do have a nvidia graphics card that was recently updated.


Kernel “series” (5.10, 5.15, 6.4, etc) are their own packages that receive their own updates, and are not mutually exclusive.

Installing a new kernel will not remove the current kernel.
You may have multiple installed and choose between them.

Assuming all is well you should be able to do a regular update:

sudo pacman -Syu

For installing a kernel, in this example 6.1:

sudo mhwd-kernel -i linux61

(this should be done automatically, but you may also run sudo update-grub)

And reboot.

You should be able to select your kernel from GRUB during boot.

Okay I feel like we coming down the final stretch here! After installing the 5.15 kernel I ran into another issue of not getting past the Asus splash screen. I searched and found this thread and another thread were suggesting I use the command

journalctl --boot=0 --system --priority=3 | tail --lines=50

It returned the following information:

kernel:x86cpu: SGX disabled by BIOS.
kernel: ata4.00: Read log 0x30 page 0x08 failed, Emask 0x40
kernel: usb 1-14: device descriptor read/64, error -71
systemd-modules-load[283]: Failed to find module 'nvidia-uvm'
overlayfs: missing 'lowerdir'

then I tried the other command:

journalctl -b-1 -p4 --no-pager
kernel: x86/cpu: SGX disabled by BIOS
kernel: MDS CPU bug present and SMT on, data leak possible. See for more details.
kernel: MMIO Stale Data CPU bug present and SMT on, data leak possible. See https: for more details
kernel: #5 # 6 #7
kernel: ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
kernel: pci 0000:04:00.0: can't disable ASPM;  OS doesn't have ASPM control
kernel:ata3.00: ATA Identify Device Log not supported
kernel:ata3.00: ATA Identify Device Log not supported
kernel: ata4.00: Read log 0x30 page 0x00 failed, Emask 0x40
kernel:ata5.00: ATA Identify Device Log not supported
kernel:ata5.00: ATA Identify Device Log not supported
kernel:kauditd_printk_skb: 54 callbacks suppressed
systemd0modules-load[279]: Failed to find module 'nvidia-uvm'
kernel: kauditd_printk_skb: 53 callbacks suppressed
kernel: r8188eu: module is from the staging directory, the quality is unknown, you have been warned. 
kernel: kauditd_printk_skb: 4 callbacks suppressed
kernel:kauditd_printk_skb: 4 callbacks suppressed
NetworkManager[777]: <warn> [1695175879.8427] device (w1p0sZ0f0u13): set-hw-addr: new MAC address ZZ: D3:5C:CE:A3:FZ not successfully set (scanning)
kernel: overlayfs: missing 'lowerdir'
kernel:kauditd_printk_skb: 123 callbacks suppressed
sddm[8112]: Signal received: SIGTERM
kernel: kauditd_printk_skb: 6 callbacks supprssed

Any help deciphering what this means would be greatly appreciated.