Black Screen Issues with KDE Plasma after Windows Update

Hey All,

I having some issues with booting Manjaro up after my Windows 10 updated. I am able to go the GRUB commandline, but that is about it. As soon as I try to access Manjaro normally it seems as though my computer freezes, and I am unable to access anything anymore. How can I fix this issue? I have tried looking at similar threads thinking that they would provide some insight, but to no avail. I have tried using the commnad startx but that didn’t work.

I would greatly appreciate any kind of assistance on this.

As far as i know, the only thing Windows messes systematically on quarterly/yearly update, is the ESP and the boot entries. But in that case you should just have booted directly into win… well, you can try reinstalling grub, if it does not help it will not hurt.
GRUB/Restore the GRUB Bootloader - Manjaro

Hey Teo!

Thanks for responding! I do have a question here and I feel a bit silly for asking, but does reinstalling GRUB delete any the data on the partition by chance?

Not unless the target already exists
(if you are installing grub to a mountpoint where it already exists … installing there again will overwrite/update existing grub files … but nothing else)

Sorry I’m being really dense today, but what do you mean by target? Also would it be possible to expand upon what a mountpoint is? Its been awhile since I’ve used Manjaro and I would really like to use it again.

target - the destination of installed files
mount point - the point in the filesystem where something is mounted (ex: /boot/efi , etc)

all I was trying to say is the only thing grub will overwrite is itself.
(which would not be a concern because you are trying to reinstall grub)

Your Windows update didn’t do that.

So by reinstalling the GRUB you’re saying I will be able access all of my old files on Manjaro, correct? If so that is fantastic news! Is there way to do so without accessing a terminal or maybe I am not finding it? Where would the terminal be at? All Im seeing is access to Manjaro, to windows, and an advanced setting, GRUB commandline, but I’m not seeing a terminal. Any help with that?

You have to read the links…in the manjaro live session started from usb

Okay, I will check back with you to see if this will work.

Okay, so I have tried to get into the kernal to no avail, what can I do now? Whenever I try to do so the screen freezes at the loading screen. Any suggestions?

Trying to boot another kernel for example.
Generally, Windows, and GRUB, and broken kernel, have little to do with each other. So maybe i don’t understand the exact problem and you have to provide more information what have you done, what do you see etc.

So I have managed to get into the TTY using


whenever I typed in the command of:

sudo-pacman mirrors -f3

I would get the response back like :

-bash: sudo-pacman: command not found 

And then I tried using the command


and got the response to something that looks like this:

X.Org X Server
X Protocol Version 11, Revision 0
Current Operating System: Linux xxxxxxx-systemproductname 5.10.123-1-MANJARO #1 SMP PREEMPT Thu Jun 16 12:34:16 UTC 2022 x86_64
Kernal command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=91380c74-af96-4052-83e2-d1865778193e rw quiet apparmor = 1 security=apparmor udev.log_priority=3

Current version of pixman: 0.40.0
Before reporting problem, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 5 04:10:46 2023
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory: "/etc/X11/xorg.conf.d"
r help. (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information. (EE) (EE) Server terminated with 
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Any help or ideas on what to do what be incredibly helpful! Thank you everybody so far for your assistance!

sudo-pacman mirrors -f3

Is false, it should be

sudo pacman-mirrors -f3
1 Like

Just tried

sudo pacman-mirrors - f3

They are saying:

sudo: pacman-mirror: command not found

Okay, that prior response was a mistake and that was on me! I just got a huge list of countries.

Seems like a silly question but since I’m from the U.S. I would choose the mirror that corresponds to that one correct?

Hey Omano!

Thank you for showing me this link! But would anyone happen to know the command to update the mirror that is in the U.S is on by chance? I don’t want to cause any drama by downloading the wrong mirror

sudo pacman-mirrors --country United_States

And BTW, the whole point of the </> tag is copy button at the right in the box. And then middleclick or three finger tap to paste in terminal