Black Screen Issue with Manjaro KDE Plasma on Wayland

Hello Manjaro Community,

I recently performed a fresh installation of Manjaro KDE Plasma and encountered an issue when running it on Wayland. After booting, only the Manjaro Hello window appears, and the rest of the screen remains black. In contrast, everything appears to function correctly under X11.

I have tried several troubleshooting steps:

  • I used chroot to re-sync and reinstall the system.
  • I also verified the ISO file’s hash to ensure there were no issues with the installation media.

My system uses an AMD 5950X processor with an RTX 4090 GPU. I apologize for the lack of detailed logs; I am unsure if the logs obtained under X11 would be helpful for diagnosing this Wayland issue.

Any guidance or suggestions would be greatly appreciated as I navigate this problem.

Thanks a lot.

Hi @AidenW, and welcome!

You are trying to use Nvidia, KDE, and Wayland? Man! You are brave indeed!

Wayland combined with Nvidia is a known problem-generator. There is a fix or fixes in the works, but it’s just that: in the works. On the way to us plebs.

In contrast, as you mentioned, X11 does not have these issues. I am testing it out daily, myself, and I suggest you stick with X11. For now, at least.

What I have read here about the combination of wayland and Nvidia cards is that they are not a good mix.
There are quite a few posts here discussing such issues.
I’d use what works - and I can’t help to troubleshoot because I only run Plasma in a VM with a virtualized GPU.
Sorry for the not helpful noise.

Well, one major reason is that I use a 4K display and require 200% scaling for comfortable usage. While X11 is generally stable, I’ve encountered various minor but annoying issues with scaling on it. These issues range from blurry fonts to inconsistent UI elements makes me annoying.

nvm. for me personally, I like gnome more but today i dont know why suddenly I just want to try KDE. GNOME works well with nvidia in Wayland.

Possibly related plymouth and possibly the lack of kms configuration.

Nvidia is known for the trouble it creates for rolling releases based on Arch Linux.

Along with Plasma 6 - the Nvidia issue is among the reasons stable branch has not been updated since mid March 2024.

But a lot of boxes has been ticked and the team are planning for a snap first thing next week.

Thanks a lot, maybe I should switch to the unstable branch?

Or just testing :slight_smile: but yes - you could do that.

See → Black Screen with Plymouth - Cause and Solution

1 Like

LOL, litterally just had the same issue after switching to testing, with NVIDIA 3060 and KDE plasma 6 wayland.

Found a solution quickly, as X11 was still working fine…:

I created a new file at /etc/modprobe.d/nvidia.conf, and put the following lines inside:

options nvidia_drm modeset=1
options nvidia_drm fbdev=1

Archlinux forum “[SOLVED] Plasma 6 Wayland+Nvidia black screen and mouse cursor only”, post 3, further references in that thread. Hope it helps :slight_smile:

1 Like