Black screen, frozen after installing nvidia drivers

Hi hi,

I just received a zotac magnus mini computer (not a laptop) with a nvidia 3080 and installed Manjaro with i3wm on it (btrfs, luks). I enjoyed it for a few minutes until I installed the nvidia drivers. Now it boots to a black screen and pressing ctrl+alt+F2 does nothing.

I tried setting ibt=off in the grub options (based on the arch wiki) but it did not help.

Then I booted from the USB stick and did

$ sudo cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive
Key slot 0 unlocked.
$ sudo mount /dev/mapper/cryptDrive /mnt
$ sudo manjaro-chroot /mnt
mount: /mnt/proc: mount point does not exist.

I don’t know how to make manjaro-chroot work, nor what should be the next steps when that works (maybe change the kernel version?).

Could someone give me a hand? :raised_hand: :slight_smile:

sudo manjaro-chroot /mnt /bin/bash


Thank you. It returns the same error about /mnt/proc.

These files are shown in /mnt.

$ ls /mnt
@/ @cache/ @home/ @log/ @swap/

All right… then it is btrfs…

 sudo mount -o subvol=@ /dev/mapper/cryptDrive /mnt

No idea where the other subvolumes are mounted into the root directory. /etc/fstab should reveal it.

1 Like

Success! :slight_smile:

That way of calling mount makes manjaro-chroot work.

Then I just updated via pacman and it seems something released in the last few days fixed it (linux and nvidia related). Now I can enjoy my new computer :slight_smile:

Thank you very much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.