Black Screen Desktop on Login

Hello there , I might have goofed up a bit.
I accidentally killed the desktop process yesterday while Manjaro was shutting down (I am an idiot).
Well , the results came about today morning when I booted up Manjaro.

On login , the desktop is black and unresponsive (no options come even on right clicking the desktop) , I did not update or anything , everything was fine until I did the killing yesterday. I am able to access everything , no problem , its just the desktop. Its possible I might have corrupted some driver or something. I tried a few things that I found by searching.

  1. Tried sudo pacman -Syyu to update the packages .
    It said there was nothing to do.
    Still rebooted , nothing.

  2. Tried TimeShift to restore yesterday’s backup to see if it might work , it didn’t . It still boots up to the black screen.

  3. Tried to use startx in console , it said this .
    xinit : connection to X server lost
    even though I am connected to the internet.

  4. Tried to change the desktop image , didn’t work.

  5. Output of the command sudo journalctl -p 3 -xb

BIOS Error (bug): Failure creating named object [\_SB.PCI0.LPCB.BTNS._HRV] ,  AE_ALREADY_EXISTS (20200717/dswload2-326)
 Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200717/psobject-220)
crb MSFT0101:00: can't request region for resource [mem 0x9cf6e000-0x9cf6e02f]
  1. Entering and exiting TTY2 console didn’t fix it.

Here the basic information of my system.

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=882db191-d1a6-4a88-a851-8252e191a3a2 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: N/A wm: xfwm4 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
  base: Arch Linux 
  Type: Convertible System: FUJITSU product: LIFEBOOK P728 v: N/A 
  serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: FUJITSU model: FJNB2B3 v: G2 serial: <filter> UEFI: FUJITSU // Insyde 
  v: Version 1.10 date: 09/12/2018 
  ID-1: CMB1 charge: 23.5 Wh (59.0%) condition: 39.8/45.0 Wh (88.4%) 
  volts: 11.1 min: 10.8 model: Fujitsu CP734929-01 type: Li-ion 
  serial: <filter> status: Discharging cycles: 216 
  RAM: total: 7.61 GiB used: 2.75 GiB (36.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: E0 cache: L2: 6 MiB bogomips: 28808 
  Speed: 1500 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 1500 2: 1500 
  3: 1500 4: 1500 5: 1500 6: 1500 7: 1500 8: 1500 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Fujitsu Limited. driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
  Device-2: Chicony FJ Camera type: USB driver: uvcvideo bus-ID: 1-10:6 
  chip-ID: 04f2:b564 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 124 size: 280x160mm (11.0x6.3") 
  diag: 322mm (12.7") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.1 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Fujitsu Limited. 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.24 running: no 
  Device-1: Intel Ethernet I219-LM vendor: Fujitsu Limited. driver: e1000e 
  v: kernel port: 3040 bus-ID: 00:1f.6 chip-ID: 8086:15d7 class-ID: 0200 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel modules: wl 
  port: 3040 bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: pan1 state: down mac: <filter> 
  IP v4: <filter> scope: global 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-7:4 chip-ID: 8087:0a2b class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Message: No LVM data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 238.47 GiB used: 118.15 GiB (49.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD8SN8U-256G-1016 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 2016 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw-size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 118.15 GiB (50.6%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 882db191-d1a6-4a88-a851-8252e191a3a2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 304 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: F4F8-68D5 
  ID-3: /run/timeshift/backup raw-size: 238.17 GiB size: <superuser required> 
  used: <superuser required> fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 882db191-d1a6-4a88-a851-8252e191a3a2 
  Alert: No Swap data was found. 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Dell Dell MS116 Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 413c:301a class-ID: 0301 
  Device-2: 1-5:3 info: Validity Sensors Swipe Fingerprint Sensor 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 138a:0050 class-ID: ff00 serial: <filter> 
  Device-3: 1-7:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2b class-ID: e001 
  Device-4: 1-8:5 info: Wacom Pen and multitouch sensor type: HID 
  driver: usbhid,wacom interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 400mA 
  chip-ID: 056a:50a9 class-ID: 0300 
  Device-5: 1-10:6 info: Chicony FJ Camera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b564 
  class-ID: 0e02 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 246 Uptime: 56m wakeups: 5 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1311 pacman: 1300 lib: 428 
  flatpak: 0 snap: 11 Shell: Bash v: 5.1.0 running-in: xfce4-terminal 
  inxi: 3.3.03 

I would try:
Remove $HOME/.cache/sessions and logoff/on.

If still black, I’d try:
xfdesktop --replace


Thank you @stargazer !

xfdesktop --replace solved it .

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.