Black screen boot after update (Failed to find module ‘nvidia-nvm’)

Hi, I know this is not the first time this topic has been brought up, but I couldn’t find the solutions in my case. I have updated some graphic drivers (nvidia) which required a restart, after the boot I’ve got just the black screen, nothing is written. I’ve tried the lighdm things but it didn’t work. I’ve tried the full system upgrade (-Syyu) but nothing out of it as well. I don’t remember exactly what I did but I tried to remove my graphics driver and reinstall it.
Here is my “journalctl -p 3 -xb” output:
(it didn’t let me to put an image, so i will write it)

kernel: x86/cpu: SGX disabled by BIOS.
systemd-modules-load[259]: Failed to find module ‘nvidia-nvm’
kernel: Bluetooth: hci0: Reading supported features failed (–16)
systemd[1]: Failed to start Light Display Manager.

and the green lines

Subject: A start job for unit has failed
Defined-By: systemd
Support: forum.manjaro

A start job for unit lightdm.service had finished with a failure.

The job identifier is 1632 and the job result is finished.

I tried to fix them by googling the errors but the I don’t think they are facing the same problem with me, so I’ve decided to write it out to you. thanks in advance.

Hello @superkiyam,

your profile said:

Did you switch kernel to another one before? Because 5.13 is not supported anymore, and there are also no nvidia drivers for this kernel available.

Also to help you more we need more information about your system.
Can you provide the output from these commands:

inxi -Fxxza 
mhwd -li
mhwd -l
1 Like

yes, sorry I forgot to mention. I have upgraded my kernel while I was looking for a solution. somehow this site doesn’t let me embed media items. If I can figure that out, i will share the outputs gladly.

Ok, perhaps this post will help you to share outputs without ‘sharing media items’.

I found the problem, since I am tl1 (new user) in this forum, I can’t embed a media, I can’t write all the output, neither I can use the sharing methods you mentioned because I can’t log into my pc. so what should I do?

Did you try to press

ctrl + alt + F2

to enter tty?

If tty dont work I guess you have to use a live system and chroot your installation. :neutral_face:

There is also a ‘howto’ for such problems: